SabNZB Errno 99 - No socket could be created - Won't launch (Unraid)

Report & discuss bugs found in SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
whitlockitup
Newbie
Newbie
Posts: 1
Joined: March 20th, 2020, 3:12 pm

SabNZB Errno 99 - No socket could be created - Won't launch (Unraid)

Post by whitlockitup »

Hello,

I was getting an errno 99 code when trying to connect to my usenet servers and found a post saying to turn off Ipv6. So I did that. Now unraid will not launch my Sab docker at all and I am getting the same erno99 code.

It's not letting me post the code because i cant post links as a new user? But here's the errors

2020-03-20 13:41:16,168::ERROR::[_cplogging:219] [20/Mar/2020:13:41:16] ENGINE Error in HTTP server: shutting down
Traceback (most recent call last):
File "/opt/sabnzbd/cherrypy/process/servers py", line 207, in _start_http_thread
self.httpserver.start()
File "/opt/sabnzbd/cherrypy/wsgiserver/__init__ py", line 2012, in start
raise socket.error(msg)

error: No socket could be created -- (('::1', 8090, 0, 0): [Errno 99] Cannot assign requested address)


I honestly am at a loss at this point and not sure what I need to do because I cant get back into the gui to access the sab settings to turn back on ipv6. Is there some command i can type in the config that will let me back into the gui and get everything working again? Any help would be greatly appreciated!!

User avatar
sander
Release Testers
Release Testers
Posts: 6977
Joined: January 22nd, 2008, 2:22 pm

Re: SabNZB Errno 99 - No socket could be created - Won't launch (Unraid)

Post by sander »


Post Reply