Cant set admin path in 3.1.0

Report & discuss bugs found in SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
sabster
Newbie
Newbie
Posts: 2
Joined: October 20th, 2020, 4:05 am

Cant set admin path in 3.1.0

Post by sabster »

Hey everyone,

i updated my sabnzbd from an older 2.x to the latest stable 3.1.0 through the available setup file ( SABnzbd-3.1.0-win-setup.exe ) on a win10 host. Since this is done, i have problems when using custom paths.

I am using custom paths/folders for admin files (also custom paths for downloads, nzb files, backup files and so one), which means the admin_dir= value is not "admin", but a absolute path which is exactly 57 chars long (without .ini file).

At every program start, sabnzbd 3.1.0 is reseting admin_dir= from *absolute path value* to "admin", so i can not use my custom path anymore.

I tried to set the admin path directly in sabnzbd.ini with an editor and also through the settings dialoge in the webinterface, but its not possible to get 3.1.0 working with (long?) custom paths anymore.

When i try to edit the path through the webinterface, a error dialog-box appears, which says: "Error: Pathlength should be shorter than 60 chars." (the original error msg in german: "Fehler: Dateipfadlänge sollte kürzer als 60 sein."). Remember: In my case, the path is 57chars long. This error message also appears, when i try to edit other folders, like "monitoring-path", which is 58 chars long.

Would be nice to see this issue fixed.



Oh and by the way a little feature request:

Can you guys make it possible to additionally / optional change the location of sabnzbd.ini?

For example to store the ini file in the programms folder (if ini is in program folder, load this, else the one in userprofile folder)
OR/AND
in an alternative folder by setting the sabnzbd.ini-path with a program-switch like: C:\Program Files\SABnzbd\SABnzbd.exe -ini "d:\sabnzbd\sabnzbd.ini".

Its a bit annoying that its possible to edit nearly every path, but not the path of the main config file.

User avatar
safihre
Administrator
Administrator
Posts: 3979
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Cant set admin path in 3.1.0

Post by safihre »

Sounds indeed like a bug.
Could you share the full paths you are trying to set? Then I can try to reproduce more easily.
In SABnzbd 3.2.0 the whole 60 chars limit will be removed, but it should not break on 3.1.0.

You can already specifiy the sabnzbd.ini location through the command line:
https://sabnzbd.org/wiki/advanced/comma ... parameters
This also changes the base-directory for the admin-files etc, they will then be relative (if no absolute path) is set to the folder of the sabnzbd.ini
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

sabster
Newbie
Newbie
Posts: 2
Joined: October 20th, 2020, 4:05 am

Re: Cant set admin path in 3.1.0

Post by sabster »

Thanks for the hint. :-) Will try the parameters.

These are the full paths from the .ini file:
admin_dir = C:\Data\Profiles\SabNZBD\_Programfiles\SABNZBD_Adminfiles
dirscan_dir = D:\Downloads\UN_sabnzb\_Programfiles\NZB-Files\Monitoring

Dont know if this issue affects download_dir=, complete_dir= with custom values or any dir= from the [categories] section.

Is there a chance to see a quick fix or should i downgrade till 3.2.0 is released?

User avatar
safihre
Administrator
Administrator
Posts: 3979
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Cant set admin path in 3.1.0

Post by safihre »

Ah, I found the problem.
We now use long-path notation, which adds an extra \\?\ to the path.
Only admin_dir is affected in your case.
The workaround would be for now to start SABnzbd with the extra parameter:

Code: Select all

-f C:\Data\Profiles\SabNZBD\_Programfiles\SABNZBD_Adminfiles\sabnzbd.ini
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

Post Reply