Folder Issue since upgrading to 3.4.1

Report & discuss bugs found in SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
312BhP
Newbie
Newbie
Posts: 4
Joined: October 6th, 2021, 11:04 am

Re: Folder Issue since upgrading to 3.4.1

Post by 312BhP »

I do have one selected for each, tv for TV Sorting and movies for Movie Sorting, the Date Sorting one at the bottom is not enabled.

User avatar
safihre
Administrator
Administrator
Posts: 4470
Joined: April 30th, 2015, 7:35 am
Contact:

Re: Folder Issue since upgrading to 3.4.1

Post by safihre »

Additionally there's also a bug that requires you to use the %fn and %ext variables. Did you do that?
We're working on that one.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

312BhP
Newbie
Newbie
Posts: 4
Joined: October 6th, 2021, 11:04 am

Re: Folder Issue since upgrading to 3.4.1

Post by 312BhP »

I don't have %fn in there but I do have %ext

TV
%sn/Season %s/%sn - S%0sE%0e.%ext

Movies
%title %y %r %GI<audio_codec>.%ext

Honestly, the movie one isn't tested as I cleared what I had in there and couldn't remember what it was!

Jobber
Newbie
Newbie
Posts: 3
Joined: October 4th, 2021, 9:13 pm

Re: Folder Issue since upgrading to 3.4.1

Post by Jobber »

Clicking "Default" under Series Sorting, Affected Categories and then saving the changes does seem to have got it working as intended. Thank you.

312BhP
Newbie
Newbie
Posts: 4
Joined: October 6th, 2021, 11:04 am

Re: Folder Issue since upgrading to 3.4.1

Post by 312BhP »

Jobber wrote:
October 6th, 2021, 4:58 pm
Clicking "Default" under Series Sorting, Affected Categories and then saving the changes does seem to have got it working as intended. Thank you.
Is that default and the category, "default" and "tv" for example?

EDIT: I can also confirm if default and tv or default and movie are both selected the sorting function does work as expected (Using 3.4.2 RC2 at least).

spec119
Newbie
Newbie
Posts: 13
Joined: May 28th, 2020, 10:01 am

Re: Folder Issue since upgrading to 3.4.1

Post by spec119 »

I have been struggling with this issue and I have gone over the settings in categories and sorting and everything is set correctly and the same settings are working fine on an older 3.3.1 installation
The only way I can get this to work is either import an nzb file and specify a category or I need to put sabnzb in pause mode then change the category from default to tv then let it resume previously this was done seamlessly without any of this extra process

silverthunderbird
Newbie
Newbie
Posts: 10
Joined: September 30th, 2021, 10:33 am

Re: Folder Issue since upgrading to 3.4.1

Post by silverthunderbird »

spec119 wrote:
October 7th, 2021, 5:54 am
I have been struggling with this issue and I have gone over the settings in categories and sorting and everything is set correctly and the same settings are working fine on an older 3.3.1 installation
The only way I can get this to work is either import an nzb file and specify a category or I need to put sabnzb in pause mode then change the category from default to tv then let it resume previously this was done seamlessly without any of this extra process
Here's the two changes I made that fixed my issue. Unfortunately, image uploading in the forum (aside from web sharing) is disabled. :-\
https://imgur.com/a/czjPs0F

However, it appears that the Category setting of "tv" is unneccesary.

spec119
Newbie
Newbie
Posts: 13
Joined: May 28th, 2020, 10:01 am

Re: Folder Issue since upgrading to 3.4.1

Post by spec119 »

silverthunderbird wrote:
October 7th, 2021, 7:39 am
spec119 wrote:
October 7th, 2021, 5:54 am
I have been struggling with this issue and I have gone over the settings in categories and sorting and everything is set correctly and the same settings are working fine on an older 3.3.1 installation
The only way I can get this to work is either import an nzb file and specify a category or I need to put sabnzb in pause mode then change the category from default to tv then let it resume previously this was done seamlessly without any of this extra process
Here's the two changes I made that fixed my issue. Unfortunately, image uploading in the forum (aside from web sharing) is disabled. :-\
https://imgur.com/a/czjPs0F

However, it appears that the Category setting of "tv" is unneccesary.
Great worked for me thanks for your valuable input :)

User avatar
safihre
Administrator
Administrator
Posts: 4470
Joined: April 30th, 2015, 7:35 am
Contact:

Re: Folder Issue since upgrading to 3.4.1

Post by safihre »

@spec indeed, you need to select all categories for it to work like before.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

User avatar
safihre
Administrator
Administrator
Posts: 4470
Joined: April 30th, 2015, 7:35 am
Contact:

Re: Folder Issue since upgrading to 3.4.1

Post by safihre »

I have finally fixed the problem that not using %ext and/or %fn would not work anymore.
@zion2k: your setup should work again!
You can download 3.4.2RC3 with the fix here (in a few minutes):
https://sabnzbd.org/downloads
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

squiggles
Newbie
Newbie
Posts: 4
Joined: October 9th, 2021, 6:06 am

Re: Folder Issue since upgrading to 3.4.1

Post by squiggles »

Hi,

The system seems to think anything with a forward slash is a link and new users can't post links, so I had to remove my examples (no real release names) and try to describe.

I'm replying in this thread since my issue appears to be driven by the same sorting engine process just used a little more simply.

In my configuration I'm using the Movie Sorter to set the final name of the file to be %dn.%ext. This use to result in the output file using the NZB name exactly with the extension of the file set correctly in my target directory.

Since upgrading to 3.4.1 (and since then 3.4.2RC3) on my Linux system it is resulting in a directory being created using the name of the release name with the scrambled name mkv inside.

I've tried unticking the 'Keep loose downloads in extra folders' and I do have the affected categories set. I tried changing to %fn.%ext with no luck.

With my title in the test data field and %dn.%ext set it displays what it *should* result in (exactly what I'm looking for), and if I change my sort string to %r/%dn.%ext just a test it updates to what I expect with a directory of resolution and proper file name one level below it. When it actually downloads it doesn't create the resolution folder and repeats the release directory with scrambled file.

Is something still playing up in 3.4.2RC3?

Just dropped back to 3.3.1 as a test and verified that %r/%dn.%ext results in the resolution folder and properly named release directly under it.

%dn.%ext results in the properly named file in my target directory.

Thanks,

Squigs

User avatar
safihre
Administrator
Administrator
Posts: 4470
Joined: April 30th, 2015, 7:35 am
Contact:

Re: Folder Issue since upgrading to 3.4.1

Post by safihre »

Just to be sure, is the category the download is when it's downloading active in Affected Categories in the Movie sorting settings?
You can switch logging to Debug in the Status window and then (using 3.4.2RC3) repeat the download using your 3.3.1 settings. After that, click Show Logging in the Status window and send me the logs at [email protected]. I will see what is going wrong.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

squiggles
Newbie
Newbie
Posts: 4
Joined: October 9th, 2021, 6:06 am

Re: Folder Issue since upgrading to 3.4.1

Post by squiggles »

Hi,

Can confirm that the 'Affected Categories' is set under the Movie Sorting section on the Sorting tab. When adding the NZB the same category is selected before clicking Add. (confirmed working on 3.3.1).

Debug logs have been emailed, 3.3.1 and 3.4.2RC3 to compare.

Thanks,

Squigs

User avatar
safihre
Administrator
Administrator
Posts: 4470
Joined: April 30th, 2015, 7:35 am
Contact:

Re: Folder Issue since upgrading to 3.4.1

Post by safihre »

You are using a Movie-sorter on a TV-show. That's not going to work.
Starting 3.4.0 the sorting-parser has become more powerful, but also more strict.
Try enabling the Series Sorting, since you already have the same settings for it. Then it should work.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

squiggles
Newbie
Newbie
Posts: 4
Joined: October 9th, 2021, 6:06 am

Re: Folder Issue since upgrading to 3.4.1

Post by squiggles »

Hi,

Since my renaming requirements were so simple I've never needed to use multiple sorting entries before.

Confirmed that enabling a series and movie sort on the same category will rename movies and series the way I want (%dn.%ext), but games still results in the top level directory and scrambled filename.iso beneath.

Is there any way to "catch all"? I trust my NZB names and want the output single file name to match that across any type of release. Another sorting category for everything else, or force use one of the existing enabled sorts if it doesn't exactly match an existing sort profile?

Thanks,

Squigs

Post Reply