Can sabyenc be made backward-compatible?

Want something added? Ask for it here.
Post Reply
User avatar
OneCD
Full Member
Full Member
Posts: 192
Joined: March 4th, 2017, 3:47 pm

Can sabyenc be made backward-compatible?

Post by OneCD » February 20th, 2018, 4:11 pm

Hello.

From time-to-time sabyenc is updated. Which can cause an error such as this one if using a 'master' branch of SABnzbd: "SABYenc disabled: no correct version found! (Found v3.4.0, expecting v3.3.2)"

This means a manual downgrade of the newer sabyenc:

Code: Select all

pip uninstall -y sabyenc; pip install sabyenc==3.3.2 && /etc/init.d/sabnzbd.sh restart
... until the 'develop' branch becomes the new 'master'.

Is there a way to prevent SABnzbd complaining when it finds a newer version of sabyenc?

Thank you. :)
Stuff I like: Apache BASH CouchPotato CRON Debian DNSMasq Entware-3x FireFox GitHub ImageMagick Kate KDE LibreELEC Netrunner NFS NVIDIA OpenVPN Orvibo S20 Python Raspberry Pi RAID SABnzbd+ SickRage Transmission Usenet VirtualBox WordPress XFCE

User avatar
safihre
Administrator
Administrator
Posts: 2754
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: Can sabyenc be made backward-compatible?

Post by safihre » February 21st, 2018, 8:08 am

In this case they are really not backwards compatible, since 3.4.0 has extra output variables.
It's already the case for minor versions (3.3.1 -> 3.3.2) that there are no errors, but for bigger changes they are just not exchangable.
The publishing of 3.4.0 to PyPi was an accident, I reverted that.

User avatar
OneCD
Full Member
Full Member
Posts: 192
Joined: March 4th, 2017, 3:47 pm

Re: Can sabyenc be made backward-compatible?

Post by OneCD » February 21st, 2018, 8:23 am

Okiedoke, thanks @safihre. ^-^
Stuff I like: Apache BASH CouchPotato CRON Debian DNSMasq Entware-3x FireFox GitHub ImageMagick Kate KDE LibreELEC Netrunner NFS NVIDIA OpenVPN Orvibo S20 Python Raspberry Pi RAID SABnzbd+ SickRage Transmission Usenet VirtualBox WordPress XFCE

Post Reply