SABnzbdX, SABnzbd for OSX gui

Got a program that plays well with SABnzbd? Share it here!
Undisclosedpower
Newbie
Newbie
Posts: 23
Joined: November 12th, 2008, 9:17 pm

Re: SABnzbdX, SABnzbd for OSX gui

Post by Undisclosedpower » November 25th, 2009, 12:04 pm

All of the instances are on my local network. Except one which is on the internet. None of them are local to the machine running sabnzbdx and none of the are API key enabled or have passwords.

Unrelated to this, does SABnzbdx support 0.5 fully yet? I'm noticing some wierd behaviours when connecting to a 0.5 instance.

rAf
Moderator
Moderator
Posts: 746
Joined: April 28th, 2008, 2:35 pm
Location: France
Contact:

Re: SABnzbdX, SABnzbd for OSX gui

Post by rAf » November 25th, 2009, 12:13 pm

No problems with 0.5.x, it works (for me at least)

Undisclosedpower
Newbie
Newbie
Posts: 23
Joined: November 12th, 2008, 9:17 pm

Re: SABnzbdX, SABnzbd for OSX gui

Post by Undisclosedpower » November 25th, 2009, 12:15 pm

Wierd, my 0.5 instance just alternates between being idle and being not started every 10(ish) seconds. It doesn't happen on the same machine on 0.4.12.

rAf
Moderator
Moderator
Posts: 746
Joined: April 28th, 2008, 2:35 pm
Location: France
Contact:

Re: SABnzbdX, SABnzbd for OSX gui

Post by rAf » November 25th, 2009, 12:17 pm

It's just a timeout issue... Could you try to change the refresh interval in preferences and restart SABnzbdX to see if it's better ?

Undisclosedpower
Newbie
Newbie
Posts: 23
Joined: November 12th, 2008, 9:17 pm

Re: SABnzbdX, SABnzbd for OSX gui

Post by Undisclosedpower » November 25th, 2009, 12:27 pm

Even on the highest timeout it still alternates between being idle and not being idle. And only when that machine is running 0.5.

rAf
Moderator
Moderator
Posts: 746
Joined: April 28th, 2008, 2:35 pm
Location: France
Contact:

Re: SABnzbdX, SABnzbd for OSX gui

Post by rAf » November 25th, 2009, 12:45 pm

Thanks for your reports, I'll have to make more tests, but it's not easily reproducible...

wally007
Release Testers
Release Testers
Posts: 179
Joined: August 28th, 2009, 5:24 pm

Re: SABnzbdX, SABnzbd for OSX gui

Post by wally007 » November 28th, 2009, 4:11 am

rAf wrote: Thanks for your reports, I'll have to make more tests, but it's not easily reproducible...
I've set up sabnzbdX to monitor my sabnzbd+ via my external IP ( i take my laptop out a lot so this way i dont have to change IP everytime i'm out of the house ) and its working fine with .5.Beta1. Only feature i'm missing that i get on my sabnzbd+ machine is history , other than that its solid performer. ( my sab machine is running 10.6.2 and my laptop 10.6.2 with sabnzbdX 1.2.4 )

Undisclosedpower
Newbie
Newbie
Posts: 23
Joined: November 12th, 2008, 9:17 pm

Re: SABnzbdX, SABnzbd for OSX gui

Post by Undisclosedpower » November 28th, 2009, 2:19 pm

raf: If you want to test against my install please PM me and I'm sure we can arrange something.

rAf
Moderator
Moderator
Posts: 746
Joined: April 28th, 2008, 2:35 pm
Location: France
Contact:

Re: SABnzbdX, SABnzbd for OSX gui

Post by rAf » November 29th, 2009, 7:31 pm

@wally007 : I'm working on a brand new SABnzbdX, no ETA for now...
@Undisclosepower : Thanks but I'll add a hidden setting that allow you to change timeout value... You're the only one who tested 1.2.6 who reported issue for now...

meshuga
Newbie
Newbie
Posts: 3
Joined: November 11th, 2009, 6:22 pm

Re: SABnzbdX, SABnzbd for OSX gui

Post by meshuga » November 30th, 2009, 11:29 am

raf, I had the exact same timeout issue with 1.2.5 and 5.0beta1. I'd love to try out 1.2.6 if you want.

Thanks!

rAf
Moderator
Moderator
Posts: 746
Joined: April 28th, 2008, 2:35 pm
Location: France
Contact:

Re: SABnzbdX, SABnzbd for OSX gui

Post by rAf » November 30th, 2009, 11:33 am

rAf wrote: Could someone who have issues with 1.2.5 could test this version and tell me if it works ?
@meshuga : see this post :)

rAf
Moderator
Moderator
Posts: 746
Joined: April 28th, 2008, 2:35 pm
Location: France
Contact:

Re: SABnzbdX, SABnzbd for OSX gui

Post by rAf » November 30th, 2009, 9:09 pm

SABnzbdX 1.2.6 released.
See main post for changes.

Some users have issues connecting to SABnzbd with 1.2.5.
I’ve added a hidden option to change http timeout value.
If you have troubles like suddenly it said via growl “not started”, then switched back to “downloading”, try to change timeout value with with command in Terminal :

Code: Select all

defaults write ~/Library/Preferences/org.sabnzbdx.team timeout -int 5
you can change value between 1 and 10 (default value in SABnzbdX 1.2.4 was 5, in 1.2.5 was 1 and in 1.2.6 it’s 2).

Undisclosedpower
Newbie
Newbie
Posts: 23
Joined: November 12th, 2008, 9:17 pm

Re: SABnzbdX, SABnzbd for OSX gui

Post by Undisclosedpower » December 1st, 2009, 8:55 am

Hi rAF,

I've installed 1.2.6 and changed the timeout up to 5 but it still alternates between start and downloading on my 0.5 install :(

Any thougts?

rAf
Moderator
Moderator
Posts: 746
Joined: April 28th, 2008, 2:35 pm
Location: France
Contact:

Re: SABnzbdX, SABnzbd for OSX gui

Post by rAf » December 1st, 2009, 10:32 am

If you use SABnzbd 1.2.4, you don't have any issue ?

Undisclosedpower
Newbie
Newbie
Posts: 23
Joined: November 12th, 2008, 9:17 pm

Re: SABnzbdX, SABnzbd for OSX gui

Post by Undisclosedpower » December 1st, 2009, 1:00 pm

Actually I still do with 1.2.4.

Post Reply