Media Rover

Got a program that plays well with SABnzbd? Share it here!
User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

markus101 wrote: [GoogleCode has a pretty good free wiki + Code Hosting for Git/SVN, I'm hosting my SABScripts there and I know a couple others that have code hosted there, personally I like it more than SourceForge for a number of reasons, but mainly navigation (I find SF to be awkward).
When choosing a hosting solution for Media Rover, I initially looked at Google Code, Launchpad, Gitorious, Sourceforge and a few others.  I can't recall the reasons for choosing GitHub over the other offerings but I haven't regretted that decision.  GitHub does have wiki functionality (which I do make limited use of) but it doesn't seem very comprehensive (feature wise) when compared to other standalone wikis.  I haven't really made much use of the wiki up to this point though.  Does anyone else out there have more extensive experience using the GitHub wikis?

Kierse

thrasherx
Newbie
Newbie
Posts: 1
Joined: December 5th, 2009, 12:16 pm

Re: Media Rover

Post by thrasherx »

Two questions with the config file:

1) Should the api key be wrapped in ?



2)I'm getting the following error:
"File "C:\Python26\mediarover\episode.py", linen 271, in __init__ raise MissingParameterError("mixxing episode series name") mediarover.error.MissingParameterError: missing episode series name

I have my tv shows set up as follows:
X:\TV\%Series_Name%\%Series_Name% - %SS%x%EE% - %Series_Name%.%ext%

My filter section looks like this:

Code: Select all

	[[filter]]
	
			[[[ The Big Bang Theory ]]]

			[[[ Community ]]]
Any help would be appreciated!

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

Hi thrasherx,
thrasherx wrote: 1) Should the api key be wrapped in ?
No, have a look at http://wiki.github.com/kierse/mediarover/config-example for an example of a complete (working) config file.  A few people have found those confusing, I'll remove them from the default config file.
thrasherx wrote: 2)I'm getting the following error:
"File "C:\Python26\mediarover\episode.py", linen 271, in __init__ raise MissingParameterError("mixxing episode series name") mediarover.error.MissingParameterError: missing episode series name
Hmmm, this error could be happening for several reasons, can you post your config file and the log data from a full run of Media Rover?
thrasherx wrote: I have my tv shows set up as follows:
X:\TV\%Series_Name%\%Series_Name% - %SS%x%EE% - %Series_Name%.%ext%
This will cause you some problems.  Media Rover expects your episodes to be organized by season, like so:

Code: Select all

    series A/
        season 01/
            episode 1
            episode 2
            ...
            episode N
        season 02/
        ...
        season N/
thrasherx wrote: My filter section looks like this:

Code: Select all

	[[filter]]
	
			[[[ The Big Bang Theory ]]]

			[[[ Community ]]]
Any help would be appreciated!
This looks good.

I would suggest updating your file structure to include season numbers (for daily shows, use the broadcast year) and trying Media Rover again.  The error you posted above could definitely be resulting from the unexpected file structure.  If that doesn't fix your problem, post your config and log somewhere and let me know.

Kierse

User avatar
clambert
Newbie
Newbie
Posts: 26
Joined: November 23rd, 2009, 9:47 pm
Location: East Coast USA
Contact:

Re: Media Rover

Post by clambert »

Ok, I'm a total noob when it comes to Python.  Any input to get me going would help.  I'm getting the following error right out of the gate when trying to generate the config file.

Pertinent Info:
Windows 7 - 64 Bit
Python 3.1

Just looking to create the config data in the default location.  I'm running the command from a command window.  I modified the path of the environmental variables to include Python.

Here is what I get when I run the command:
E:\[Media Rover]>python mediarover.py --write-configs
Traceback (most recent call last):
  File "mediarover.py", line 17, in
    import mediarover
  File "E:\[Media Rover]\mediarover\__init__.py", line 98
    except Exception, e:
                            ^
SyntaxError: invalid syntax
What am I missing?

Thanks in advance for any help.

-- Craig

krogaw
Release Testers
Release Testers
Posts: 5
Joined: November 21st, 2009, 6:59 pm

Re: Media Rover

Post by krogaw »

clambert wrote: Ok, I'm a total noob when it comes to Python.  Any input to get me going would help.  I'm getting the following error right out of the gate when trying to generate the config file.

Pertinent Info:
Windows 7 - 64 Bit
Python 3.1
Use Python 2.6.4

Python 3.x broke backwards compatiblity and MR is written for 2.5+

User avatar
clambert
Newbie
Newbie
Posts: 26
Joined: November 23rd, 2009, 9:47 pm
Location: East Coast USA
Contact:

Re: Media Rover

Post by clambert »

krogaw wrote: Use Python 2.6.4

Python 3.x broke backwards compatiblity and MR is written for 2.5+
That did it thanks.  I'm sure I'l have more questions as I play with it.  Thanks for getting me on the right path however.  :)

bnevets27
Release Testers
Release Testers
Posts: 58
Joined: February 17th, 2009, 5:03 pm

Re: Media Rover

Post by bnevets27 »

Just got mediarover working. It was actually a lot easier for the most part then I thought it would be. I like how the config file is setup. A GUI will be nice for new users setting up the program.

I can't get the episode sorting to work though. I get this:

Code: Select all

D:\Program Files\SABnzbd 5>D:\Python26\pythonw.exe D:\Program Files\mediarover\episodesort.py -c "D:\Documents and Settings\XXXX\Application Data\Mediarover" "I:\Downloads\Newsgroups\SABnzbd\Completed\TV\30.Rock.S0XE0X.HDTV" 30.Rock.S0XE0X.HDTV 30.Rock.S0XE0X.HDTV "" tv alt.XXXX.XXXX 
D:\Python26\pythonw.exe: can't open file 'D:\Program': [Errno 2] No such file or directory
(I had to edit that a bit for form rules, I hope its ok now)


You might want to add tbn,jpg,info to the default ignored extensions, XBMC stuff. Not hard to just add myself but looks like you are trying to cover everything.

Looks like there's a error in the config file it has the wrong name for nzbs.org under sources. The config file by default makes it [[nzbs.org]] should be [[nzbs]]

Not sure if this is a bug in mediarover or sabnzbd or if I have something configured wrong but sabnzbd keeps getting this authentication error:

Code: Select all

WARNING:
Authentication missing, please enter username/password from Config->General into your 3rd party program:
The nzb's do get added without issue. It seems that the warning comes after an nzb is added for the first time. Then anytime mediarover is run after that I get the error again. I don't get the error when mediarover is run before a nzb has ever been added.

Is there a way at this time that allows you to specify SD or HD per show?

rollingeyeball
Release Testers
Release Testers
Posts: 183
Joined: January 30th, 2009, 12:26 pm

Re: Media Rover

Post by rollingeyeball »

Hey bnevets27. I hope i can help you a bit.

I can't get the episode sorting to work though. I get this:
Surround the path to episodesort.py with double quotes.

Code: Select all

D:\Python26\pythonw.exe "D:\Program Files\mediarover\episodesort.py"
It's do do with the space in 'program files'


Not sure if this is a bug in mediarover or sabnzbd or if I have something configured wrong but sabnzbd keeps getting this authentication error:
Code:

WARNING:
Authentication missing, please enter username/password from Config->General into your 3rd party program:

The nzb's do get added without issue. It seems that the warning comes after an nzb is added for the first time. Then anytime mediarover is run after that I get the error again. I don't get the error when mediarover is run before a nzb has ever been added.
I also have this 'issue'. I thought it was to do with nzbdstatus and I thought it was my fault.
Like you said though, everything works.


Is there a way at this time that allows you to specify SD or HD per show?
At the moment that totally relies on your rss feed.

Yes with newzbin
Yes with nzbs, I believe.
And I can't think of any other sources at the moment =/
If you can't specify a min or max size or a particular 'category' in your rss feed then no.

User avatar
clambert
Newbie
Newbie
Posts: 26
Joined: November 23rd, 2009, 9:47 pm
Location: East Coast USA
Contact:

Re: Media Rover

Post by clambert »

Quick question...

If a proper is released for a show, does Media Rover allow the download off the bat?  Is it something you need to configure?  Or does it just get ignored all together?

I'm guessing MR probably handles it natively.

Thanks.

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

bnevets27 wrote: I can't get the episode sorting to work though. I get this:

Code: Select all

D:\Program Files\SABnzbd 5>D:\Python26\pythonw.exe D:\Program Files\mediarover\episodesort.py -c "D:\Documents and Settings\XXXX\Application Data\Mediarover" "I:\Downloads\Newsgroups\SABnzbd\Completed\TV\30.Rock.S0XE0X.HDTV" 30.Rock.S0XE0X.HDTV 30.Rock.S0XE0X.HDTV "" tv alt.XXXX.XXXX 
D:\Python26\pythonw.exe: can't open file 'D:\Program': [Errno 2] No such file or directory
(I had to edit that a bit for form rules, I hope its ok now)
Have you tried using the windows shell boot script?  There is an example script in the scripts/ directory called sabnzbd_episode_sort.bat.example.  It's been tested against all recent versions of Windows (XP, Vista, and 7)
bnevets27 wrote: You might want to add tbn,jpg,info to the default ignored extensions, XBMC stuff. Not hard to just add myself but looks like you are trying to cover everything.
Done
bnevets27 wrote: Looks like there's a error in the config file it has the wrong name for nzbs.org under sources. The config file by default makes it [[nzbs.org]] should be [[nzbs]]
I can't verify this one.  I regenerated the configs on Linux and Windows and the nzbs subsection was properly created.  Is this repeatable or was it just a fluke of nature?
bnevets27 wrote: Not sure if this is a bug in mediarover or sabnzbd or if I have something configured wrong but sabnzbd keeps getting this authentication error:

Code: Select all

WARNING:
Authentication missing, please enter username/password from Config->General into your 3rd party program:
The nzb's do get added without issue. It seems that the warning comes after an nzb is added for the first time. Then anytime mediarover is run after that I get the error again. I don't get the error when mediarover is run before a nzb has ever been added.
Hmmm, I went through the SABnzbd logs on my server but wasn't able to find the "Authentication missing" warning.  You (and rollingeyeball I think) are running Windows whereas I'm running Linux, I suppose that might have something to do with it.  Do me a favour: can you turn on authentication in SABnzbd and set the username/password in Media Rover and see if the warning goes away?  Maybe I just need to pass empty parameters when connecting even if authentication is off.
bnevets27 wrote: Is there a way at this time that allows you to specify SD or HD per show?
Not yet.  As rollingeyeball mentioned, you can control what MR finds by building a custom RSS feed.  I hope to introduce this functionality in the future

Kierse

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

clambert wrote: Quick question...

If a proper is released for a show, does Media Rover allow the download off the bat?  Is it something you need to configure?  Or does it just get ignored all together?

I'm guessing MR probably handles it natively.

Thanks.
Hey Clambert,

Media Rover doesn't care if its a proper release or not.  Currently, it just schedules the first nzb it comes across that represents a missing episode on disk.  That would be an interesting feature to add in the future though.  I don't know how I would determine if an nzb represents a proper release vs a regular release as I don't think any of the RSS sources include that sort of data.  The only thing I can think that might work would be parsing the actual episode filename for "PROPER".  Something to consider for sure

Kierse

rollingeyeball
Release Testers
Release Testers
Posts: 183
Joined: January 30th, 2009, 12:26 pm

Re: Media Rover

Post by rollingeyeball »

You (and rollingeyeball I think) are running Windows whereas I'm running Linux, I suppose that might have something to do with it.  Do me a favour: can you turn on authentication in SABnzbd and set the username/password in Media Rover and see if the warning goes away?  Maybe I just need to pass empty parameters when connecting even if authentication is off.
I'm also running Windows, yep. I do have authentication.

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

rollingeyeball wrote: I'm also running Windows, yep. I do have authentication.
And you still see those "Authentication missing" warnings, hmmm.  What version of SABnzbd are you running?

rollingeyeball
Release Testers
Release Testers
Posts: 183
Joined: January 30th, 2009, 12:26 pm

Re: Media Rover

Post by rollingeyeball »

*cough 0.5a9
*another cough Windows XP is it means anything

I just manually ran Media Rover then and it definitely is MR that's causing the warnings. It may well be a sab issue though, occurring whenever something uses API.
I ought to update to beta 3 anyway so I'll do that today and get back to you

pilGrim
Full Member
Full Member
Posts: 116
Joined: January 9th, 2009, 7:28 pm
Location: Hong Kong, SAR China

Re: Media Rover

Post by pilGrim »

Hi All,

A few questions on the sort script:

Show in question: Brothers & Sisters

File structure on drive: Brothers & Sisters (must name this way to have media management program scrapers pick up info from thetvdb.com)

normal upload name: Brothers and Sisters

Using aliases the show is caught and queued for download

Problem:
SABnzbd folder sorting would always create a naming / file structure under: Brothers and Sisters, I would then have to go in and manually move and rename files to "Brothers & Sisters"

Mediarover Script: picks up file due to alias but does not seem to use Alias name in the sorting script?  I am getting a folder naming convention of "Brothers.and.Sisters" which is actually worse than the SABnzbd function as I have the periods in there.  

I am waiting for additional shows to dl where the name is exactly the same as my folder structure to see if mediarover script puts the files in "Some Show Name" or creates a new directory called "Some.Show.Name"

Is this how the script is supposed to work or am I using it wrong?

Can someone give me the main points of difference between mediarover sorting and SABnzbd folder sort naming function?

Many thanks!!

EDIT: A few other shows seem to be sorting just fine and are matching up to "Some Show Name" versus creating a dir called "Some.Show.Name".  Does the sorter only create a dir with periods when it does not match to an existing show?  Brothers & Sisters not found and no Brothers and Sisters, so creates Bothers.and.Sisters.
Last edited by pilGrim on December 11th, 2009, 11:59 pm, edited 1 time in total.

Post Reply