Media Rover

Got a program that plays well with SABnzbd? Share it here!
jayman
Newbie
Newbie
Posts: 45
Joined: July 2nd, 2009, 2:14 pm

Re: Media Rover

Post by jayman »

i have the default on my config. file which shouldn't produce underscores, right?  Also, it doesn't do this with the other feeds (ie mytvnzb and tvnzb).  This doesn't happen with you and newzbin?  If it doesn't, I must be doing something different...

rollingeyeball
Release Testers
Release Testers
Posts: 183
Joined: January 30th, 2009, 12:26 pm

Re: Media Rover

Post by rollingeyeball »

Code: Select all

	# episode title pattern
		# used when renaming downloaded episodes
		#
		#  $(title)s  => 'Hello World!'
		#  $(title.)s => 'Hello.World!'
		#  $(title_)s => 'Hello_World!'
		# 
		# NOTE: defaults to '$(title)s'
		title = $(title)s
Wait.. The shows folders...
I misread, sorry.

Code: Select all

		# series naming pattern
		# used when creating series directories
		# 
		#  $(series)s  => "Series Name"
		#  $(series.)s => "Series.Name"
		#  $(series_)s => "Series_Name"
		#
		# NOTE: defaults to '$(series)s'
		series = $(series)s
Remember, for any of the renaming to work you need to run the sorting script... I think

Also, Kierse If you're reading this, Can I ask that the sXXsXX formatted titles have the S and E capitalised? It's a simple thing that annoys me a lot.
Last edited by rollingeyeball on July 9th, 2009, 11:41 am, edited 1 time in total.

jayman
Newbie
Newbie
Posts: 45
Joined: July 2nd, 2009, 2:14 pm

Re: Media Rover

Post by jayman »

I'm running the sorting script and the default is without underscores, right?  I don't know why mine are having underscores then.  With yours, your newsbin feed isn't producing underscores?

rollingeyeball
Release Testers
Release Testers
Posts: 183
Joined: January 30th, 2009, 12:26 pm

Re: Media Rover

Post by rollingeyeball »

Yeah, mine is totally without underscores.

Can you clarify what has underscores? The series folder name?

And can I see your SAB script output? I probably won't be able to help but it's worth a try I s'pose.

Also, perhaps double check the source nzb to see if there's anything obvious there that may have caused it?

jayman
Newbie
Newbie
Posts: 45
Joined: July 2nd, 2009, 2:14 pm

Re: Media Rover

Post by jayman »

will post it when I get home.  thanks.  do you think it's the kind of rss I got from newzbin?  I think I used newzbin reports and just picked all the xvid tv.

rollingeyeball
Release Testers
Release Testers
Posts: 183
Joined: January 30th, 2009, 12:26 pm

Re: Media Rover

Post by rollingeyeball »

I have a search set exactly the same.

It's probably something simple.

jayman
Newbie
Newbie
Posts: 45
Joined: July 2nd, 2009, 2:14 pm

Re: Media Rover

Post by jayman »

here is what I get.  It's driving me nuts.  I redid the config file just to make sure I didn't screw anything up.  It makes both the folder name and the title with underscores.  I did not change the default options and it doesn't do it with any other feeds but newzbin:

2009-07-09 18:04:26,809 INFO - watching 26 tv show(s) - episode.py:205
2009-07-09 18:04:26,809 DEBUG - finished processing tv directory - episode.py:206
2009-07-09 18:04:26,809 DEBUG - identified possible download: filename =>  - S01E01.avi, size => 183937024 - episode.py:232
2009-07-09 18:04:26,809 INFO - found download file at 'H:\TV Media Encoded\\Season 01/- S01E01.avi' - episode.py:238
2009-07-09 18:04:26,811 ERROR - Unable to parse job name (_-_1x01_-_Pilot) and extract necessary values - episode.py:251
2009-07-09 18:04:26,811 ERROR - missing episode season number - episode.py:112
Traceback (most recent call last):
 File "C:\Users\jay\Downloads\mediarover\mediarover\mediarover\scripts\sabnzbd\episode.py", line 109, in sort
   _process_download(config, options, args)
 File "C:\Users\jay\Downloads\mediarover\mediarover\mediarover\scripts\sabnzbd\episode.py", line 248, in _process_download
   episode = NewzbinEpisode.new_from_string(job)
 File "C:\Users\jay\Downloads\mediarover\mediarover\mediarover\sources\newzbin\episode.py", line 46, in new_from_string
   year = p['year'], month = p['month'], day = p['day'], title = p['title'])
 File "C:\Users\jay\Downloads\kierse-mediarover-01399cd2af4113d6ac4dfa537b40c0e7b10ebda4\kierse-mediarover-01399cd2af4113d6ac4dfa537b40c0e7b10ebda4\mediarover\episode.py", line 274, in __init__
   raise MissingParameterError("missing episode season number")
MissingParameterError: missing episode season number
Last edited by jayman on July 10th, 2009, 12:21 pm, edited 1 time in total.

jayman
Newbie
Newbie
Posts: 45
Joined: July 2nd, 2009, 2:14 pm

Re: Media Rover

Post by jayman »

i'm an idiot.  somehow under 'switches' in sabnzbd the box for put underscores in empty spaces got checked.  you think this program is still being developed?

rollingeyeball
Release Testers
Release Testers
Posts: 183
Joined: January 30th, 2009, 12:26 pm

Re: Media Rover

Post by rollingeyeball »

i'm an idiot.  somehow under 'switches' in sabnzbd the box for put underscores in empty spaces got checked.
Haha, Told yuo it'd be something simple. Glad you got it sorted out now.
  you think this program is still being developed?
Sabnzbd or media rover?
Both are.  Kierse hasn't replied so I can only assume he's busy, but it's still being developed afaik.

Also, you should probably remove the names from your script output above.
Mods will yell at you otherwise :)

rollingeyeball
Release Testers
Release Testers
Posts: 183
Joined: January 30th, 2009, 12:26 pm

Re: Media Rover

Post by rollingeyeball »

:-\

Seems media Rover had an error today with checking what was in the queue (it IS meant to check that I think..)
And got the same file from 2 sources

I've disabled the 2nd source for now but I'd really like in queue checking to work.. that way I can have multiple sources and MR can nab the fastest post.

jayman
Newbie
Newbie
Posts: 45
Joined: July 2nd, 2009, 2:14 pm

Re: Media Rover

Post by jayman »

thanks.  done.  I guess a workaround, if you'd like to guarantee x264 being download is to make sure that mediarover looks at an RSS feed first that only has x264 options first and then looks at the Xvid feeds (pretty obvious).

jayman
Newbie
Newbie
Posts: 45
Joined: July 2nd, 2009, 2:14 pm

Re: Media Rover

Post by jayman »

rollingeyeball wrote: :-\

Seems media Rover had an error today with checking what was in the queue (it IS meant to check that I think..)
And got the same file from 2 sources

I've disabled the 2nd source for now but I'd really like in queue checking to work.. that way I can have multiple sources and MR can nab the fastest post.
I'm pretty sure it doesn't check the queue.  As an example, if you set mediarover to work every fifteen minutes and the file takes 20 minutes to download it will keep downloading that same file because it thinks you don't have it.  It doesn't remember from the last time it ran that it was already queued.  It only looks at your file folders and if the video isn't there it is gonna queue it.

rollingeyeball
Release Testers
Release Testers
Posts: 183
Joined: January 30th, 2009, 12:26 pm

Re: Media Rover

Post by rollingeyeball »

True. True.

And with a 15minute schedule and 43minute downloads It's not surprise problems have arisen.

I suppose it really needs queue checking then.

Something like when it adds something to queue, it puts flags that episode, not the nzb or anything specific, but the episode itself.
If it sees something in a feed that's flagged as already being dealt with, it can move on.

And for the record, it downloaded a few HD eps :)
I have a 40gb monthly allowance (screw Australian internet) and HD eps are impossible.

markus101
Release Testers
Release Testers
Posts: 413
Joined: August 13th, 2008, 2:51 am

Re: Media Rover

Post by markus101 »

Mines been great, though its pretty dead for downloading right now. Ouch 40GB a month? I've never had any issue with a quota, but it's supposed to be 80GB, but at 15Mbit I download as much as I can... 34GB this month and counting. 43 mins to download, double ouch....glad I'm here in Canada, that makes me cringe.

If you tell SAB to ignore dupes you should be fine with it adding the show multiple times, you'll get some warnings, but that's about it.

-Markus
Co-developer of NzbDrone (.Net NNTP PVR) - http://www.nzbdrone.com

rollingeyeball
Release Testers
Release Testers
Posts: 183
Joined: January 30th, 2009, 12:26 pm

Re: Media Rover

Post by rollingeyeball »

Markus, it was different nzbs, so sab was no help.
Different sources.

I'm just going to use newzbin for now though

Post Reply