Media Rover

Got a program that plays well with SABnzbd? Share it here!
User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

wally007 wrote: Since my knowledge ends with xhtml/css and little bit of PHP i'm not the most qualified person to guess, but your solution seems like major undertaking. Do you have estimate how long it can take to develop your idea vs my idea ?
You are correct.  Introducing a database would likely be a larger undertaking than implementing your solution.  At this time, I don't have any estimates for you regarding effort and quite frankly I don't plan on spending the time to come up with one.  I'd much rather spend what little time I have improving Media Rover.  Your solution, while clever and quite simple, is in my opinion more of a hack than a viable long term solution.  But don't despair!  The beauty of open source software is that anyone (including you) can pick up the source code and make changes as they see fit.  I learned Python while developing Media Rover and so can you.  If your desire to see this functionality is great enough, I urge you to solve the problem yourself.  Otherwise, I suggest you wait patiently until I can get to it :)

Kierse

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

Hi jkristoph,
jkristoph wrote: There is one small problem. I am using your new release for sabnzbd 0.5.0 beta6 and I keep getting an error user HISTORY in the sab webinterface when it attempts to call on the rover sorting script

"Script Exit{1} NameError: global name 'exit' is not defined" 

The funny thing is that the sorting script is working like it should and all my episodes are being sorted as configured.
Hmm, I thought we had solved this issue.  A few questions for you?

1. what version of Media Rover are you running?  The latest release (0.3.0) or the latest code from the development branch?
2. what OS are you running?
3. can you send me the complete sort script log?

Kierse

wally007
Release Testers
Release Testers
Posts: 179
Joined: August 28th, 2009, 5:24 pm

Re: Media Rover

Post by wally007 »

kierse wrote:
wally007 wrote: Since my knowledge ends with xhtml/css and little bit of PHP i'm not the most qualified person to guess, but your solution seems like major undertaking. Do you have estimate how long it can take to develop your idea vs my idea ?
You are correct.  Introducing a database would likely be a larger undertaking than implementing your solution.  At this time, I don't have any estimates for you regarding effort and quite frankly I don't plan on spending the time to come up with one.  I'd much rather spend what little time I have improving Media Rover.  Your solution, while clever and quite simple, is in my opinion more of a hack than a viable long term solution.  But don't despair!  The beauty of open source software is that anyone (including you) can pick up the source code and make changes as they see fit.  I learned Python while developing Media Rover and so can you.  If your desire to see this functionality is great enough, I urge you to solve the problem yourself.  Otherwise, I suggest you wait patiently until I can get to it :)

Kierse
So you learned programming from scratch and your first app is Media Rover ? If so congrats. Unfortunately i work in totally different field 11 hours a day so unless i quit ( or get fired :-) )  and get IT job i dont see myself progressing much further.

Thanks.

wally007
Release Testers
Release Testers
Posts: 179
Joined: August 28th, 2009, 5:24 pm

Re: Media Rover

Post by wally007 »

kierse wrote: Hmm, I thought we had solved this issue.  A few questions for you?

1. what version of Media Rover are you running?  The latest release (0.3.0) or the latest code from the development branch?
2. what OS are you running?
3. can you send me the complete sort script log?

Kierse
I dont know if i encountered a bug or its just something Media Rover isnt ready to deal with but for past few hours nzbs.org was having problems and MediaRover wasnt able to continue after it got to processing nzbs source.

Code: Select all

2010-01-17 19:30 INFO - processing 'nzbs' items - __init__.py:305
2010-01-17 19:30 ERROR - syntax error: line 1, column 0 - __init__.py:99
Traceback (most recent call last):
  File "/Users/vladik1/Downloads/mediarover/mediarover/__init__.py", line 97, in main
    _process(config, options, args)
  File "/Users/vladik1/Downloads/mediarover/mediarover/__init__.py", line 307, in _process
    items = source.items()
  File "/Users/vladik1/Downloads/mediarover/mediarover/sources/nzbs/source.py", line 39, in items
    self.__get_document()
  File "/Users/vladik1/Downloads/mediarover/mediarover/sources/nzbs/source.py", line 55, in __get_document
    self.__document = xml.dom.minidom.parse(url)
  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/xml/dom/minidom.py", line 1918, in parse
  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/xml/dom/expatbuilder.py", line 928, in parse
  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/xml/dom/expatbuilder.py", line 207, in parseFile
ExpatError: syntax error: line 1, column 0
Traceback (most recent call last):
  File "/Users/vladik1/Downloads/mediarover/mediarover.py", line 19, in <module>
    mediarover.main()
  File "/Users/vladik1/Downloads/mediarover/mediarover/__init__.py", line 97, in main
    _process(config, options, args)
  File "/Users/vladik1/Downloads/mediarover/mediarover/__init__.py", line 307, in _process
    items = source.items()
  File "/Users/vladik1/Downloads/mediarover/mediarover/sources/nzbs/source.py", line 39, in items
    self.__get_document()
  File "/Users/vladik1/Downloads/mediarover/mediarover/sources/nzbs/source.py", line 55, in __get_document
    self.__document = xml.dom.minidom.parse(url)
  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/xml/dom/minidom.py", line 1918, in parse
  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/xml/dom/expatbuilder.py", line 928, in parse
  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/xml/dom/expatbuilder.py", line 207, in parseFile
xml.parsers.expat.ExpatError: syntax error: line 1, column 0
I had nzbs.org as my first source. Media Rover gave me that error and never got past it to newzbin and nzbmatrix sources. Once nzbs.org fixed their problem Media Rover got back to processing all 3 feeds again. Is there anyway to tell Media Rover if one source errors out to go back and process next source available ?

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

wally007 wrote: So it's the comas that divide subcategories that break it...
Fixed, commas in a url should no longer cause any problems.
wally007 wrote: Is there anyway to tell Media Rover if one source errors out to go back and process next source available ?
Fixed.  MR should no longer die when it encounters an error accessing a sources RSS feed.  It now traps the error, logs it, and continues on to the next source.

These changes are available on the dev branch

Kierse

wally007
Release Testers
Release Testers
Posts: 179
Joined: August 28th, 2009, 5:24 pm

Re: Media Rover

Post by wally007 »

kierse wrote:
wally007 wrote: So it's the comas that divide subcategories that break it...
Fixed, commas in a url should no longer cause any problems.
wally007 wrote: Is there anyway to tell Media Rover if one source errors out to go back and process next source available ?
Fixed.  MR should no longer die when it encounters an error accessing a sources RSS feed.  It now traps the error, logs it, and continues on to the next source.

These changes are available on the dev branch

Kierse
Wow  thanks, you're fast. Will give it a try this weekend.

By the way is there anyway to configure episode sorting so that if TV show doesnt exist on the disk,  to get rid of the "." in the name ?
Newzbin and nzbmatrix put spaces in the name but unfortunatelly tvnzb and nzbs.org leave dots in the names.

Lokro
Newbie
Newbie
Posts: 5
Joined: January 22nd, 2010, 4:02 am

Re: Media Rover

Post by Lokro »

I'm having a problem with a daily show.

Code: Select all

2010-01-22 01:45 DEBUG - begin processing item 'The Daily Show 2010 01 21 Julie Andrews HDTV XviD FQM' - __init__.py:317
2010-01-22 01:45 ERROR - unsupported item title format - error.py:45
2010-01-22 01:45 INFO - skipping 'The Daily Show 2010 01 21 Julie Andrews HDTV XviD FQM', unknown format - __init__.py:321
I have a feeling it's because this RSS feed uses spaces, I want to get it to work with this feed if I can.

isore
Newbie
Newbie
Posts: 1
Joined: January 22nd, 2010, 5:53 am

Re: Media Rover

Post by isore »

At the moment my binary downloads via newsgroups are encrypted over an SSL connection however I suspect the RSS nzb downloads are over the http connection. Therefore I'm looking for a 'grabber' that can download via a proxy, does anyone know if MediaRover can do this, I had a quick look through the config files and couldn't see anything?

markus101
Release Testers
Release Testers
Posts: 413
Joined: August 13th, 2008, 2:51 am

Re: Media Rover

Post by markus101 »

If the host where you download NZBs from supports SSL (Newzbin to name one), all downloads should come through HTTPS as opposed to HTTP, you could confirm when something like wireshark.

-Markus
Co-developer of NzbDrone (.Net NNTP PVR) - http://www.nzbdrone.com

rollingeyeball
Release Testers
Release Testers
Posts: 183
Joined: January 30th, 2009, 12:26 pm

Re: Media Rover

Post by rollingeyeball »

I formatted today and reinstalled MR from the /dev branch and python 2.5.4
I get this error

Code: Select all

C:\MediaRover\mediarover\__init__.py:311: Warning: 'as' will become a reserved k
eyword in Python 2.6
Traceback (most recent call last):
  File "C:\MediaRover\mediarover.py", line 17, in <module>
    import mediarover
  File "C:\MediaRover\mediarover\__init__.py", line 311
    except Exception as error:
                      ^
SyntaxError: invalid syntax

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

rollingeyeball wrote:

Code: Select all

C:\MediaRover\mediarover\__init__.py:311: Warning: 'as' will become a reserved k
eyword in Python 2.6
Traceback (most recent call last):
  File "C:\MediaRover\mediarover.py", line 17, in <module>
    import mediarover
  File "C:\MediaRover\mediarover\__init__.py", line 311
    except Exception as error:
                      ^
SyntaxError: invalid syntax
Sorry rollingeyeball, my fault.  I used a new language directive introduced in Python 2.6 without realizing it.  I've replaced the code in question with something that's 2.5 compliant.  You shouldn't have any further troubles.

Kierse

rollingeyeball
Release Testers
Release Testers
Posts: 183
Joined: January 30th, 2009, 12:26 pm

Re: Media Rover

Post by rollingeyeball »

Thanks Kierse.
All good now :)

A suggestion too - maybe an easier config option for disabling logging to screen, so that pythonw works?
Removing instances of 'screen' in logging.conf works fine but I forgot it just then, and I figure some others probably don't even know you can edit logging.conf to allow for it.

Jeebz
Newbie
Newbie
Posts: 5
Joined: January 9th, 2010, 9:42 pm

Re: Media Rover

Post by Jeebz »

Heyy all,

I finally got this setup and working sweet monitoring 16 shows and it queues up the ep's to download and i let one finish downloading but it just went into my completed downloads folder and not the folder that MR is monitoring for that show.

I have my shows split across two HDD's, (A-K) on one and (L-Z) on the other but when the download completes i thought it was meant to rename that ep and move it to the relavent folder for it? unless there is some other coding im meant to be doing. Ive just setup my filters, RSS feed but not touched anything to do with naming and moving files cause i couldn't find a guide on it? any help would be appreciated thanks

Jeebz

Edit: seems from reading a little more Sabnzbd is meant to auto start the script once a download is complete is there some setting in Sabnzbd i should have enabled to start this script? first time user of sab aswell :D
Last edited by Jeebz on January 26th, 2010, 4:37 am, edited 1 time in total.

pilGrim
Full Member
Full Member
Posts: 116
Joined: January 9th, 2009, 7:28 pm
Location: Hong Kong, SAR China

Re: Media Rover

Post by pilGrim »

Hi Everyone,

Been traveling a lot for work and have not had time to hit the boards to keep up with latest.  Mediarover seemed to be working fine, but I now find an error.  I do have something odd in my file structure and that is that I name my series like this:  Damages\Damages - Season 01\Damages - s03e01.avi  I have this setup in my config file and all has worked in the past, so was not thinking this is the issue.  The Damages.s03e01 is not present, neither is season 03, but season 01 and 02 are there.

I upgraded to latest version but the error did not go away.  Any thoughts?  Here is my debug. 

Code: Select all

2010-01-26 19:20 INFO - --- STARTING --- - __init__.py:93
2010-01-26 19:20 INFO - begin processing tv directory: M:\TV Shows - __init__.py:142
2010-01-26 19:20 INFO - begin processing tv directory: M:\Kids\TV Shows - __init__.py:142
2010-01-26 19:20 INFO - watching 141 tv show(s) - __init__.py:192
2010-01-26 19:20 INFO - begin processing sources - __init__.py:195
2010-01-26 19:20 INFO - found feed 'Custom shows I select RSS feed' - __init__.py:211
2010-01-26 19:20 INFO - found feed 'NZBS.org last 100 feed' - __init__.py:211
2010-01-26 19:20 INFO - watching 2 source(s) - __init__.py:242
2010-01-26 19:20 INFO - processing 'Custom shows I select RSS feed' items - __init__.py:305
2010-01-26 19:20 ERROR - episode 'Damages - 3x01' does not exist on disk - error.py:45
2010-01-26 19:20 ERROR - missing episode series name - error.py:45
2010-01-26 19:20 ERROR - missing episode series name - __init__.py:99
Traceback (most recent call last):
  File "C:\Users\Admin\Mediarover\mediarover\__init__.py", line 97, in main
    _process(config, options, args)
  File "C:\Users\Admin\Mediarover\mediarover\__init__.py", line 363, in _process
    if queue.in_queue(episode):
  File "C:\Users\Admin\Mediarover\mediarover\queues\sabnzbd\queue.py", line 102, in in_queue
    if download == job.download():
  File "C:\Users\Admin\Mediarover\mediarover\queues\sabnzbd\job.py", line 45, in download
    self.__parseJob()
  File "C:\Users\Admin\Mediarover\mediarover\queues\sabnzbd\job.py", line 75, in __parseJob
    self.__download = Episode.new_from_string(title)
  File "C:\Users\Admin\Mediarover\mediarover\episode.py", line 81, in new_from_string
    year = p['year'], month = p['month'], day = p['day'], title = p['title'])
  File "C:\Users\Admin\Mediarover\mediarover\episode.py", line 271, in __init__
    raise MissingParameterError("missing episode series name")
MissingParameterError: missing episode series name
Traceback (most recent call last):
  File "C:\Users\Admin\Mediarover\mediarover.py", line 19, in <module>
    mediarover.main()
  File "C:\Users\Admin\Mediarover\mediarover\__init__.py", line 97, in main
    _process(config, options, args)
  File "C:\Users\Admin\Mediarover\mediarover\__init__.py", line 363, in _process
    if queue.in_queue(episode):
  File "C:\Users\Admin\Mediarover\mediarover\queues\sabnzbd\queue.py", line 102, in in_queue
    if download == job.download():
  File "C:\Users\Admin\Mediarover\mediarover\queues\sabnzbd\job.py", line 45, in download
    self.__parseJob()
  File "C:\Users\Admin\Mediarover\mediarover\queues\sabnzbd\job.py", line 75, in __parseJob
    self.__download = Episode.new_from_string(title)
  File "C:\Users\Admin\Mediarover\mediarover\episode.py", line 81, in new_from_string
    year = p['year'], month = p['month'], day = p['day'], title = p['title'])
  File "C:\Users\Admin\Mediarover\mediarover\episode.py", line 271, in __init__
    raise MissingParameterError("missing episode series name")
MissingParameterError: missing episode series name

pilGrim
Full Member
Full Member
Posts: 116
Joined: January 9th, 2009, 7:28 pm
Location: Hong Kong, SAR China

Re: Media Rover

Post by pilGrim »

pilGrim wrote: Hi Everyone,

Been traveling a lot for work and have not had time to hit the boards to keep up with latest.  Mediarover seemed to be working fine, but I now find an error.  I do have something odd in my file structure and that is that I name my series like this:  Damages\Damages - Season 01\Damages - s03e01.avi  I have this setup in my config file and all has worked in the past, so was not thinking this is the issue.  The Damages.s03e01 is not present, neither is season 03, but season 01 and 02 are there.

I upgraded to latest version but the error did not go away.  Any thoughts?  Here is my debug. 
I figured out the problem, turns out I had some movies in the queue and mediarover hit an error thinking they were tv shows as it could not parse a name, season and episode #.

So the lesson is, no shows dl when you have a lot of movies queued up.

pilGrim

Post Reply