Media Rover

Got a program that plays well with SABnzbd? Share it here!
wally007
Release Testers
Release Testers
Posts: 179
Joined: August 28th, 2009, 5:24 pm

Re: Media Rover

Post by wally007 »

kierse wrote:
wally007 wrote: Logs for BOTH episodes ( original avi and second mkv ) sent to your PM address.
I just released the last of several updates that address the problem you've been having.  Update to the latest sources and give it a whirl.

Kierse
New version doesnt work. Sent you TERMINAL error via PM.

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

wally007 wrote: New version doesnt work. Sent you TERMINAL error via PM.
Sorry about that, rogue import statement.  It should be working now.

Kierse

wally007
Release Testers
Release Testers
Posts: 179
Joined: August 28th, 2009, 5:24 pm

Re: Media Rover

Post by wally007 »

Thanks. Will let you know when i encounter new episodes next week.

Only other problem i had was with renaming template. I tried to change it anyway i could to no avail. Newzbin downloads ALWAYS have smart title even when i have smart title disabled and is not part of my rename template string.

im including my config file , if you have time can you please look at it and see if something is at fault there ?

Previous versions of MR ( before quality management ) always renamed episode properly to Show name - S01E01.avi. Now i get Show name - s01e01.avi and in case episode comes from Newzbin source Show name - s01e01 - episode title.avi

Necro
Newbie
Newbie
Posts: 9
Joined: April 9th, 2009, 5:39 pm

Re: Media Rover

Post by Necro »

Hrm...having some issues with getting sorting working:

Code: Select all

2010-05-14 14:58 INFO - begin processing tv directory: \\whs\Television - episode.py:225
2010-05-14 14:58 INFO - watching 25 tv show(s) - episode.py:295
2010-05-14 14:58 INFO - found download file at '\\whs\downloads\- Television\19.Kids.And.Counting.S04E16.HDTV.XviD-CRiMSON\19.Kids.And.Counting.S04E16.HDTV.XviD-CRiMSON.avi' - episode.py:326
2010-05-14 14:58 INFO - scanning filesystem for episodes belonging to '19 kids and counting'... - series.py:224
2010-05-14 14:58 ERROR - 'NoneType' object has no attribute 'upper' - episode.py:135
Traceback (most recent call last):
  File "c:\progra~1\mediarover\mediarover\scripts\sabnzbd\episode.py", line 132, in sort
    _process_download(config, broker, options, args)
  File "c:\progra~1\mediarover\mediarover\scripts\sabnzbd\episode.py", line 393, in _process_download
    new_path = os.path.join(dest_dir, file.format(additional))
  File "C:\Program Files\MediaRover\mediarover\filesystem\episode.py", line 37, in format
    params = self.format_parameters(series=True, season=True, episode=True, quality=True, title=True)
  File "C:\Program Files\MediaRover\mediarover\filesystem\episode.py", line 106, in format_parameters
    params['QUALITY'] = episode.quality.upper()
AttributeError: 'NoneType' object has no attribute 'upper'
FAILURE, unable to sort downloaded episode! See log file at 'C:\\Progra~1\\MediaRover\\config\\logs\\sabnzbd_episode_sort.log' for more details!
(BTW, that's a random show I picked because it was smaller and I can't figure out how to manually run the sort script over and over while modifying things to debug... :) - it's the only episode going into a totally empty folder) .

Also - I have the SAB TV show sorting turned off. 

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

wally007 wrote: Only other problem i had was with renaming template.
Ahh, I know what the problem is: along with the changes introduced for quality management, the single episode template variable was renamed from 'series_episode' to 'single_episode'.  You have 'series_episode' in your config file.  MR no longer looks for 'series_episode' and will use the default value for 'single_episode' (which is - sXXeXX - .ext) if you don't provide an override.  I'm guessing that when you first installed the new code base you didn't notice the variable name change.  Renaming 'series_episode' to 'single_episode' in your config should fix the problem.

Sorry I didn't notice that the first time you posted your config.

Kierse

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

Necro wrote: Hrm...having some issues with getting sorting working:

Code: Select all

    params['QUALITY'] = episode.quality.upper()
AttributeError: 'NoneType' object has no attribute 'upper'
FAILURE, unable to sort downloaded episode! See log file at 'C:\\Progra~1\\MediaRover\\config\\logs\\sabnzbd_episode_sort.log' for more details!
I seem to recall fixing this error (or something very similar) recently.  Are you running the most recent code?
Necro wrote: ...I can't figure out how to manually run the sort script...
I log the exact call that invokes the sorting script in the sorting script log.  Its located right after the '--- STARTING ---'  line.  If you copy and paste that command in a terminal, the sorting script will run just as if SAB called it.  You can also invoke the sorting script without any arguments (or with --help) and it will display usage information.

Kierse

wally007
Release Testers
Release Testers
Posts: 179
Joined: August 28th, 2009, 5:24 pm

Re: Media Rover

Post by wally007 »

kierse wrote:
wally007 wrote: Only other problem i had was with renaming template.
Ahh, I know what the problem is: along with the changes introduced for quality management, the single episode template variable was renamed from 'series_episode' to 'single_episode'.  You have 'series_episode' in your config file.  MR no longer looks for 'series_episode' and will use the default value for 'single_episode' (which is - sXXeXX - .ext) if you don't provide an override.  I'm guessing that when you first installed the new code base you didn't notice the variable name change.  Renaming 'series_episode' to 'single_episode' in your config should fix the problem.

Sorry I didn't notice that the first time you posted your config.

Kierse
Yep , that was it. I cant believe it i didnt notice it , i must have gone over it million times.

Thanks a lot. Will keep you posted on that "deleting old" episode bug.

Necro
Newbie
Newbie
Posts: 9
Joined: April 9th, 2009, 5:39 pm

Re: Media Rover

Post by Necro »

kierse wrote:
Necro wrote: Hrm...having some issues with getting sorting working:

Code: Select all

    params['QUALITY'] = episode.quality.upper()
AttributeError: 'NoneType' object has no attribute 'upper'
FAILURE, unable to sort downloaded episode! See log file at 'C:\\Progra~1\\MediaRover\\config\\logs\\sabnzbd_episode_sort.log' for more details!
I seem to recall fixing this error (or something very similar) recently.  Are you running the most recent code?
Necro wrote: ...I can't figure out how to manually run the sort script...
I log the exact call that invokes the sorting script in the sorting script log.  Its located right after the '--- STARTING ---'  line.  If you copy and paste that command in a terminal, the sorting script will run just as if SAB called it.  You can also invoke the sorting script without any arguments (or with --help) and it will display usage information.

Kierse
I THINK I am - I downloaded the development release on the site (the filename was kierse-mediarover-v0.4.1-174-g9fa529e.zip) and extracted that over the .41 build.  Redid my config as well after doing so.  (just to make sure it wasn't fixed... :) )

Should I grab it straight from git?

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

Necro wrote: I THINK I am - I downloaded the development release on the site (the filename was kierse-mediarover-v0.4.1-174-g9fa529e.zip) and extracted that over the .41 build.  Redid my config as well after doing so.  (just to make sure it wasn't fixed... :) )
Yup, it looks like you are running the latest code base.  I'll dig a little deeper and see if I can figure out whats going on.  In the meantime, can you do two things for me:

1. Send me a full copy of the sorting log.  Just PM it to me if you don't mind.
2. Delete your MR application directory and re-extract it.  I've run into problems in the past when extracting a new code base over top of an existing one.  There were quite a few changes (including a large reorganization) and python may be loading something that left over from 0.4.1.
Necro wrote: Should I grab it straight from git?
No, the links on mediarover.tv link straight to Github, what you've got should be fine.

Kierse

Necro
Newbie
Newbie
Posts: 9
Joined: April 9th, 2009, 5:39 pm

Re: Media Rover

Post by Necro »

Retried with fresh install - same show, same files - same thing happened.

Code: Select all

           2010-05-14 19:17 INFO - --- STARTING --- - episode.py:123
2010-05-14 19:17 INFO - begin processing tv directory: \\whs\Television - episode.py:225
2010-05-14 19:17 INFO - watching 25 tv show(s) - episode.py:295
2010-05-14 19:17 INFO - found download file at '\\whs\downloads\- Television\19.Kids.And.Counting.S04E16.HDTV.XviD-CRiMSON\19.Kids.And.Counting.S04E16.HDTV.XviD-CRiMSON.avi' - episode.py:326
2010-05-14 19:17 INFO - scanning filesystem for episodes belonging to '19 kids and counting'... - series.py:224
2010-05-14 19:17 ERROR - 'NoneType' object has no attribute 'upper' - episode.py:135
Traceback (most recent call last):
  File "c:\progra~1\mediarover\mediarover\scripts\sabnzbd\episode.py", line 132, in sort
    _process_download(config, broker, options, args)
  File "c:\progra~1\mediarover\mediarover\scripts\sabnzbd\episode.py", line 393, in _process_download
    new_path = os.path.join(dest_dir, file.format(additional))
  File "C:\PROGRA~1\MediaRover\mediarover\filesystem\episode.py", line 37, in format
    params = self.format_parameters(series=True, season=True, episode=True, quality=True, title=True)
  File "C:\PROGRA~1\MediaRover\mediarover\filesystem\episode.py", line 106, in format_parameters
    params['QUALITY'] = episode.quality.upper()
AttributeError: 'NoneType' object has no attribute 'upper'
FAILURE, unable to sort downloaded episode! See log file at 'C:\\Progra~1\\MediaRover\\config\\logs\\sabnzbd_episode_sort.log' for more details!

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

Hey Necro,
Necro wrote:

Code: Select all

    params['QUALITY'] = episode.quality.upper()
AttributeError: 'NoneType' object has no attribute 'upper'
FAILURE, unable to sort downloaded episode! See log file at 'C:\\Progra~1\\MediaRover\\config\\logs\\sabnzbd_episode_sort.log' for more details!
I just pushed several updates that should fix the issues you reported (including the one regarding daily episodes).  Update your code and let me know how it goes.

Kierse

Necro
Newbie
Newbie
Posts: 9
Joined: April 9th, 2009, 5:39 pm

Re: Media Rover

Post by Necro »

Worked!  Nice!

You sir, rock. :)

wally007
Release Testers
Release Testers
Posts: 179
Joined: August 28th, 2009, 5:24 pm

Re: Media Rover

Post by wally007 »

I thought ability to handle RSS feed errors were fixed but something must have changed .... nzbs.org is down at the moment and MR is unable to continue because of it. When i delete my nzbs.org sources MR is able to continue and process rest of the sources.

Sent you TERMINAL error via PM.

EDIT --> nzbs.org is not really down. Its just sporadicly returnig Too many connections error message when trying to access their site or RSS feeds. But i think in the past MR was able to continue even when one source crapped out.
Last edited by wally007 on May 17th, 2010, 7:08 pm, edited 1 time in total.

g1zm0
Newbie
Newbie
Posts: 24
Joined: February 7th, 2010, 7:57 am

Re: Media Rover

Post by g1zm0 »

Hey Guys,

Started having some wierd problems recently with the sorting script not working. Can anyone help me debug this? (at work, not got time to read all the past posts now, if this is a known problem just ignore me and ill look when im home)

Cheers

Code: Select all

Family Guy S08E19 HR PDTV X264 DIMENSION

           2010-05-18 02:02 INFO - --- STARTING --- - episode.py:124
2010-05-18 02:02 INFO - begin processing tv directory: J:\TV - episode.py:226
2010-05-18 02:02 INFO - begin processing tv directory: L:\TV II - episode.py:226
2010-05-18 02:02 INFO - begin processing tv directory: K:\TV III - episode.py:226
2010-05-18 02:02 INFO - begin processing tv directory: M:\TV IV - episode.py:226
2010-05-18 02:02 INFO - watching 61 tv show(s) - episode.py:296
2010-05-18 02:02 INFO - found download file at 'F:\USENET\FINISHED\Family Guy S08E19 HR PDTV X264 DIMENSION.5\Family.Guy.S08E19.HR.PDTV.X264-DIMENSION.mkv' - episode.py:327
2010-05-18 02:02 ERROR - 'NoneType' object has no attribute 'upper' - episode.py:136
Traceback (most recent call last):
  File "C:\SCRIPTS\Mediarover\mediarover\scripts\sabnzbd\episode.py", line 133, in sort
    _process_download(config, broker, options, args)
  File "C:\SCRIPTS\Mediarover\mediarover\scripts\sabnzbd\episode.py", line 400, in _process_download
    new_path = os.path.join(dest_dir, episode.format(additional))
  File "C:\SCRIPTS\Mediarover\mediarover\filesystem\episode\single.py", line 100, in format
    params = self.format_parameters(series=True, season=True, episode=True, quality=True, title=True)
  File "C:\SCRIPTS\Mediarover\mediarover\filesystem\episode\single.py", line 161, in format_parameters
    params['QUALITY'] = self.quality.upper()
AttributeError: 'NoneType' object has no attribute 'upper'
FAILURE, unable to sort downloaded episode! See log file at 'C:\\Users\\Barry\\AppData\\Local\\Mediarover\\logs\\sabnzbd_episode_sort.log' for more details!

           

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

Hey wally007,
wally007 wrote: I thought ability to handle RSS feed errors were fixed but something must have changed .... nzbs.org is down at the moment and MR is unable to continue because of it. When i delete my nzbs.org sources MR is able to continue and process rest of the sources.
Fixed, there was a typo in a logging statement I added a while back that only gets triggered when a specific error is encountered.

Post Reply