Media Rover

Got a program that plays well with SABnzbd? Share it here!
User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

Hi Poag,
Poag wrote: This morning i attempted to update to the 0.5.1 version. I've tried both a upgrade and a complete reinstall to no avail.

Code: Select all

...
ValueError: invalid literal for int() with base 10: ''
It appears the code responsible for parsing the series .ignore files (that I tried to fix the other day) still had a bug in it.  I've corrected the problem and release MR 0.5.2.  As a side note, one of your series .ignore files has a line that isn't being used.  When parsing the .ignore files, MR looks for two things:

1) a *
2) digits

Everything else is stripped away.  The problem you were seeing was because you have a line that has neither a * or at least one digit.

Kierse

Maverick519
Newbie
Newbie
Posts: 15
Joined: January 16th, 2010, 9:59 pm

Re: Media Rover

Post by Maverick519 »

kierse wrote: Hey Maverick519,
Maverick519 wrote: This keeps showing up for a lot of my nbzmatrix rss feeds 2010-07-30 19:30 DEBUG - skipping u'SHOW Name', unsupported category type - __init__.py:44.
My fault, the nzbmatrix source plugin was checking each report to see if it was a TV subcategory.  Categories 9 and 53 (for documentaries) obviously don't meet that requirement.  I'll have a fix out for you shortly.

Kierse
I am wondering if you can give me an idea of how I could by pass this in the code so that I no longer have the problem because I can see the value of checking TV only but since I like to use the program for other catagory's if I just by pass that check in the code on my end it would fix my problem with not using a standard source on nbzmatrix.

Maverick519

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

Hi Maverick519,
Maverick519 wrote: I am wondering if you can give me an idea of how I could by pass this in the code so that I no longer have the problem because I can see the value of checking TV only but since I like to use the program for other catagory's if I just by pass that check in the code on my end it would fix my problem with not using a standard source on nbzmatrix.
Sorry for not getting back to you sooner.  I've got a solution for your problem and its currently available on the dev branch.  Along with the fix for your problem there were several non-trivial changes to the code base and its not quite ready for an official release yet.  That being said, I've been running it for a few days on my own and have had no problems with it.  If you don't want to wait for 0.6.0, I would suggest downloading the latest from the dev branch and giving it a whirl.

Kierse

Maverick519
Newbie
Newbie
Posts: 15
Joined: January 16th, 2010, 9:59 pm

Re: Media Rover

Post by Maverick519 »

kierse wrote: Hi Maverick519,
Maverick519 wrote: I am wondering if you can give me an idea of how I could by pass this in the code so that I no longer have the problem because I can see the value of checking TV only but since I like to use the program for other catagory's if I just by pass that check in the code on my end it would fix my problem with not using a standard source on nbzmatrix.
Sorry for not getting back to you sooner.  I've got a solution for your problem and its currently available on the dev branch.  Along with the fix for your problem there were several non-trivial changes to the code base and its not quite ready for an official release yet.  That being said, I've been running it for a few days on my own and have had no problems with it.  If you don't want to wait for 0.6.0, I would suggest downloading the latest from the dev branch and giving it a whirl.

Kierse
Sure I will give it a whirl. Always nice to play with some new stuff.

Maverick519

jansverre
Newbie
Newbie
Posts: 14
Joined: January 11th, 2010, 8:11 pm

Re: Media Rover

Post by jansverre »

got a chence to see at the free space check yet ? :) got it full again here now :p hehe

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

Hey jansverre,
jansverre wrote: got a chence to see at the free space check yet ? :) got it full again here now :p hehe
Damn, I knew I forgot to tell someone!  I pushed some code to the dev branch a few days ago that should (hopefully) solve your problem.  I haven't yet had the opportunity to fully test the feature but I'm confident it should work.  Download the latest code available on the dev branch and let me know how it works.

Here's how things should work:

1. MR first checks if any of the disks that a series is already present on has space.  The order is the same as folders listed in tv_root
2. If there isn't space in any of the existing series folders, MR then checks all folders in tv_root to see if any of them has any space.  If one is found, MR creates a new series folder and sorts the episode there.
3. If no configured disk has space for the downloaded episode, MR prints an error message and exits

Give it a whirl and let me know how it goes.

Kierse

avatarr
Newbie
Newbie
Posts: 29
Joined: April 17th, 2010, 9:46 pm

Re: Media Rover

Post by avatarr »

For some reason, MR doesn't seem to be grabbing new episodes of Weeds from an nzbmatrix HDTV rss feed. I don't think it has anything to do with the nzbmatrix rss feed, but as it is 2 days old, the HDTV feed is already beyond the point that the recent episode would be included. MR missed last week's episode too (episode 1). Is there perhaps something I'm missing / doing wrong? Other shows download just fine.

Thanks in advance.

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

Hey avatarr,
avatarr wrote: For some reason, MR doesn't seem to be grabbing new episodes of Weeds from an nzbmatrix HDTV rss feed. I don't think it has anything to do with the nzbmatrix rss feed, but as it is 2 days old, the HDTV feed is already beyond the point that the recent episode would be included. MR missed last week's episode too (episode 1). Is there perhaps something I'm missing / doing wrong? Other shows download just fine.

Thanks in advance.
It could be a couple of things:

1) How frequent are you running the scheduler?  Its possible that the nzb appeared on the RSS and moved off it between runnings.
2) Do you have any filters or an .ignore file for that series?  Its possible they could be the culprit

Also what version are you running?

Kierse

avatarr
Newbie
Newbie
Posts: 29
Joined: April 17th, 2010, 9:46 pm

Re: Media Rover

Post by avatarr »

kierse wrote: Hey avatarr,
avatarr wrote: For some reason, MR doesn't seem to be grabbing new episodes of Weeds from an nzbmatrix HDTV rss feed. I don't think it has anything to do with the nzbmatrix rss feed, but as it is 2 days old, the HDTV feed is already beyond the point that the recent episode would be included. MR missed last week's episode too (episode 1). Is there perhaps something I'm missing / doing wrong? Other shows download just fine.

Thanks in advance.
It could be a couple of things:

1) How frequent are you running the scheduler?  Its possible that the nzb appeared on the RSS and moved off it between runnings.
2) Do you have any filters or an .ignore file for that series?  Its possible they could be the culprit

Also what version are you running?

Kierse
Kierse,
I highly doubt it's the first one. I have it checking every 10 minutes and like I said, it seems that it's catching every show other than Weeds.
I'm using version 0.5.0

I don't have any ignore filters specified in my .conf file, nor are there any .ignore files in my Weeds directory or any Season XX directory therein.

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

avatarr wrote: Kierse,
I highly doubt it's the first one. I have it checking every 10 minutes and like I said, it seems that it's catching every show other than Weeds.
I'm using version 0.5.0

I don't have any ignore filters specified in my .conf file, nor are there any .ignore files in my Weeds directory or any Season XX directory therein.
Do me a favour and upgrade to 0.5.2.  You won't need to change your config file at all, just unpack the code and your good to go.  You can create a series specific RSS feed in nzbmatrix and try running it again.  If it doesn't pick up the missed episodes, let me know.

Kierse

avatarr
Newbie
Newbie
Posts: 29
Joined: April 17th, 2010, 9:46 pm

Re: Media Rover

Post by avatarr »

kierse wrote:
avatarr wrote: Kierse,
I highly doubt it's the first one. I have it checking every 10 minutes and like I said, it seems that it's catching every show other than Weeds.
I'm using version 0.5.0

I don't have any ignore filters specified in my .conf file, nor are there any .ignore files in my Weeds directory or any Season XX directory therein.
Do me a favour and upgrade to 0.5.2.  You won't need to change your config file at all, just unpack the code and your good to go.  You can create a series specific RSS feed in nzbmatrix and try running it again.  If it doesn't pick up the missed episodes, let me know.

Kierse
Will do but I don't think I'm going to tackle that tonight as I'm very tired. I'll give it a shot tomorrow and let you know what's up.

I figured you might find this useful though:

Code: Select all

[~/.mediarover] # python mediarover.py episode-sort /share/Qdownload/sabnzbd/complete/Weeds\ S06E02\ iNTERNAL\ 720p\ HDTV\ x264\ SYS/
2010-08-26 00:51 INFO - --- STARTING --- - __init__.py:622
2010-08-26 00:51 INFO - begin processing tv directory: /share/Qmultimedia/TV - __init__.py:757
2010-08-26 00:51 INFO - watching 44 tv show(s) - __init__.py:827
2010-08-26 00:51 INFO - found download file at '/share/Qdownload/sabnzbd/complete/Weeds S06E02 iNTERNAL 720p HDTV x264 SYS/Weeds.S06E02.iNTERNAL.720p.HDTV.x264-SYS.mkv' - __init__.py:858
2010-08-26 00:51 INFO - scanning filesystem for episodes belonging to 'Weeds'... - series.py:232
2010-08-26 00:51 ERROR - list index out of range - __init__.py:1021
Traceback (most recent call last):
  File "/root/.mediarover/mediarover/__init__.py", line 668, in episode_sort
    __episode_sort(broker, options, **params)
  File "/root/.mediarover/mediarover/__init__.py", line 925, in __episode_sort
    desirables = series.filter_undesirables(episode)
  File "/root/.mediarover/mediarover/series.py", line 96, in filter_undesirables
    sample = self.episodes
  File "/root/.mediarover/mediarover/series.py", line 407, in _episodes_prop
    self.__check_episode_lists()
  File "/root/.mediarover/mediarover/series.py", line 332, in __check_episode_lists
    self.__find_series_episodes()
  File "/root/.mediarover/mediarover/series.py", line 253, in __find_series_episodes
    if dirnames[i].startswith('.'):
IndexError: list index out of range
FAILURE, unable to sort downloaded episode! See log file at '/root/.mediarover/logs/sabnzbd_episode_sort.log' for more details!

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

avatarr wrote: Will do but I don't think I'm going to tackle that tonight as I'm very tired. I'll give it a shot tomorrow and let you know what's up.

I figured you might find this useful though:

Code: Select all

...
2010-08-26 00:51 ERROR - list index out of range - __init__.py:1021
Hmm, I'll look into this one.  Meanwhile, when you upgrade try sorting the same episode again.  If it still gives you the same error let me know.

Kierse

avatarr
Newbie
Newbie
Posts: 29
Joined: April 17th, 2010, 9:46 pm

Re: Media Rover

Post by avatarr »

kierse wrote:
avatarr wrote: Will do but I don't think I'm going to tackle that tonight as I'm very tired. I'll give it a shot tomorrow and let you know what's up.

I figured you might find this useful though:

Code: Select all

...
2010-08-26 00:51 ERROR - list index out of range - __init__.py:1021
Hmm, I'll look into this one.  Meanwhile, when you upgrade try sorting the same episode again.  If it still gives you the same error let me know.

Kierse
As I am obsessive over issues such as these I just couldn't go to bed and leave it hanging. I downloaded 0.5.2, copied it to my .mediarover folder, and still no dice.

Dump:

Code: Select all

[~/.mediarover] # python mediarover.py --version
0.5.2
[~/.mediarover] # python mediarover.py episode-sort /share/Qdownload/sabnzbd/complete/Weeds\ S06E02\ iNTERNAL\ 720p\ HDTV\ x264\ SYS/
2010-08-26 01:07 INFO - --- STARTING --- - __init__.py:622
2010-08-26 01:07 INFO - begin processing tv directory: /share/Qmultimedia/TV - __init__.py:757
2010-08-26 01:07 INFO - watching 44 tv show(s) - __init__.py:827
2010-08-26 01:07 INFO - found download file at '/share/Qdownload/sabnzbd/complete/Weeds S06E02 iNTERNAL 720p HDTV x264 SYS/Weeds.S06E02.iNTERNAL.720p.HDTV.x264-SYS.mkv' - __init__.py:858
2010-08-26 01:07 INFO - scanning filesystem for episodes belonging to 'Weeds'... - series.py:232
2010-08-26 01:07 ERROR - list index out of range - __init__.py:1021
Traceback (most recent call last):
  File "/root/.mediarover/mediarover/__init__.py", line 668, in episode_sort
    __episode_sort(broker, options, **params)
  File "/root/.mediarover/mediarover/__init__.py", line 925, in __episode_sort
    desirables = series.filter_undesirables(episode)
  File "/root/.mediarover/mediarover/series.py", line 96, in filter_undesirables
    sample = self.episodes
  File "/root/.mediarover/mediarover/series.py", line 407, in _episodes_prop
    self.__check_episode_lists()
  File "/root/.mediarover/mediarover/series.py", line 332, in __check_episode_lists
    self.__find_series_episodes()
  File "/root/.mediarover/mediarover/series.py", line 253, in __find_series_episodes
    if dirnames[i].startswith('.'):
IndexError: list index out of range
FAILURE, unable to sort downloaded episode! See log file at '/root/.mediarover/logs/sabnzbd_episode_sort.log' for more details!

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

avatarr wrote: As I am obsessive over issues such as these I just couldn't go to bed and leave it hanging. I downloaded 0.5.2, copied it to my .mediarover folder, and still no dice.
Found the bug.  I've release a patch in the form of MR 0.5.3.  Give it a whirl and let me know if you have any problems.

Kierse

avatarr
Newbie
Newbie
Posts: 29
Joined: April 17th, 2010, 9:46 pm

Re: Media Rover

Post by avatarr »

kierse wrote:
avatarr wrote: As I am obsessive over issues such as these I just couldn't go to bed and leave it hanging. I downloaded 0.5.2, copied it to my .mediarover folder, and still no dice.
Found the bug.  I've release a patch in the form of MR 0.5.3.  Give it a whirl and let me know if you have any problems.

Kierse
The links don't seem to be working for me. Did you get tired? :)

http://github.com/kierse/mediarover/zipball/v0.5.3
http://nodeload.github.com/kierse/media ... all/v0.5.3

Post Reply