Media Rover

Got a program that plays well with SABnzbd? Share it here!
hayesb2
Newbie
Newbie
Posts: 7
Joined: November 19th, 2009, 10:21 am

Re: Media Rover

Post by hayesb2 »

GUI update???

mike171562
Newbie
Newbie
Posts: 37
Joined: June 5th, 2009, 12:37 pm

Re: Media Rover

Post by mike171562 »

Guess i answered my own question, had to downgrade to v5 sab, what a PITA!

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

Hey mike171562,
mike171562 wrote: I upgraded to the Dev Version of mediarover and the most recent Sab 6.1, I am getting the error reported earlier

mediarover.error.UnknownQueue: SABnzbd 0.5.0 or greater required!

I tried the suggestion posted earlier about adding check version = False but only get errors from mediarover about not finding the queue, do I need to downgrade Sabnzbd back to version 5 or what?
I should have a fix out for you sometime later today.

Kierse

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

Hey hayesb2,
hayesb2 wrote: GUI update???
I've got a very basic web interface up and running. I'm currently working towards making MR configurable via the web interface. Once that's done I'll push my changes to the dev branch and start adding more features.

Kierse

hayesb2
Newbie
Newbie
Posts: 7
Joined: November 19th, 2009, 10:21 am

Re: Media Rover

Post by hayesb2 »

Thats great! Let me know once the web app is available to download...I'd be willing to beta test...

mike171562
Newbie
Newbie
Posts: 37
Joined: June 5th, 2009, 12:37 pm

Re: Media Rover

Post by mike171562 »

I should have a fix out for you sometime later today.

Thanks, I am  up and running now with an older version of Sab5, i suspect this issue will come up soon as more people upgrade their SAB though.

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

mike171562 wrote: Thanks, I am  up and running now with an older version of Sab5, i suspect this issue will come up soon as more people upgrade their SAB though.
I just pushed MR 0.7.5. It should fix the version check issue you reported. Also, I checked and the __check_version__ flag seems to be work as expected (even with 0.6.x). Did you name the variable correctly? It should be '__check_version__'.

Kierse

mike171562
Newbie
Newbie
Posts: 37
Joined: June 5th, 2009, 12:37 pm

Re: Media Rover

Post by mike171562 »

I updated my Sab back to sabnzbdplus-0.6.1 to test

without getting your latest mediarover update, i get the same error

    raise UnknownQueue("SABnzbd 0.5.0 or greater required!")
mediarover.error.UnknownQueue: SABnzbd 0.5.0 or greater required!

after making the [[sabnzbd]]__check_version__ = False change i get the following error

2011-05-20 16:03 WARNING - No queue found! - schedule.py:226
ERROR: Did not find a configured queue in configuration file.  Unable to proceed

.


after installing your latest updated mediarover kierse-mediarover-v0.7.3-14-g8223b9b.tar.gz i get the same error

2011-05-20 16:14 WARNING - No queue found! - schedule.py:226
ERROR: Did not find a configured queue in configuration file.  Unable to proceed!

mike171562
Newbie
Newbie
Posts: 37
Joined: June 5th, 2009, 12:37 pm

Re: Media Rover

Post by mike171562 »

I used git to get your latest push 

python mediarover.py --version          0.7.5


and removed the __check version stuff and were back in business, thanks alot its working now.

Maverick519
Newbie
Newbie
Posts: 15
Joined: January 16th, 2010, 9:59 pm

Re: Media Rover

Post by Maverick519 »

kierse wrote:
mike171562 wrote: Thanks, I am  up and running now with an older version of Sab5, i suspect this issue will come up soon as more people upgrade their SAB though.
I just pushed MR 0.7.5. It should fix the version check issue you reported. Also, I checked and the __check_version__ flag seems to be work as expected (even with 0.6.x). Did you name the variable correctly? It should be '__check_version__'.

Kierse
It is a non issue if they would have read the message that you sent about it back in febuary when I started using version 6. Ever since I changed the flag in the config mediarover has been humming along with no problems for getting my shows since then with the sab 6 branch.

Maverick519

Maverick519
Newbie
Newbie
Posts: 15
Joined: January 16th, 2010, 9:59 pm

Re: Media Rover

Post by Maverick519 »

mike171562 wrote: I updated my Sab back to sabnzbdplus-0.6.1 to test

without getting your latest mediarover update, i get the same error

    raise UnknownQueue("SABnzbd 0.5.0 or greater required!")
mediarover.error.UnknownQueue: SABnzbd 0.5.0 or greater required!

after making the [[sabnzbd]]__check_version__ = False change i get the following error

2011-05-20 16:03 WARNING - No queue found! - schedule.py:226
ERROR: Did not find a configured queue in configuration file.  Unable to proceed

.


after installing your latest updated mediarover kierse-mediarover-v0.7.3-14-g8223b9b.tar.gz i get the same error

2011-05-20 16:14 WARNING - No queue found! - schedule.py:226
ERROR: Did not find a configured queue in configuration file.  Unable to proceed!


Weird that you are having problems even after changing check version I have been using sab 6 since febuary and since I found out about changing check version back then I haven't had one problem with mediarover working.

Maverick519

jmagg
Newbie
Newbie
Posts: 5
Joined: April 21st, 2010, 5:54 pm

Problem after updating

Post by jmagg »

After a year plus of problem free use, I decided to update sabnzbd+. Mediarover quit working, so I updated that as well. Now, it almost works. It seems to choke on shows with a date instead of sXXeXX. Can someone help? I'd like to get numberwoman and riseon as well as other shows that air daily. Here is a sample log: 2011-06-26 10:45 INFO - scanning filesystem for episodes belonging to 'johnny.riseon'... - series.py:283
2011-06-26 10:45 ERROR - 'FilesystemSingleEpisode' object has no attribute 'year
' - schedule.py:105
Traceback (most recent call last):
  File "/Users/user/mediarover/mediarover/command/schedule.py", line 103, in sc
hedule
    __schedule(broker, options)
  File "/Users/user/mediarover/mediarover/command/schedule.py", line 283, in __
schedule
    __process_item(broker, item, queue, scheduled, drop_from_queue)
  File "/Users/user/mediarover/mediarover/command/schedule.py", line 365, in __
process_item
    if not series.should_episode_be_downloaded(episode):
  File "/Users/user/mediarover/mediarover/series.py", line 79, in should_episod
e_be_downloaded
    if len(self.filter_undesirables(episode, *args)) > 0:
  File "/Users/user/mediarover/mediarover/series.py", line 97, in filter_undesi
rables
    sample = self.episodes
  File "/Users/user/mediarover/mediarover/series.py", line 440, in episodes
    self.__check_episode_lists()
  File "/Users/user/mediarover/mediarover/series.py", line 393, in __check_epis
ode_lists
    self.__find_series_episodes()
  File "/Users/user/mediarover/mediarover/series.py", line 374, in __find_serie
s_episodes
    if self.__is_older_than_oldest(episode):
  File "/Users/user/mediarover/mediarover/series.py", line 402, in __is_older_t
han_oldest
    if oldest > episode.parts()[0]:
  File "/Users/user/mediarover/mediarover/episode/daily.py", line 136, in __gt_
_
    return not self
    mediarover.run()
  File "/Users/user/mediarover/mediarover/__init__.py", line 77, in run
    schedule(broker, args)
  File "/Users/user/mediarover/mediarover/command/schedule.py", line 103, in sc
hedule
    __schedule(broker, options)
  File "/Users/user/mediarover/mediarover/command/schedule.py", line 283, in __
schedule
    __process_item(broker, item, queue, scheduled, drop_from_queue)
  File "/Users/user/mediarover/mediarover/command/schedule.py", line 365, in __
process_item
    if not series.should_episode_be_downloaded(episode):
  File "/Users/user/mediarover/mediarover/series.py", line 79, in should_episod
e_be_downloaded
    if len(self.filter_undesirables(episode, *args)) > 0:
  File "/Users/user/mediarover/mediarover/series.py", line 97, in filter_undesi
rables
    sample = self.episodes
  File "/Users/user/mediarover/mediarover/series.py", line 440, in episodes
    self.__check_episode_lists()
  File "/Users/user/mediarover/mediarover/series.py", line 393, in __check_epis
ode_lists
    self.__find_series_episodes()
  File "/Users/user/mediarover/mediarover/series.py", line 374, in __find_serie
s_episodes
    if self.__is_older_than_oldest(episode):
  File "/Users/user/mediarover/mediarover/series.py", line 402, in __is_older_t
han_oldest
    if oldest > episode.parts()[0]:
  File "/Users/user/mediarover/mediarover/episode/daily.py", line 136, in __gt_
_
    return not self < other
  File "/Users/user/mediarover/mediarover/episode/daily.py", line 139, in __lt_
_
    return (self.year, self.month, self.day) < (other.year, other.month, other.d
ay)
AttributeError: 'FilesystemSingleEpisode' object has no attribute 'year'


TIA,
jmagg

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Problem after updating

Post by kierse »

Hey jmagg,
jmagg wrote:After a year plus of problem free use, I decided to update sabnzbd+. Mediarover quit working, so I updated that as well. Now, it almost works. It seems to choke on shows with a date instead of sXXeXX. Can someone help?
Sorry for the late reply, were you able to figure this problem out? If not, can you tell me what version of SABnzbd and Media Rover you're running?

Kierse

hayesb2
Newbie
Newbie
Posts: 7
Joined: November 19th, 2009, 10:21 am

Re: Media Rover

Post by hayesb2 »

Still no GUI?

User avatar
kierse
Sr. Member
Sr. Member
Posts: 254
Joined: March 5th, 2009, 11:59 pm
Location: Canada
Contact:

Re: Media Rover

Post by kierse »

Hey hayesb2,
hayesb2 wrote:Still no GUI?
I've actually started testing the GUI locally in my own network. It's been slow going as I haven't had much time to dedicate to MR the last couple of months but it is progressing. At the moment it's pretty limited and basically allows you to configure all MR options through the browser. Once its stable enough to start using I'll push everything to the dev branch for those that are interested.

Kierse

Post Reply