CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Got a program that plays well with SABnzbd? Share it here!
RuudBurger
Sr. Member
Sr. Member
Posts: 305
Joined: July 2nd, 2010, 6:11 am

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by RuudBurger » October 29th, 2010, 11:46 am

I don't know where the 5 hours comes from, it should download directly when you have set it to 0 days.
Let me check it out.

Edit: I think it has something to do with the time difference.
It uses the nzb date in the wait for x days calculations. Dunno how to fix this yet. Maybe put -1 in the "wait for day(s)"?
Last edited by RuudBurger on October 29th, 2010, 11:53 am, edited 1 time in total.
CouchPotato - Automatic Movie Downloader
For bugs & feature request go to Lighthouse. For questions & problems go to our support forum

maxrogers
Newbie
Newbie
Posts: 29
Joined: May 24th, 2009, 11:52 am

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by maxrogers » October 29th, 2010, 11:55 am

RuudBurger wrote: I don't know where the 5 hours comes from, it should download directly when you have set it to 0 days.
Let me check it out.

Edit: I think it has something to do with the time difference.
It uses the nzb date in the wait for x days calculations. Dunno how to fix this yet. Maybe put -1 in the "wait for day(s)"?
Not a big deal. I will throw a -1 in there to see what happens. I think you are right though about the nzb date. Another one was grabbed perfectly at that same time and downloaded immediately!  ;)

RuudBurger
Sr. Member
Sr. Member
Posts: 305
Joined: July 2nd, 2010, 6:11 am

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by RuudBurger » October 29th, 2010, 12:11 pm

I'll do a different calculation when waitFor is 0. Let me know if the -1 helps ;)
CouchPotato - Automatic Movie Downloader
For bugs & feature request go to Lighthouse. For questions & problems go to our support forum

perrin
Newbie
Newbie
Posts: 6
Joined: October 30th, 2010, 4:32 am

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by perrin » October 30th, 2010, 4:35 am

Firstoff, im amazed at how much RuudBurger is actually active in this thread.  Thanks so much for the great app mate.

now, unfortunately comes the "im having a problem, halp" bit.  I cant get CouchPotato to save to the config file no matter what.  This means it never saves my sabnzbd api key, or anything else, and hence never works.  If i edit the settings in the program, click save, and then go back to the settings, theyre there, but when i open the config file it empty.  Upon reboot, or restart of the program, when it reloads from the settings file, all settings are gone.

Facts)

#1) have tried deleting the config file and letting it rebuild
#2) on windows, have tried both the precompiled version, and git (currently running git, since its newer)
#3) Couchpotato worked once in the beginning, sorted some of my pre-existing movies, then mysteriously stopped 

Hmmm, any thoughts?

RuudBurger
Sr. Member
Sr. Member
Posts: 305
Joined: July 2nd, 2010, 6:11 am

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by RuudBurger » October 30th, 2010, 4:40 am

This is all on Windows? I have heard of this problem, but it was fixed after a restart.
Are you running from a network (mounted) drive? I had some problems with my VMware (Windows 7) running CP from a network drive..
CouchPotato - Automatic Movie Downloader
For bugs & feature request go to Lighthouse. For questions & problems go to our support forum

perrin
Newbie
Newbie
Posts: 6
Joined: October 30th, 2010, 4:32 am

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by perrin » October 30th, 2010, 4:56 am

All on windows.  I can restart again, but im pretty sure i have within the progress of the problem.  Win2k8 R2.

I saw someone earlier in the thread had a problem with settings not sticking at all, even within the app.  Mine at least show up in app until restart (although they arente written to config, so i dont think they take effect)

perrin
Newbie
Newbie
Posts: 6
Joined: October 30th, 2010, 4:32 am

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by perrin » October 30th, 2010, 4:57 am

Also, local drive.  RAID array, but thats transparent, shouldnt make a difference.  Its not C, (D) but that shouldnt make a difference i would hope. 

RuudBurger
Sr. Member
Sr. Member
Posts: 305
Joined: July 2nd, 2010, 6:11 am

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by RuudBurger » October 30th, 2010, 5:04 am

No, paths should be relative. And if it writes the config the first time, it should write it the second time..
Could you give me temporary access to your CP install? Maybe there are some errors on save I can debug in Firefox.
Just PM them to me if you want.
CouchPotato - Automatic Movie Downloader
For bugs & feature request go to Lighthouse. For questions & problems go to our support forum

blade-runner
Newbie
Newbie
Posts: 46
Joined: August 17th, 2010, 10:44 am

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by blade-runner » October 30th, 2010, 6:11 am

That subtitle feature is awesome except it doesn't seem to work here:

13:01:58 INFO  [    app.lib.cron.subtitle] Just searched for subtitles. Can do a search every 5 minutes.
13:01:56 INFO  [    app.lib.cron.subtitle] Done adding movies to subtitle search.
13:01:56 ERROR [          app.lib.library] Can't find directory:
13:01:56 INFO  [    app.lib.cron.subtitle] Start adding movies to subtitle search.

And the directory's are there, any ideas?

RuudBurger
Sr. Member
Sr. Member
Posts: 305
Joined: July 2nd, 2010, 6:11 am

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by RuudBurger » October 30th, 2010, 6:14 am

It the "Movie destination" in renaming settings (you don't have to have it enabled though, just fill it in)
This is just temporary, as I will create some sort of library thing eventually ;)
CouchPotato - Automatic Movie Downloader
For bugs & feature request go to Lighthouse. For questions & problems go to our support forum

flipz
Newbie
Newbie
Posts: 3
Joined: October 30th, 2010, 10:26 am

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by flipz » October 30th, 2010, 10:49 am

Ok my turn to ask for help. :)  First off I want to say GREAT work on this addon. It looks beautiful. I just installed it a little bit ago and I'm having an issue but with no error.

I have it installed on Windows Home Server (which is the same place that I have sabnzbd and also sick beard, all of which works just fine).
I am using r25

I have added a movie and this is what I'm getting:

Code: Select all

11:36:34 INFO  [.lib.provider.yarr.search] Checking if http://nzbmatrix.com/api-nzb-download.php?id=REMOVED is valid.
11:36:24 INFO  [er.yarr.sources.nzbmatrix] Found: MOVIE 1982 SE INTERNAL DVDRip XviD PARTiCLE
11:36:24 INFO  [er.yarr.sources.nzbmatrix] Found: MOVIE 1982 dvdrip xvid particle
11:36:14 INFO  [         app.lib.cron.eta] No DVD release info found.
11:36:14 INFO  [         app.lib.cron.eta] No Theater release info found.
11:36:14 INFO  [         app.lib.cron.eta] Scanning http://videoeta.com/movie/10600.
11:36:13 INFO  [er.yarr.sources.nzbmatrix] Searching: http://rss.nzbmatrix.com/rss.php?=REMOVED
So from what I can tell it searches, finds it just fine, but never does anything with it. It never sends it to sabnzb and it's still sitting in my wanted queue. Thoughts?

Edit: I figured I'd throw in here that I've restarted both the computer and couch potato, just for good measure.
Last edited by flipz on October 30th, 2010, 10:52 am, edited 1 time in total.

MrAcid
Newbie
Newbie
Posts: 43
Joined: December 8th, 2009, 4:29 pm

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by MrAcid » October 30th, 2010, 10:53 am

Judging from that log I'd say that the NZB/report has been removed but is still showing up in the RSS of NZBMatrix. That's why it won't download.

flipz
Newbie
Newbie
Posts: 3
Joined: October 30th, 2010, 10:26 am

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by flipz » October 30th, 2010, 10:58 am

For what it's worth I can tell you that I can manually search nzbmatrix and both copies that couch potato finds are on there and both are well within my settings (for retention, size, quality, etc).

RuudBurger
Sr. Member
Sr. Member
Posts: 305
Joined: July 2nd, 2010, 6:11 am

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by RuudBurger » October 30th, 2010, 11:15 am

Does it say anything about sabnzbd anywhere? If you add the "http://nzbmatrix.com/api-nzb-download.php?id=REMOVED" manually to sabnzbd does it download?
Check your sabnzbd settings in CP.
CouchPotato - Automatic Movie Downloader
For bugs & feature request go to Lighthouse. For questions & problems go to our support forum

flipz
Newbie
Newbie
Posts: 3
Joined: October 30th, 2010, 10:26 am

Re: CouchPotato - Automatic Movie Downloader via NZB & Torrents!

Post by flipz » October 30th, 2010, 11:32 am

RuudBurger wrote: Does it say anything about sabnzbd anywhere? If you add the "http://nzbmatrix.com/api-nzb-download.php?id=REMOVED" manually to sabnzbd does it download?
Check your sabnzbd settings in CP.
I added the URL manually and it worked just fine. Although it did have to try twice. Is that maybe what's tripping it up? Here's sabnzb's log:

Code: Select all

2010-10-30 12:18:13,150::INFO::[__init__:380] Fetching http://nzbmatrix.com/api-nzb-download.php?REMOVED
2010-10-30 12:18:13,150::INFO::[nzbqueue:92] Saving queue
2010-10-30 12:18:13,150::INFO::[urlgrabber:126] Grabbing URL http://nzbmatrix.com/api-nzb-download.php?REMOVED
2010-10-30 12:19:13,447::INFO::[urlgrabber:171] Retry URL http://nzbmatrix.com/api-nzb-download.php?REMOVED
2010-10-30 12:19:13,447::INFO::[urlgrabber:126] Grabbing URL http://nzbmatrix.com/api-nzb-download.php?REMOVED
2010-10-30 12:19:36,025::INFO::[nzbstuff:396] File ftarh.part.subs.sfv added to queue
And then it continues on with all the files and downloads it.

Edit: First I do want to say what's been said that you are awesome for monitoring this thread! I personally develop things for android and have a hard time keeping up with all of it. No the log doesn't have any errors about sabnzb that I can see. And the settings are all setup. I set them up, saved, rebooted comp and couch potato. All the settings are still there but no go.

Post Reply