MovieGrabber - Completely Automated Movie Downloader

Got a program that plays well with SABnzbd? Share it here!
User avatar
Matr1x
Newbie
Newbie
Posts: 5
Joined: August 18th, 2012, 5:55 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by Matr1x » July 27th, 2013, 5:50 am

When can we expect a new beta or new version of MovieGrabber? I have b4 running without issues on Synology Diskstation for several months now.

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » July 29th, 2013, 4:54 am

Matr1x wrote:When can we expect a new beta or new version of MovieGrabber? I have b4 running without issues on Synology Diskstation for several months now.
glad to hear b4 has been running well for you :-), b5 should be out in around 2 weeks time, there are a lot of changes under the hood for b5, which will hopefully give me a rock solid base from which to add in even more functionality in the future.

menage
Newbie
Newbie
Posts: 2
Joined: August 2nd, 2013, 8:15 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by menage » August 2nd, 2013, 8:43 am

I have just started using version 2.2.4b4 on my Windows 7 HTPC. I still very much in the learning stage however I have noted in earlier posts that UNC is not supported. Is this still the case? If yes will UNC be available in b5?

menage
Newbie
Newbie
Posts: 2
Joined: August 2nd, 2013, 8:15 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by menage » August 3rd, 2013, 8:56 am

I have been trying to use more than one Indexer and have tried configuring NZB Megasearch with MovieGrabber. Has anybody had any luck with a similar configuration. P.S. I do have NZB Megasearch working fine with CouchPotato & Sick Beard

User avatar
Matr1x
Newbie
Newbie
Posts: 5
Joined: August 18th, 2012, 5:55 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by Matr1x » August 17th, 2013, 6:19 pm

binhex wrote: glad to hear b4 has been running well for you :-), b5 should be out in around 2 weeks time, there are a lot of changes under the hood for b5, which will hopefully give me a rock solid base from which to add in even more functionality in the future.
Problems releasing b5? Should be available by now... ;D

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » August 19th, 2013, 3:33 am

its coming Matr1x :-), just taking a bit longer than expected to finish.

newzabby9

Re: MovieGrabber - Completely Automated Movie Downloader

Post by newzabby9 » August 25th, 2013, 12:32 am

Hi all, Would really love some help as I don't understand where to get the details for the Usenet Index configuration. I really would love to understand how to choose or find the port number?

I just tried to use Port 80 as a guess. But when I choose Run Now, nothing appears to happen and this message is still on the home page: Please click on Run Now or Schedule the downloader.

This is how I set the Usenet Index
Hostname: http://www.usenet-crawler.com/
Port: 80

Thanks if anyone can help.

newzabby9

Re: MovieGrabber - Completely Automated Movie Downloader

Post by newzabby9 » August 25th, 2013, 4:27 pm

got it going now! O0 i tied this a few times in last year or so but could never work out usenet configuration.

newzabby9

Re: MovieGrabber - Completely Automated Movie Downloader

Post by newzabby9 » September 8th, 2013, 6:56 am

Hi, just wondering if there is any way to delete an individual item from the Que?

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » September 9th, 2013, 6:12 am

newzabby9 wrote:Hi, just wondering if there is any way to delete an individual item from the Que?
there isn't an option in 2.2.0.b4 however there was a feature request to have this added in and it has now been added to 2.2.0.b5 which is out very shortly.

for now i would recommend releasing any movie in the queue that you want and then purge the remaining items in the queue to clear it down.

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » September 16th, 2013, 10:22 am

ok 2.2.0.b5 is now out and uploaded to sourceforge, if your upgrading then please shutdown moviegrabber and then unzip b5 to the same location as your previous installation, overwriting ALL files.

please be aware of the following when upgrading:-

1. the sqlite db will be deleted when you first run b5, reason for this is multiple changes to the database schema, i will in future versions be looking at a way of upgrading the schema, but for now it will delete, so please make sure you release anything in your queue (if using the queue feature) BEFORE upgrading.

2. post processing rules are now stored in the config.ini instead of sqlite db so please take a screenshot of your post processing rules before upgrading, you will need to re-create these once upgraded.

as always if you see a bug please give me as much detail as possible, ideally with a traceback if possible.

binhex.

troelsdk
Newbie
Newbie
Posts: 4
Joined: December 31st, 2011, 4:11 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by troelsdk » September 17th, 2013, 5:49 am

Hi Binhex,

Thanks for the new version. I have a couple of questions.

1) Installed on my qnap and working fine using "screen", but I can't get it work with daemon-mode. If I do, nothing is written in the logfile and no searches are done. The webinterface is working fine. Do I have to do something other than adding the --daemon when starting?

2) I know this has been asked before, but couldn't find the answer. Is it possible to filter out non-english languaged movies somehow?

Thanks
Troels

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » September 17th, 2013, 7:07 am

hi troelsdk, replies as follows:-

1) hmm strange that should work ok, i have this running on my unraid system using the daemon flag and it works ok, i will take a look at this when i can and confirm its working as expected.

2) at the moment there is no way to filter by language in moviegrabber, i have had a quick look and it looks like the newznab api does have an extended attribute for language so i will take a look and see if i can make use of this. just as a side note kat (torrent index) does have language filtering and this has been implemented in moviegrabber.

edit - quick update on 1), i have tested this running debian and it works as expected, ran moviegrabber with the daemon flag and i can successfully see items appearing in history, so not sure why its not working for you, perhaps its permissions related, are you running this as root?, also try increasing the logging to "info" in configurations/general/logging, then try clicking on "run now" again.

troelsdk
Newbie
Newbie
Posts: 4
Joined: December 31st, 2011, 4:11 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by troelsdk » September 19th, 2013, 2:55 pm

Yes I'm running as root. I also tried to define the pid-path when I ran it.

But to no avail.

- I press the run now
- Moviegrabber log show its running a search and getting results. No errors or anything.
- Nothing is shown in history
- If I press run now again - the "Last Run on" does not update and still no history. And nothing in the log.

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » September 19th, 2013, 3:17 pm

What is the search criteria your using?

Post Reply