MovieGrabber - Completely Automated Movie Downloader

Got a program that plays well with SABnzbd? Share it here!
splnut
Newbie
Newbie
Posts: 35
Joined: February 21st, 2011, 8:46 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by splnut » December 30th, 2013, 10:10 pm

any word on the release of b6?

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » December 31st, 2013, 4:30 am

hi splnut, i promise it is coming soon :-), ive been working away on b6 in the background, got a few more bits to sort out and then onto testing to make sure ive not screwed up anything, once im happy then i will release.

amongst other things i have included a nice new shiny feature called preferred groups in b6, this allows moviegrabber to "upgrade" your existing movie collection by forcing a download of a matching movie with a post group name that matches your preferred defined list, this then means you dont have to worry about keeping tabs on whether your favourite release group later on releases a movie you have already grabbed from some no name group, cool hu?, this sort of thing is becoming important as content is DMCA'd quicker and thus you don't want to miss out on a release, if anything automation is becoming more critical than ever now im my opinion.

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » January 10th, 2014, 12:37 pm

Beta 6 is now uploaded, sorry for the delay guys.

pilGrim
Full Member
Full Member
Posts: 114
Joined: January 9th, 2009, 7:28 pm
Location: Hong Kong, SAR China

Re: MovieGrabber - Completely Automated Movie Downloader

Post by pilGrim » January 12th, 2014, 3:25 am

binhex wrote:Beta 6 is now uploaded, sorry for the delay guys.
Hi Binex,

Many thanks for the new version. I was setting up for a friend and noticed. I did a clean install and movies are being sent to SABnzbd but each time I try to look at the history tab I get an error. He took the computer and I told him I would try and help him with it later. Maybe I missed something in the setup. Will upgrade my install on Mon or Tue and let you know if I get the same issues.

Greg

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » January 12th, 2014, 5:17 am

Is this on windows or another platform? I need the exact error message your getting.

Binhex

pilGrim
Full Member
Full Member
Posts: 114
Joined: January 9th, 2009, 7:28 pm
Location: Hong Kong, SAR China

Re: MovieGrabber - Completely Automated Movie Downloader

Post by pilGrim » January 13th, 2014, 8:19 pm

binhex wrote:Is this on windows or another platform? I need the exact error message your getting.

Binhex
Windows 7 Home Premium

Error is:

500 Internal Server Error
The server encountered an unexpected condition which prevented it from fulfilling the request.

Traceback (most recent call last):
File "cherrypy\_cprequest.pyc", line 656, in respond
File "cherrypy\lib\encoding.pyc", line 188, in __call__
File "cherrypy\_cpdispatch.pyc", line 34, in __call__
File "MovieGrabber.py", line 5663, in index
IndexError: list index out of range
Powered by CherryPy 3.2.2

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » January 14th, 2014, 4:35 am

hi pilgrim, i can see what the issue is but not sure what has caused it, basically your missing the following from the config.ini:-

history_sort_order = desc,postdatesort

so im assuming your config.ini entry is either completely missing or the value for history_sort_order is blank?, can you pm me your config.ini so i can take a look as i cant seem to be able to replicate this issue.

thanks.

pilGrim
Full Member
Full Member
Posts: 114
Joined: January 9th, 2009, 7:28 pm
Location: Hong Kong, SAR China

Re: MovieGrabber - Completely Automated Movie Downloader

Post by pilGrim » January 14th, 2014, 4:55 am

binhex wrote:hi pilgrim, i can see what the issue is but not sure what has caused it, basically your missing the following from the config.ini:-

history_sort_order = desc,postdatesort

so im assuming your config.ini entry is either completely missing or the value for history_sort_order is blank?, can you pm me your config.ini so i can take a look as i cant seem to be able to replicate this issue.

thanks.
Sure thing. It is on a friends computer so I will get it from him and then send it to you.

splnut
Newbie
Newbie
Posts: 35
Joined: February 21st, 2011, 8:46 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by splnut » January 17th, 2014, 12:29 am

For the unraid users, is it as simple as replacing "B5" with "B6" in the plugin and rebooting?

Swedeckard
Newbie
Newbie
Posts: 3
Joined: January 18th, 2014, 2:08 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by Swedeckard » January 18th, 2014, 4:12 am

Hi there,
and first not to forget: a big Thanks for this piece of software!!

A problem though:
after update to b6 I don't get hits anymore, as far as I can tell the log reports a UnicodeDecodeError for everything that passed the filters.
Here's an excerpt from the log file, the end of one hit:

Code: Select all

2014-01-18 09:59:16,628 INFO search_index_thread_nzbs4u_net_1 MovieGrabber filter_os_queued :: System - NZB/Torrent is NOT in Queued table
2014-01-18 09:59:16,628 ERROR search_index_thread_nzbs4u_net_1 MovieGrabber newznab_index :: 
Traceback (most recent call last):
  File "MovieGrabber.py", line 3336, in newznab_index
  File "MovieGrabber.py", line 2675, in filter_check
  File "MovieGrabber.py", line 1243, in filter_os_movies_downloaded
  File "encodings\utf_8.pyc", line 16, in decode
UnicodeDecodeError: 'utf8' codec can't decode byte 0xb3 in position 5: invalid start byte
Any ideas what to do?
Cheers /Deckard

pilGrim
Full Member
Full Member
Posts: 114
Joined: January 9th, 2009, 7:28 pm
Location: Hong Kong, SAR China

Re: MovieGrabber - Completely Automated Movie Downloader

Post by pilGrim » January 18th, 2014, 6:10 am

I just did a clean install and then copied in my old config file. I looked through all the options to make sure they looked right and also checked that I could navigate to all MovieGrabber menus. All looked good but when I run, I get the following error in my log:

2014-01-18 18:57:26,111 ERROR search_index_thread_nzb_su_1 MovieGrabber newznab_index ::
Traceback (most recent call last):
File "MovieGrabber.py", line 3336, in newznab_index
File "MovieGrabber.py", line 2675, in filter_check
File "MovieGrabber.py", line 1243, in filter_os_movies_downloaded
File "encodings\utf_8.pyc", line 16, in decode
UnicodeDecodeError: 'utf8' codec can't decode byte 0xe9 in position 1: invalid continuation byte

I did rebuild the usnet index site settings but still same error.

Thoughts?

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » January 20th, 2014, 6:32 am

hi Swedeckard and pilGrim, you both have the same issue, ive fixed the bug and have posted up 2.2.0.b7 to resolve this issue, please download it, then shutdown moviegrabber, unzip and copy over your existing installtion overwriting all files, then start moviegrabber and let me know if it resolves the issue.

binhex.

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » January 20th, 2014, 6:45 am

splnut wrote:For the unraid users, is it as simple as replacing "B5" with "B6" in the plugin and rebooting?
hi splnut, its not so simple with unraid plugins, im working on an upgrade of the plugin that will allow you to perform an upgrade through the webui, for now you can perform a manual upgrade by simply stopping the plugin, then download the latest beta and unzip and overwrite all files in your installation folder, then start the plugin.

Swedeckard
Newbie
Newbie
Posts: 3
Joined: January 18th, 2014, 2:08 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by Swedeckard » January 20th, 2014, 2:52 pm

Thanks binhex,
b7 works fine for me!
(Updated from b5)

Had to edit my MUST parameter in order not to get "Search criteria MUST exist failed".
Changing from "1080p bluray" to "1080p,bluray" did the trick.
I changed the MUST NOT parameter to the same format as well but haven't verified if that's correct.

I don't understand when a release gets to be on the history page though;
most releases that pass MUST, MUST NOT and Size don't end up on the list.
Is it because that title already is on the history list?
But on the other hand there already are doublets on the list...

Anyways: Keep up the good work!
/Deckard

splnut
Newbie
Newbie
Posts: 35
Joined: February 21st, 2011, 8:46 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by splnut » January 21st, 2014, 1:07 am

Upgraded to B7 on unraid. Can you tell me what is wrong with my config? It wants to download movies that I already have and movies older than what I specified. A sample of the movies it put in my watch folder are: A bittersweet life 2005, Deadfall 1968, Maniac Cop 2 1990, We're the Millers 2013, etc. From the history page it appears to be downloading everything. Unless I have something wrong in my favorites, I don't get it. The date/size/rating of the movies are not matching.

https://skydrive.live.com/redir?resid=8 ... ile%2c.ini

Post Reply