MovieGrabber - Completely Automated Movie Downloader

Got a program that plays well with SABnzbd? Share it here!
binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » August 19th, 2014, 9:16 am

hi redcell, looks like your db has either become corrupt or is missing. shutdown moviegrabber completely then go to the db folder and delete everything in there, then start moviegrabber, this will force the db to be re-created, then try a run now

redcell
Newbie
Newbie
Posts: 18
Joined: May 10th, 2012, 4:59 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by redcell » August 22nd, 2014, 11:18 am

@binhex working now, thanx!!!

redcell
Newbie
Newbie
Posts: 18
Joined: May 10th, 2012, 4:59 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by redcell » August 26th, 2014, 8:51 am

unfortunately I was to premature, tested now for a couple of days, there are no errors anymore, but there are no movies being "fetched", the first time I ran "run now" only 1 movie was fetched in the history, after days, still only this 1 movie is being displayed, and pressing "run now" takes really long to process, I also have enabled scheduling, so every hour MovieGrabber should fetch a list of movies, but after days, it just shows the 1 movie it "fetched" from the first time I ran "run now"

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » September 10th, 2014, 4:13 am

hi redcell, sorry for the delay ive been on holiday, please can you pm me your config.ini minus any apikey information and i will take a look for you.

zinc69
Newbie
Newbie
Posts: 3
Joined: September 27th, 2014, 11:05 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by zinc69 » September 27th, 2014, 11:08 pm

i am getting the same error
Debian / MG 2.2.1.0
after some additional testing the last version that worked correctly was 2.2.0.b7
2.2.0.b9 has the same error as 2.2.1.0

Code: Select all

500 Internal Server Error

The server encountered an unexpected condition which prevented it from fulfilling the request.

Traceback (most recent call last):
  File "/home/zinc/.moviegrabber/lib/site-packages/cherrypy/_cprequest.py", line 656, in respond
    response.body = self.handler()
  File "/home/zinc/.moviegrabber/lib/site-packages/cherrypy/lib/encoding.py", line 188, in __call__
    self.body = self.oldhandler(*args, **kwargs)
  File "/home/zinc/.moviegrabber/lib/site-packages/cherrypy/_cpdispatch.py", line 34, in __call__
    return self.callable(*self.args, **self.kwargs)
  File "/home/zinc/.moviegrabber/MovieGrabber.py", line 6148, in run_now
    SearchIndexThread().checks()
  File "/home/zinc/.moviegrabber/MovieGrabber.py", line 6346, in checks
    self.run()
  File "/home/zinc/.moviegrabber/MovieGrabber.py", line 6388, in run
    search_index_function = getattr(SearchIndex(self.download_type,self.index_site_item), self.search_index_function)
  File "/home/zinc/.moviegrabber/MovieGrabber.py", line 1499, in __init__
    self.movies_replace_cache = list(itertools.chain.from_iterable(os.walk(root_path) for root_path in movies_replace_dir_list))
  File "/usr/lib/python2.7/os.py", line 294, in walk
    for x in walk(new_path, topdown, onerror, followlinks):
  File "/usr/lib/python2.7/os.py", line 294, in walk
    for x in walk(new_path, topdown, onerror, followlinks):
  File "/usr/lib/python2.7/os.py", line 294, in walk
    for x in walk(new_path, topdown, onerror, followlinks):
  File "/usr/lib/python2.7/os.py", line 294, in walk
    for x in walk(new_path, topdown, onerror, followlinks):
  File "/usr/lib/python2.7/os.py", line 284, in walk
    if isdir(join(top, name)):
  File "/usr/lib/python2.7/posixpath.py", line 80, in join
    path += '/' + b
UnicodeDecodeError: 'ascii' codec can't decode byte 0x91 in position 9: ordinal not in range(128)
Powered by CherryPy 3.2.2

Code: Select all

* Parent:   22242 su zinc
 * Terminal: 22249 bash
 * Shell:    21479 sudo bash ./locale-check

Looks good. ♥
 * You are using the en_US.UTF-8 locale.
 * Shell's locale matches terminal's locale.
 * Terminal's locale matches parent process locale.

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » September 30th, 2014, 4:46 am

hi zinc69, that tracelog is not from 2.2.1.0 with the fix in place, can you please try 2.2.1.0 again and paste the traceback if you recieve one, i want to see it fail running 2.2.1.0 as it maybe a slightly different error, link to 2.2.1.0 https://github.com/binhex/moviegrabber/ ... stable.zip you may of been running master branch which does NOT include the fix, got a massive commit coming which should bring all this into sync soon.

zinc69
Newbie
Newbie
Posts: 3
Joined: September 27th, 2014, 11:05 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by zinc69 » September 30th, 2014, 7:34 pm

ok that version works just fine, thanks

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » October 1st, 2014, 3:41 am

zinc69 wrote:ok that version works just fine, thanks
appreciate you taking the time to post back, glad its working!, i am coding away madly on moviegrabber, big changes coming, especially in regards to torrent support.

zinc69
Newbie
Newbie
Posts: 3
Joined: September 27th, 2014, 11:05 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by zinc69 » October 1st, 2014, 7:47 am

a one button/click program update feature would be nice. And since its on github now i would think it wouldn't be too hard to add as sick beard does the same thing.

Rumobritt
Newbie
Newbie
Posts: 1
Joined: October 6th, 2014, 6:00 am
Location: USA

Re: MovieGrabber - Completely Automated Movie Downloader

Post by Rumobritt » October 6th, 2014, 6:03 am

Best Post , And Provide good Information

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » October 15th, 2014, 11:33 am

zinc69 wrote:a one button/click program update feature would be nice. And since its on github now i would think it wouldn't be too hard to add as sick beard does the same thing.
on my list to do :-)

neo_x
Newbie
Newbie
Posts: 30
Joined: March 5th, 2012, 11:23 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by neo_x » October 22nd, 2014, 4:59 pm

hi Binhex

is is maybe possible to check if Kickass Torrents is still working?
I have not been getting any torrents added to the que for a while.

Log file shows the following :
2014-10-22 23:55:52,601 INFO search_index_thread_kat_1 moviegrabber kat_index :: RSS feed httpskickass.to:443/usearch/category%3Ahighres-movies%20language%3Aenglish%20seeds%3A1/?rss=1
2014-10-22 23:55:54,721 INFO search_index_thread_kat_1 moviegrabber kat_index :: Post title is Maleficent 2014 720p BluRay DTS x264-GKNByNW
2014-10-22 23:55:54,721 INFO search_index_thread_kat_1 moviegrabber kat_index :: Post release group GKNByNW
2014-10-22 23:55:54,721 INFO search_index_thread_kat_1 moviegrabber filter_index_search_and :: Index - Search criteria MUST exist passed://
2014-10-22 23:55:54,721 INFO search_index_thread_kat_1 moviegrabber filter_index_search_not :: Index - Search criteria MUST NOT exist passed
2014-10-22 23:55:54,721 INFO search_index_thread_kat_1 moviegrabber kat_index :: Post IMDb link not found
Hope this helps?

regards

Neo_x

ferdi-t
Newbie
Newbie
Posts: 3
Joined: November 5th, 2014, 4:10 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by ferdi-t » November 5th, 2014, 4:14 am

Hi there,

Recently installed Moviegrabber and although it looks promising, I haven't been able to get it to work. A snippet from moviegrabber.log shows the following:

Code: Select all

2014-11-05 08:48:37,414 INFO search_index_thread_kat_1 MovieGrabber kat_index :: KAT Index - Post title is Sin City A Dame to Kill For 2014 1080p BluRay H264 AAC-RARBG
2014-11-05 08:48:37,423 INFO search_index_thread_kat_1 MovieGrabber kat_index :: KAT Index - Post release group RARBG
2014-11-05 08:48:37,440 INFO search_index_thread_kat_1 MovieGrabber kat_index :: KAT Index - Post IMDb link not found
2014-11-05 08:48:37,449 INFO search_index_thread_kat_1 MovieGrabber kat_index :: KAT Index - Post title is The Goat 1981 1080p BluRay x264-CiNEFiLE
2014-11-05 08:48:37,457 INFO search_index_thread_kat_1 MovieGrabber kat_index :: KAT Index - Post release group CiNEFiLE
2014-11-05 08:48:37,473 INFO search_index_thread_kat_1 MovieGrabber kat_index :: KAT Index - Post IMDb link not found
2014-11-05 08:48:37,482 INFO search_index_thread_kat_1 MovieGrabber kat_index :: KAT Index - Post title is Sabotage 2014 BRRip 720p x264 AAC [English_Latino] URBiN4HD
2014-11-05 08:48:37,491 INFO search_index_thread_kat_1 MovieGrabber kat_index :: KAT Index - Post release group not found
2014-11-05 08:48:37,507 INFO search_index_thread_kat_1 MovieGrabber kat_index :: KAT Index - Post IMDb link not found
2014-11-05 08:48:37,516 INFO search_index_thread_kat_1 MovieGrabber kat_index :: KAT Index - Post title is Step Up All In 2014 MULTi 1080p BluRay x264-LOST
2014-11-05 08:48:37,525 INFO search_index_thread_kat_1 MovieGrabber kat_index :: KAT Index - Post release group LOST
2014-11-05 08:48:37,542 INFO search_index_thread_kat_1 MovieGrabber kat_index :: KAT Index - Post IMDb link not found
Using kickass.to as a searchengine, btw.

Any idea what I could do to get everything up and running?

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » November 5th, 2014, 11:55 am

hi ferdi-t, the reason moviegrabber is not picking up as many/any results as expected is due to this issue, as shown in the log:-

"2014-11-05 08:48:37,542 INFO search_index_thread_kat_1 MovieGrabber kat_index :: KAT Index - Post IMDb link not found"

so basically moveigrabber relies on a link to imdb in order to evaluate the movie against the criteria you set, if no link is found then there is no way to check the movie against the imdb site.

however having said all this, i have completely reworked all of this in the latest dev build and it removes the necessity for any imdb links to be present, it instead looks up the title (based on post name) via the omdb and tmdb api's, so in the next release torrent support will be MASSIVELY improved, im also adding in additonal public index sites to give more results. unfortunately for you its not ready quite yet as i need to write a whole new section around client api interaction with deluge/utorrent etc in order to deal with things like magnet links, and thus although you can run it and will see results for movies there will be no easy way to push this to the client, short of downloading the torrent/magnet manually.

@neo_x please also read the above, as your issue is related to the same thing.

im going to try and get something out soon guys, so just hang in there.

binhex.

ferdi-t
Newbie
Newbie
Posts: 3
Joined: November 5th, 2014, 4:10 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by ferdi-t » November 6th, 2014, 6:09 am

Hey Binhex, thanks for the reply. Does this essentially mean that it's not possible yet to use Moviegrabber with a torrent-client? Because in that case I'll stop looking for a solution and see what you come up with.
unfortunately for you its not ready quite yet as i need to write a whole new section around client api interaction with deluge/utorrent etc in order to deal with things like magnet links, and thus although you can run it and will see results for movies there will be no easy way to push this to the client, short of downloading the torrent/magnet manually.
How about using a torrent black hole instead? Dunno about uTorrent, but Deluge and Transmission accept incoming torrents dropped in folder x without breaking a sweat.

Post Reply