[Windows] YoVanilla: Movie and Documentary Post-Processing

Come up with a useful post-processing script? Share it here!

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby polayer5 » September 4th, 2016, 8:48 am

I'm getting the move error to? Is there a bug in the latest script? I have been using this script for years and have not had a problem. Looked over my .ini and everything checks out. Any advice?
polayer5
Newbie
Newbie
 
Posts: 19
Joined: August 7th, 2013, 8:31 pm

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby polayer5 » September 4th, 2016, 11:31 am

StickyDonkey wrote:Hi, I'm stuck with an issue with this script. Its deleting the movie and not moving it to the destination.

SAB Category set to "movies" "+Delete" and "C:\Downloads\NZB\Complete\Movies"

Destination is another machine, mapped to "y:\movies"


I'm getting the same thing.

Preparing to rename and move files...
ERROR: No Files Found in E:\My Downloads\Complete\Movies\A MOVIE ;)!
polayer5
Newbie
Newbie
 
Posts: 19
Joined: August 7th, 2013, 8:31 pm

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby NoTolerance » September 4th, 2016, 11:48 am

polayer5 wrote:I'm getting the move error to? Is there a bug in the latest script? I have been using this script for years and have not had a problem. Looked over my .ini and everything checks out. Any advice?


Are you moving the files to a network drive, too? The more information I have, the more quickly I can troubleshoot the issue.

FYI: there haven't been any major changes to the base code in quite a while, so at the moment, nothing immediately comes to mind as to what would be causing this.

I would suggest reverting back to a previous version for now until I get this checked out.
NoTolerance
Full Member
Full Member
 
Posts: 122
Joined: June 27th, 2012, 9:55 am

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby polayer5 » September 4th, 2016, 5:59 pm

Yes. It's a mapped network drive on Windows 10. Script runs fine until it gets to the moving part.
polayer5
Newbie
Newbie
 
Posts: 19
Joined: August 7th, 2013, 8:31 pm

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby StickyDonkey » September 5th, 2016, 5:11 am

Mine is also mapped to a network drive on on a Windows 2012 server. My Script doesnt have any failure errors at all.



Back With My Brand New Invention: v1.0.0.71
INI File Version: v1.0.0.06
You're running the current version of YoVanilla.
Your INI File is current.
New Job: The Dead Room 2015 BDRip X264-ROVERS-3366
Making sure NZB was processed successfully...
NZB processing completed without error. Yo, VIP! Let's kick it!
Running Job: "C:\Apps\sickbeard\autoProcessTV\YoVanilla.exe" "C:\Downloads\NZB\Complete\Movies\The Dead Room (2015)" "The.Dead.Room.2015.BDRip.X264-ROVERS-3366.nzb" "The Dead Room 2015 BDRip X264-ROVERS-3366" "" "movies" "alt.binaries.moovee" "0"
Subdirectory Check Result: 9
Reading configuration options from C:\Apps\sickbeard\autoProcessTV\YoVanilla.ini
Looks like an HD movie.
Processing as an HD movie.
Formatting date...
Date: 2015
Removed date; renamed title: The Dead Room
Done with date.
Special Edition Folder is now The Dead Room
Processing "The Dead Room"
Preparing to clean up files...
Looking for C:\Downloads\NZB\Complete\Movies\The Dead Room (2015)
Deleted C:\Downloads\NZB\Complete\Movies\The Dead Room (2015)\The Dead Room (2015).nfo
Deleted C:\Downloads\NZB\Complete\Movies\The Dead Room (2015)\The Dead Room (2015).sfv
Deleted C:\Downloads\NZB\Complete\Movies\The Dead Room (2015)\The Dead Room (2015).srr
Preparing to rename and move files...
Only one file left.
Renaming/Moving C:\Downloads\NZB\Complete\Movies\The Dead Room (2015)\The Dead Room (2015).mkv to Y:\Movies\The Dead Room\The Dead Room.mkv SUCCEEDED! Now deleting...
Deleting C:\Downloads\NZB\Complete\Movies\The Dead Room (2015) SUCCEEDED!
Yo man - let's get out of here. Word to your mother.
StickyDonkey
Newbie
Newbie
 
Posts: 3
Joined: September 3rd, 2016, 5:36 pm

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby StickyDonkey » September 8th, 2016, 4:34 am

If i change the destination location from the Mapped drive to the local C drive it works fine. So its having an issue with the mapped drive. I was initially mapping to the C$ admin share but have now created a proper share on the destination server with Everyone Full rights and mapping to that new Share and still doesnt move the file there. Funny thing is, the script still doesnt show an error message when it works or not, still shows SUCCESS.
StickyDonkey
Newbie
Newbie
 
Posts: 3
Joined: September 3rd, 2016, 5:36 pm

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby CranialBlaze » October 8th, 2016, 2:51 am

What are the arguments that need to be passed to the exe, I am looking at cobbling together a phython script to use this with NZBGet.
CranialBlaze
Newbie
Newbie
 
Posts: 14
Joined: May 29th, 2010, 6:57 am

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby NoTolerance » October 10th, 2016, 11:05 am

CranialBlaze wrote:What are the arguments that need to be passed to the exe, I am looking at cobbling together a phython script to use this with NZBGet.


You don't have to pass any arguments to the exe if your script doesn't require any.

Code: Select all
AppPath="C:\SABnzbd\scripts\myapp.exe"
   Full path to script/program (including script or program name to run).

PassArgs=0
   Pass arguments to script/program? Arguments passed are:
   [1] Final destination directory and file name (e.g. "D:\Media\x264\My Film\My Film.mkv")
   [2] Final destination directory (e.g. "D:\Media\x264\My Film")
   [3] Folder name (e.g. "My Film")
   [4] File name (e.g. "My Film.mkv")


Those are the available arguments you can pass to your script after YoVanilla completes.
NoTolerance
Full Member
Full Member
 
Posts: 122
Joined: June 27th, 2012, 9:55 am

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby NoTolerance » October 10th, 2016, 7:37 pm

Okay, to the people having issues using YV with a mapped or network drive: I can't duplicate the issue at the moment. Help me help you by answering these questions:

1) What OS are you using?

2) What type of device are you sending the files to (NAS, a server, etc) and what OS or brand is it?

3) Are you only having this issue with one type of file or all files (e.g. does it only happen with MKVs or is it also happening with AVIs)?

4) Does the problem go away if you use a local drive?

I have my suspicions on what the issue *may* be, but I'd like to gather more information before digging deeper.
NoTolerance
Full Member
Full Member
 
Posts: 122
Joined: June 27th, 2012, 9:55 am

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby MajorMercyFlush » October 14th, 2016, 11:13 pm

NoTolerance wrote:Okay, to the people having issues using YV with a mapped or network drive: I can't duplicate the issue at the moment. Help me help you by answering these questions:

1) What OS are you using?

2) What type of device are you sending the files to (NAS, a server, etc) and what OS or brand is it?

3) Are you only having this issue with one type of file or all files (e.g. does it only happen with MKVs or is it also happening with AVIs)?

4) Does the problem go away if you use a local drive?

I have my suspicions on what the issue *may* be, but I'd like to gather more information before digging deeper.



Hi. I actually reported this error in 2013 and wrote a bit of a breakdown. Mine seemed very specific at the time but I think that was just circumstances masking the issue, the underlying problem is more generic and as I mentioned in my previous post seems to have originated with Windows 8.1 (I did some testing on this it). It was just at the time no one else had reported it. We had a little back and forth in PM trying to work it out.

https://forums.sabnzbd.org/viewtopic.ph ... =60#p90347

At the time you mentioned putting a check to see if the move was successful but I dont know how that panned out.

EDIT: this was added after our initial discussion
1.0.0.64
=========
* Added graceful exit with error code for instances where destination directory is missing or not found.


I'm running windows 10 now and just remembered your script and thought I'd duck in to see if it had been resolved because it was so useful.

At the time I'd suggested some more granular detail to the log file so I could troubleshoot this as back then you also couldn't replicate it.

EDIT: If it is possible could you add just one line to the log file?

Code: Select all
2015-01-15 11:17 - Preparing to clean up files...
2015-01-15 11:17 - Looking for E:\Downloads\ToProcess\Movies\John Wick 2014 720p WEB-DL 750MB MC
2015-01-15 11:17 - Couldn't move E:\Downloads\ToProcess\Movies\John Wick 2014 720p WEB-DL 750MB MC\xyz.mkv as R:\John Wick\John Wick.mkv

^ WHAT IS THE ERROR CODE ON THIS FAIL?

2015-01-15 11:17 - Preparing to rename and move files...
2015-01-15 11:17 - Only one file left.
2015-01-15 11:17 - Renaming/Moving E:\Downloads\ToProcess\Movies\John Wick 2014 720p WEB-DL 750MB MC\xyz.mkv to R:\John Wick\John Wick.mkv SUCCEEDED! Now deleting...



I've also a had a few thoughts on this matter I thought I'd investigate. Is it possible to get the complete command line parameter exactly as sab uses to execute YV? That way I can execute YV as if it was sab doing it and can just keep passing it a completed movie file to run with while I'm testing a few things out without having to keep downloading the movie and having sab do it.

thanks and if I can be of any help...
MajorMercyFlush
Newbie
Newbie
 
Posts: 5
Joined: November 16th, 2013, 7:35 am

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby MajorMercyFlush » October 15th, 2016, 5:33 am

I've solved the deleted files on move! Just tested it with a film coming down through SAB and it worked a treat.
So pretty much ignore the post above except for anecdotal purposes.


Don't mean to drop that and then bail but I made half a dozen changes at the same time as I've had one foot out the door all day and wanted this working after a lightbulb moment.

It is unlikely to be YoVanilla, though I did make a change that affected it directly so it's possible.

I'll roll the changes back until it's where it was and go through it systematically and post the solution ASAP.
MajorMercyFlush
Newbie
Newbie
 
Posts: 5
Joined: November 16th, 2013, 7:35 am

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby NoTolerance » October 17th, 2016, 12:30 pm

MajorMercyFlush wrote:I've solved the deleted files on move! Just tested it with a film coming down through SAB and it worked a treat.
So pretty much ignore the post above except for anecdotal purposes.


Don't mean to drop that and then bail but I made half a dozen changes at the same time as I've had one foot out the door all day and wanted this working after a lightbulb moment.

It is unlikely to be YoVanilla, though I did make a change that affected it directly so it's possible.

I'll roll the changes back until it's where it was and go through it systematically and post the solution ASAP.


I suspect I know where you're going with this and look forward to hearing the results of your testing.

When Sab calls YV, it calls the YoVanilla.exe with the following parameters:

Code: Select all
[1] ; The final directory of the job (full path)
[2] ; The original name of the NZB file
[3] ; Clean version of the job name (no path info and ".nzb" removed)
[4] ; Indexer's report number (if supported)
[5] ; User-defined category
[6] ; Group that the NZB was posted in e.g. alt.binaries.x
[7] ; Status of post processing. 0 = OK, 1=failed verification, 2=failed unpack, 3=1+2


So a command would look like this:

Code: Select all
YoVanilla.exe "D:\sabnzbd\incomplete\Movie.2016.BluRay.1080p.x264.DTS-HDChin" "Movie.2016.BluRay.1080p.x264.DTS-HDChina.nzb" "Movie 2016 BluRay 1080p x264 DTS-HDChina" "" "x264" "alt.binaries.frogs" "0"
NoTolerance
Full Member
Full Member
 
Posts: 122
Joined: June 27th, 2012, 9:55 am

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby idlecogz » November 20th, 2016, 11:39 pm

Hi, Just wondering if there was any resolution to this. Windows 10, network drive failing to move, ticking all the boxes for my issue as well. Switch my movies to a local drive for now but that won't hold for long.

Love the script, thanks for your efforts.
idlecogz
Newbie
Newbie
 
Posts: 1
Joined: November 20th, 2016, 11:36 pm

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby fleinbach » November 21st, 2016, 6:08 am

idlecogz wrote:Hi, Just wondering if there was any resolution to this. Windows 10, network drive failing to move, ticking all the boxes for my issue as well. Switch my movies to a local drive for now but that won't hold for long.


I tried another method a few months ago and all is good so far. It is a free program called Netdrives.
fleinbach
Newbie
Newbie
 
Posts: 21
Joined: January 23rd, 2014, 6:21 am

Re: [Windows] YoVanilla: Movie and Documentary Post-Processi

Postby polayer5 » December 3rd, 2016, 1:06 pm

MajorMercyFlush wrote:I've solved the deleted files on move! Just tested it with a film coming down through SAB and it worked a treat.
So pretty much ignore the post above except for anecdotal purposes.


Don't mean to drop that and then bail but I made half a dozen changes at the same time as I've had one foot out the door all day and wanted this working after a lightbulb moment.

It is unlikely to be YoVanilla, though I did make a change that affected it directly so it's possible.

I'll roll the changes back until it's where it was and go through it systematically and post the solution ASAP.


Can you provide an update or details on how you solved the problem. I'm still trying to isolate what the root cause is. The file appears to download and create a folder where it should. I'm assuming YoVanilla then deletes the file and is not able to find it when it's time to work it's magic and move the file. I would really like to resolve this as soon as possible if anyone can help.

NoTolerance
Would you be able to link a download of each version in the second post? This would be useful in case we need to roll back a version or two due to an outage with the current version. Thank you for your consideration of this request.
polayer5
Newbie
Newbie
 
Posts: 19
Joined: August 7th, 2013, 8:31 pm

PreviousNext

Return to Post-Processing Scripts