All output files getting deleted (sometimes)

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
alex_london
Newbie
Newbie
Posts: 11
Joined: May 25th, 2014, 7:40 am

All output files getting deleted (sometimes)

Post by alex_london » June 9th, 2018, 10:21 am

In the past few months some downloads are completely deleted by SABnzbd for no apparent reason, leaving jobs stuck in the queue in Sonarr or other apps. Re-downloading the same NZB in most cases will work. So the issue is not related to the download itself (e.g. failure during unpack, etc), but something weird within SABnzb...

I'm not able to post the log excerpts directly here as they come up as containing URLs (even though they don't), which I'm restricted from posting as a new user. So I've uploaded them to pastebin dot com,

For example, this shows where SABnzbd "decided" to delete the main .mkv file after it was completed:
pastebin dot com / UN88iVZ3

You'll see the file ("tvslices - sns8 . s02e11 . 720p . web . mkv" - spaces added to avoid this post from being blocked) is being deleted at timestamp 2018-06-08 22:22:08,384.

Re-downloading the same NZB a little later shows it completes successfully, and the file isn't deleted:
pastebin dot com / sZ3kruYc

I'm currently on the latest version of SABnzbd (2.3.4), running on Windows 7 SP2.

Any thoughts?

-Alex

User avatar
safihre
Administrator
Administrator
Posts: 3367
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: All output files getting deleted (sometimes)

Post by safihre » June 9th, 2018, 10:59 am

Strange. From the log it seems you have disabled "Enable folder rename" in Config Switches?

User avatar
safihre
Administrator
Administrator
Posts: 3367
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: All output files getting deleted (sometimes)

Post by safihre » June 9th, 2018, 11:07 am

Could you try again with Direct Unpack disabled?

alex_london
Newbie
Newbie
Posts: 11
Joined: May 25th, 2014, 7:40 am

Re: All output files getting deleted (sometimes)

Post by alex_london » June 9th, 2018, 7:50 pm

safihre wrote:
June 9th, 2018, 10:59 am
Strange. From the log it seems you have disabled "Enable folder rename" in Config Switches?
No, all of the "Naming" section is unchecked.

alex_london
Newbie
Newbie
Posts: 11
Joined: May 25th, 2014, 7:40 am

Re: All output files getting deleted (sometimes)

Post by alex_london » June 9th, 2018, 7:53 pm

safihre wrote:
June 9th, 2018, 11:07 am
Could you try again with Direct Unpack disabled?
Done. Note that this doesn't happen all the time... a rough estimate is maybe 5% of all downloads fail this way, and as I mentioned before it's not reproducible (i.e. the same NZB which failed may later succeed). So I'll keep an eye on it over the next week and report back.

I should also add, I think this problem became more apparent when I upgraded to a faster line (went to gigabit, from a meager 20Mbps). it may have been happening before, but certainly not as often as in the past 6 months or so, which coincides with my line upgrade (I know, correlation does not imply causation and all that!).

pxr5
Newbie
Newbie
Posts: 20
Joined: July 22nd, 2008, 5:10 am

Re: All output files getting deleted (sometimes)

Post by pxr5 » June 11th, 2018, 6:29 am

I noticed this too a few months ago. A completed NZB just disappears with no errors, I thought it was maybe something I was doing wrong or something with my windows installation as I hadn't seen anything remotely like this reported here until I read this post. I have Direct Unpack disabled and haven't had the issue since. I will reenable Direct Unpack and monitor.

User avatar
safihre
Administrator
Administrator
Posts: 3367
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: All output files getting deleted (sometimes)

Post by safihre » June 11th, 2018, 11:53 am

I think it's canceling Direct Unpack after it finished the regular unpack.
One part of the cancelling is to clean the failed Direct Unpack, but that's not the case here.
It shouldn't do that of course.

Could you send me the whole log, not just the last part? [email protected] or via pastebin is also good.

pxr5
Newbie
Newbie
Posts: 20
Joined: July 22nd, 2008, 5:10 am

Re: All output files getting deleted (sometimes)

Post by pxr5 » June 12th, 2018, 6:24 am

I'll keep an eye out for doing it again now I've reenabled Direct Unpack. I'll forward the log as requested if it occurs again. Thanks.

alex_london
Newbie
Newbie
Posts: 11
Joined: May 25th, 2014, 7:40 am

Re: All output files getting deleted (sometimes)

Post by alex_london » June 19th, 2018, 5:58 pm

I re-enabled Direct Unpack after reading the later messages here and the problem has re-occurred with a couple of downloads last night. Full logs (from the time Sonarr snatched the file to the download completing in SAB) have been uploaded:

https://pastebin.com/34FPP1xB

https://pastebin.com/Jn5CeMhU

BTW, when this happens, Sonarr shows the downloads as "stuck" at 100%, and I have to manually remove them from the client before re-attempting the download.

User avatar
safihre
Administrator
Administrator
Posts: 3367
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: All output files getting deleted (sometimes)

Post by safihre » June 20th, 2018, 2:38 am

Could you send me the NZB?

It has something to do with the obfuscation and the order in which the files came in. Still trying to figure out what.
Seems to be timing issue, otherwise many people would have this.

alex_london
Newbie
Newbie
Posts: 11
Joined: May 25th, 2014, 7:40 am

Re: All output files getting deleted (sometimes)

Post by alex_london » June 20th, 2018, 6:08 pm

safihre wrote:
June 20th, 2018, 2:38 am
Could you send me the NZB?
Sent to your [email protected] address.

User avatar
safihre
Administrator
Administrator
Posts: 3367
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: All output files getting deleted (sometimes)

Post by safihre » June 23rd, 2018, 4:45 am

Thanks, will work on a fix.

User avatar
safihre
Administrator
Administrator
Posts: 3367
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: All output files getting deleted (sometimes)

Post by safihre » July 14th, 2018, 3:38 pm

I hope to have fixed it now for the next release :)

pxr5
Newbie
Newbie
Posts: 20
Joined: July 22nd, 2008, 5:10 am

Re: All output files getting deleted (sometimes)

Post by pxr5 » July 16th, 2018, 6:11 am

safihre wrote:
July 14th, 2018, 3:38 pm
I hope to have fixed it now for the next release :)
Great stuff. Mine did it again with 2 files one after the other. I've since disabled direct unpack again. (I didn't send a log as you seem to know the issue)

User avatar
safihre
Administrator
Administrator
Posts: 3367
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: All output files getting deleted (sometimes)

Post by safihre » July 16th, 2018, 1:08 pm

You could try this test build of 2.3.5 and let me know if it happens again?
https://github.com/sabnzbd/sabbuild/rel ... 2.3.5-test

Post Reply