2.3.6Beta1 rss delete not working

Questions and bug reports for Beta releases should be posted here.
Forum rules
Help us help you:
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Hairybiker
Newbie
Newbie
Posts: 47
Joined: October 24th, 2011, 4:18 am

2.3.6Beta1 rss delete not working

Post by Hairybiker »

Running on Mint 19 64bit
When pressing delete on a RSS match item it will not delete, does nothing.

User avatar
safihre
Administrator
Administrator
Posts: 3976
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6Beta1 rss delete not working

Post by safihre »

What Delete button do you mean? In the RSS-page or in the Queue?
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

Hairybiker
Newbie
Newbie
Posts: 47
Joined: October 24th, 2011, 4:18 am

Re: 2.3.6Beta1 rss delete not working

Post by Hairybiker »

The one on the RSS page, to delete a setup search item.

User avatar
safihre
Administrator
Administrator
Posts: 3976
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6Beta1 rss delete not working

Post by safihre »

Could you show us a screenshot?
I couldn't reproduce it.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

Hairybiker
Newbie
Newbie
Posts: 47
Joined: October 24th, 2011, 4:18 am

Re: 2.3.6Beta1 rss delete not working

Post by Hairybiker »

Image

The trash can at the end.
Clicking on it does nothing. Tested on Chromium 70 on Win 7 and Linux Mint 19, checked using an incognito page as well with same result.

User avatar
safihre
Administrator
Administrator
Posts: 3976
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6Beta1 rss delete not working

Post by safihre »

That's very strange, I still can't reproduce it.
Could you right click in the browser, then Inspect Element and then open the Console tab.
If you click the delete-button, do you get an error?

Otherwise: in Status and Interface settings window on the main download-page, set logging-level to +Debug and then try again to remove the filter.
After that, click Show Logging Status and Interface settings window and see if there's some error near the end.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

Hairybiker
Newbie
Newbie
Posts: 47
Joined: October 24th, 2011, 4:18 am

Re: 2.3.6Beta1 rss delete not working

Post by Hairybiker »

I get this on the console tab

jquery-3.2.1.min.js?v=2.3.6Beta1:2 Uncaught TypeError: $(...).tablesort is not a function
at HTMLDocument.<anonymous> (?feed=2.4:15177)
at mightThrow (jquery-3.2.1.min.js?v=2.3.6Beta1:2)
at process (jquery-3.2.1.min.js?v=2.3.6Beta1:2)
favicon.ico/:1 Failed to load resource: net::ERR_NAME_NOT_RESOLVED

No error in the debug log.

I am seeing some "Opening and ending tag mismatch: hr line 6 and body" from nzbindex.nl but that is all.

User avatar
safihre
Administrator
Administrator
Posts: 3976
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6Beta1 rss delete not working

Post by safihre »

That's very strange. Could you send me your rss_data.sab file from "admin_dir" (location: https://sabnzbd.org/wiki/advanced/directory-setup)

At [email protected]
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

Hairybiker
Newbie
Newbie
Posts: 47
Joined: October 24th, 2011, 4:18 am

Re: 2.3.6Beta1 rss delete not working

Post by Hairybiker »

sent

User avatar
safihre
Administrator
Administrator
Posts: 3976
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6Beta1 rss delete not working

Post by safihre »

Very strange.. still can't reproduce it :o
Could you send me the [rss] part of your sabnzbd,ini file?
I won't abuse your API-keys!
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

Hairybiker
Newbie
Newbie
Posts: 47
Joined: October 24th, 2011, 4:18 am

Re: 2.3.6Beta1 rss delete not working

Post by Hairybiker »

sent

AnonyMouse
Newbie
Newbie
Posts: 27
Joined: December 9th, 2017, 10:45 am

Re: 2.3.6Beta1 rss delete not working

Post by AnonyMouse »

Did this ever get figured out? I seem to be running into the same thing. I can't delete rss filters I've applied to a feed. The trash can button toggles state, but doesn't seem to trigger any events.

I'm on 2.3.8 running in a container.

User avatar
safihre
Administrator
Administrator
Posts: 3976
Joined: April 30th, 2015, 7:35 am
Location: Switzerland
Contact:

Re: 2.3.6Beta1 rss delete not working

Post by safihre »

We didn't figure it out.. Maybe you can also send me the [rss] part of your sabnzbd.ini?
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

AnonyMouse
Newbie
Newbie
Posts: 27
Joined: December 9th, 2017, 10:45 am

Re: 2.3.6Beta1 rss delete not working

Post by AnonyMouse »

safihre wrote:
May 22nd, 2019, 6:16 am
We didn't figure it out.. Maybe you can also send me the [rss] part of your sabnzbd.ini?
Certainly! It's late now, but I'll dig it out sometime in the next day and send it over.

Hairybiker
Newbie
Newbie
Posts: 47
Joined: October 24th, 2011, 4:18 am

Re: 2.3.6Beta1 rss delete not working

Post by Hairybiker »

Mine seemed to relate to a single rss from nzbindex. Not sure if it was too long (the rss string) or what but that was the issue.

Post Reply