SSL Errors on Startup [ Docker (binhex/sabnzbdvpn) ]

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
Posts: 23
Joined: December 9th, 2015, 6:15 pm

SSL Errors on Startup [ Docker (binhex/sabnzbdvpn) ]

Post by fatgeek »

I am getting SSL errors all of the sudden on startup.


Downloads are still working, it's just annoying.

I'm running 3.1.1 [99b5a00] via Docker (binhex/sabnzbdvpn) on UnRAID.

I've never had SSL enabled on the server, it's only accessible to my LAN.

SSL is disabled in Settings > General.

I've tried blanking out the cert and key fields, no effect. I've tried point them to my valid Let's Encrypt cert and key, no effect.

Debug logging with ini from my last starttup:
Full Member
Full Member
Posts: 160
Joined: September 2nd, 2017, 3:02 am

Re: SSL Errors on Startup

Post by Puzzled »

Using --https as a parameter to the SABnzbd start up command forces https to be on.

Remove "--https" "8090":
"/usr/lib/sabnzbd/" "--daemon" "--config-file" "/config" "--server" "" "--https" "8090"
User avatar
Release Testers
Release Testers
Posts: 8583
Joined: January 22nd, 2008, 2:22 pm

Re: SSL Errors on Startup

Post by sander »

On top of what Puzzled says:

Talk to your docker creator, so Binhex, because they use the "--https" "8090" ... forcing HTTPS.
Post Reply