BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Report & discuss bugs found in SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
.maxx
Release Testers
Release Testers
Posts: 69
Joined: April 10th, 2008, 6:32 am

BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Post by .maxx »

Hey guy’s,

I can‘t get 3.4.0 to work on M1 Mac mini with macOS 11.6.
I downloaded the newest sabnzbd 3.4.0. Quit 3.3.1 and double clicked on 3.4.0 to launch it.
But nothing happens. No sabnzbd in activity monitor.
Tried to delete the Sabnzbd folder in application support but still no luck.

Please help.

HorseCalledHorse
Newbie
Newbie
Posts: 20
Joined: September 19th, 2011, 8:05 pm

Re: BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Post by HorseCalledHorse »

I think something has changed with the MacOS build between 3.4.0RC1 and 3.4.0 final. I'll open a new thread for this, but support for older operating systems (I run 10.12.6) has also disappeared. I'm guessing the app has been built a different way.

User avatar
sander
Release Testers
Release Testers
Posts: 7715
Joined: January 22nd, 2008, 2:22 pm

Re: BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Post by sander »

Any logging or messages?

What if you open a terminal and start SABnzbd from there? I guess the SABnzbd executable might be in ~/Library/Application Support/SABnzbd/

.maxx
Release Testers
Release Testers
Posts: 69
Joined: April 10th, 2008, 6:32 am

Re: BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Post by .maxx »

Code: Select all

 Last login: Sat Sep 18 09:23:40 on console
[email protected] ~ % /Applications/SABnzbd.app/Contents/MacOS/SABnzbd 
[25667] Error loading Python lib '/Applications/SABnzbd.app/Contents/MacOS/Python': dlopen: dlopen(/Applications/SABnzbd.app/Contents/MacOS/Python, 10): no suitable image found.  Did find:
	/Applications/SABnzbd.app/Contents/MacOS/Python: mach-o, but wrong architecture
	/Applications/SABnzbd.app/Contents/MacOS/Python: stat() failed with errno=1
[email protected] ~ % 


User avatar
sander
Release Testers
Release Testers
Posts: 7715
Joined: January 22nd, 2008, 2:22 pm

Re: BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Post by sander »

Code: Select all

'/Applications/SABnzbd.app/Contents/MacOS/Python' .... mach-o, but wrong architecture
As you're on M1, I guess the python binary (included by the SABnzbd Mac package) hasn't got the M1 binary, but only the x86 binary

Assuming MacOS has the "file" command, can you this:

Code: Select all

file Applications/SABnzbd.app/Contents/MacOS/Python
If possible, can you also do it on an earlier version of SAB (3.4.0 RC1 or 3.3.1) that did work on your M1?

PS:

All this is based on assumpation SABnzbd did provide a M1 binary earlier on. So dual architecture binary: x86 and M1.
And having said that: can you run the SABnzbd 3.4.0 executable with the M1 x86 emulator? AFAIK you can select that from the Mac GUI.

.maxx
Release Testers
Release Testers
Posts: 69
Joined: April 10th, 2008, 6:32 am

Re: BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Post by .maxx »

3.4.0

Code: Select all

 Last login: Mon Sep 20 18:26:59 on ttys000
[email protected] ~ % file /Applications/SABnzbd.app/Contents/MacOS/Python 
/Applications/SABnzbd.app/Contents/MacOS/Python: Mach-O 64-bit dynamically linked shared library x86_64
[email protected] ~ % 
3.3.1

Code: Select all

 Last login: Mon Sep 20 18:27:35 on ttys000
[email protected] ~ % file /Applications/SABnzbd.app/Contents/MacOS/Python 
/Applications/SABnzbd.app/Contents/MacOS/Python: Mach-O 64-bit dynamically linked shared library x86_64
[email protected] ~ % 


User avatar
sander
Release Testers
Release Testers
Posts: 7715
Joined: January 22nd, 2008, 2:22 pm

Re: BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Post by sander »

And my PS?

User avatar
sander
Release Testers
Release Testers
Posts: 7715
Joined: January 22nd, 2008, 2:22 pm

Re: BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Post by sander »

On my Linux: dmg2img to unpack .dmg, then mount resulting .img:


3.3.1:

Code: Select all

[email protected]:/media/sander/SABnzbd-3.3.1/SABnzbd.app/Contents$ file MacOS/SABnzbd
MacOS/SABnzbd: Mach-O 64-bit x86_64 executable, flags:<NOUNDEFS|DYLDLINK|TWOLEVEL|PIE>

[email protected]:/media/sander/SABnzbd-3.3.1/SABnzbd.app/Contents$ file MacOS/Python 
MacOS/Python: Mach-O 64-bit x86_64 dynamically linked shared library, flags:<NOUNDEFS|DYLDLINK|TWOLEVEL|NO_REEXPORTED_DYLIBS>
3.4.0RC1

Code: Select all

[email protected]:/media/sander/SABnzbd-3.4.0RC1/SABnzbd.app/Contents$ file MacOS/Python 
MacOS/Python: Mach-O 64-bit x86_64 dynamically linked shared library, flags:<NOUNDEFS|DYLDLINK|TWOLEVEL|NO_REEXPORTED_DYLIBS>

[email protected]:/media/sander/SABnzbd-3.4.0RC1/SABnzbd.app/Contents$ file MacOS/SABnzbd
MacOS/SABnzbd: Mach-O 64-bit x86_64 executable, flags:<NOUNDEFS|DYLDLINK|TWOLEVEL|PIE>
So: x86_64 only. So M1 Mac must use the x86 emulator.

But then:

3.4.0:

Code: Select all

[email protected]:/media/sander/SABnzbd-3.4.0/SABnzbd.app/Contents$ file ./MacOS/SABnzbd
./MacOS/SABnzbd: Mach-O universal binary with 2 architectures: 
[x86_64:Mach-O 64-bit x86_64 executable, flags:<NOUNDEFS|DYLDLINK|TWOLEVEL|PIE>] 
[arm64:Mach-O 64-bit arm64 executable, flags:<NOUNDEFS|DYLDLINK|TWOLEVEL|PIE>]


[email protected]:/media/sander/SABnzbd-3.4.0/SABnzbd.app/Contents$ file ./MacOS/Python
./MacOS/Python: Mach-O 64-bit x86_64 dynamically linked shared library, flags:<NOUNDEFS|DYLDLINK|TWOLEVEL|NO_REEXPORTED_DYLIBS>
See that? The SABnzbd is dual-binary: also arm64 (but Python is not)

So ... my assumption: the SABnzbd binary is arm64, so MacOS expects the python also to be that ... which is not the case => mach-o error.

This must be a problem/bug in the SABnzbd building process.

User avatar
safihre
Administrator
Administrator
Posts: 4471
Joined: April 30th, 2015, 7:35 am
Contact:

Re: BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Post by safihre »

Will work on this..
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

zer0future
Newbie
Newbie
Posts: 1
Joined: September 20th, 2021, 5:18 pm

Version 3.4.0 will not run on M1 macOS machines.

Post by zer0future »

Hello, I tried to update to the latest release however once I attempt to run the app it will not launch. I receive the prompt about allowing software downloaded from the internet to run and choose to allow but SAB doesn't actually launch. I rebooted and tried to download the DMG again but same issue. I attempted to run it on an M1 Mac mini and M1 MacBook air. Version 3.4.0 installs and runs normally on a Windows 10 machine however. I posted about this on the usenet subreddit over on reddit and someone replied that the latest update wouldn't run on linux also but I can not personally verify that. Thank you.

User avatar
safihre
Administrator
Administrator
Posts: 4471
Joined: April 30th, 2015, 7:35 am
Contact:

Re: BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Post by safihre »

Could you try this version?
https://github.com/sabnzbd/sabnzbd/acti ... 1255094244
You'll need a Github account.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate

brightaxis
Newbie
Newbie
Posts: 3
Joined: September 21st, 2021, 7:45 am

Re: BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Post by brightaxis »

safihre wrote:
September 21st, 2021, 4:51 am
Could you try this version?
SNIP
You'll need a Github account.
Does not launch for me after install - error happened today and I'm glad I'm not the only one facing this.

.maxx
Release Testers
Release Testers
Posts: 69
Joined: April 10th, 2008, 6:32 am

Re: BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Post by .maxx »

Found a workaround.
Right Click on the app -> Information-> activate Rosetta emulation

brightaxis
Newbie
Newbie
Posts: 3
Joined: September 21st, 2021, 7:45 am

Re: BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Post by brightaxis »

.maxx wrote:
September 21st, 2021, 8:34 am
Found a workaround.
Right Click on the app -> Information-> activate Rosetta emulation
Brilliant, worked. I wonder what changed between the updates?

User avatar
sander
Release Testers
Release Testers
Posts: 7715
Joined: January 22nd, 2008, 2:22 pm

Re: BUG - 3.4.0 doesn’t start on macOS 11.6 on M1 Mac Mini

Post by sander »

.maxx wrote:
September 21st, 2021, 8:34 am
Found a workaround.
Right Click on the app -> Information-> activate Rosetta emulation
Ah, I think you're then forcing Rosetta emulation. So that the semi-dual SAB binary does not confuse MacOS anymore.

Nice.

Post Reply