SABnzbd not downloading after updating QKPG on QNAP

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
andyvie
Newbie
Newbie
Posts: 11
Joined: January 20th, 2022, 3:21 pm

SABnzbd not downloading after updating QKPG on QNAP

Post by andyvie »

After updating the SABnzbdQKPG on my QNAP TS-119P II SABnzbd stopped downloading files. Before updating SABnzbd worked fine.
Now, as a nzb-file is imported, the download shows up in the queue, but it doesn't seem to start.

When I test the newsserver on the server config page I get an error message stating that the hostname is invalid. At first I thought there was a problem with my internet connection, but SABnzbd on my laptop works fine with the same server settings. Also, Sickgear on my QNAP works fine too and is sending nzb-files to SABnzbd.
I have removed the hostserver and added it again, but the problem remains.
I have asked OneCD on the QNAP forum, but he refered me to this forum. I hope you can help me.

Information:
QNAP TS-119PII firmware 4.3.3.1864 Build 20211212
QKPG version 210401 (installed via Sherpa)
SABnzb version 3.4.2
Python version 3.10.0 (default, Dec 10 2021, 08:29:27) [GCC 8.4.0] [UTF-8]
Open SSL OpenSSL 1.1.1l 24 Aug 2021

Hostname: newszilla[.]xs4all[.]nl (without brackets)
Port: 563
SSL
Username/Password: <empty> as I use an XS4ALL connection

I would be happy to test SABnzbd with default settings, but I have limited knowledge of SSH, so if it is needed to test with default settings, can someone give me directions in how to make a backup of the sabnzbd.ini file and removing the necessary files from the appropriate folder?

User avatar
sander
Release Testers
Release Testers
Posts: 7955
Joined: January 22nd, 2008, 2:22 pm

Re: SABnzbd not downloading after updating QKPG on QNAP

Post by sander »

DNS not working? No Internet access? Check with:

In SABnzbd's upper right corner, click on the wrench symbol ("Status and interface options"), then click on first tab Status, and there. click on the Refresh Arrow. Copy all info here, but alter your public IPv4 a bit if you want before posting.

andyvie
Newbie
Newbie
Posts: 11
Joined: January 20th, 2022, 3:21 pm

Re: SABnzbd not downloading after updating QKPG on QNAP

Post by andyvie »

Lokaal IPv4-adres 192.168.178.24
Openbaar IPv4-adres 83.162.xxx.xxx
IPv6-adres Geen
Nameserver / DNS opzoeken OK
Gebruikte buffer 0 B (0 artikelen)
Systeemprestaties (Pystone) 5112 Linux-3.4.6-armv5tel-with…
Snelheid van download map 31.3 MB/s (/share/Andy/sabnzbd/temp)
Snelheid van verwerkte downloads map 32.4 MB/s (/share/HDA_DATA/Andy/Dow…)
Internet Bandbreedte 9.6 MB/s (76.8 Mbps)

User avatar
sander
Release Testers
Release Testers
Posts: 7955
Joined: January 22nd, 2008, 2:22 pm

Re: SABnzbd not downloading after updating QKPG on QNAP

Post by sander »

Nice results (except for the Systeemprestaties ... 20 times slower than my Celeron)

Next step: add extra server, for example news.eweka.nl and click on Test Servers ... what do you get?

andyvie
Newbie
Newbie
Posts: 11
Joined: January 20th, 2022, 3:21 pm

Re: SABnzbd not downloading after updating QKPG on QNAP

Post by andyvie »

Hmmm, this is strange. When I add Eweka I first get a message that a username and password is required. When I use a random username and password I get the following error: 502 Authentication Failed.
I tried to add newszilla again (in case of a hidden space or something) and the error message changes back to Invalid hostname (Ongeldige servernaam).

PS I appreciate your help! Sadly, I won't be able to respond until sunday evening. I'll check then for further tests. I wish everyone a nice weekend!

User avatar
sander
Release Testers
Release Testers
Posts: 7955
Joined: January 22nd, 2008, 2:22 pm

Re: SABnzbd not downloading after updating QKPG on QNAP

Post by sander »

So news.eweka.nl works. Good.

Back to newszilla.xs4all.nl

Fun fact: when I fill out in SAB, SAB says "Could not determine connection result ()". What is that?
Also for news.kpn.nl
... Oh, wait, I'm not on Xs4all/KPN network, so my connection is refused.

Your IP 83.162.xxx.xxx is a Xs4all subnet, so that is not the problem.

You might try some other servers from https://www.appelboor.com/newsservers/n ... ll-OK.html
If they work (which I expect) I suspect it's a problem with xs4all or newszilla.xs4all.nl (which nowadays is not hosted by Xs4all/KPN anymore). Then you should contact xs4all.

EDIT

A dirty hack: put in the hard IP address 94.232.116.172 of newszilla.xs4all.nl to circumvent DNS resolving problems, and try again. Turn off SSL, because that will complain.

andyvie
Newbie
Newbie
Posts: 11
Joined: January 20th, 2022, 3:21 pm

Re: SABnzbd not downloading after updating QKPG on QNAP

Post by andyvie »

Hi Sander,

I was thinking the same way. I already found the IP-adres of newszilla, but did not turn off SSL.
I can confirm that using the ip-adres with SSL switched off solves my problem. With SSL turned on I get the following error message:
[Errno 111] [SSL: SSLV3_ALERT_HANDSHAKE_FAILURE] sslv3 alert handshake failure (_ssl.c:997)

I also now know why SABnzbd works without a problem on my laptop. My laptop uses IPv6, while my NAS uses IPv4, so it seems that this problem is IPv4 specific.

Edit:wait, that’s not true. I could ping newszilla from my laptop using ping newszilla.xs4all.nl -4, so it still looks like a problem within my NAS.

Perhaps contacting xs4all is the next step. But if you have other ideas I would be happy to hear them.

Have a nice weekend!

User avatar
sander
Release Testers
Release Testers
Posts: 7955
Joined: January 22nd, 2008, 2:22 pm

Re: SABnzbd not downloading after updating QKPG on QNAP

Post by sander »

Ah ... if SAB is working on your laptop, but not on your QNAP, it's a local problem, on your NAS. I don't think Xs4all is willing & able to help with that.

You can turn on logging to +Debug, and check logging for lines with "happyeyeballs" and "newszilla".

Or just keep the IP address in place.

andyvie
Newbie
Newbie
Posts: 11
Joined: January 20th, 2022, 3:21 pm

Re: SABnzbd not downloading after updating QKPG on QNAP

Post by andyvie »

I did some logging and it seems like something goes wrong with SSL switched on. When I don't switch on SSL resolving newszilla works fine.
Without SSL- switched on, the logfile shows this:

2022-01-24 19:43:20,833::DEBUG::[interface:130] Request POST /api from 192.168.178.20 [Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/97.0.4692.99 Safari/537.36 Edg/97.0.1072.69] {'mode': 'config', 'name': 'test_server', 'apikey':<APIKEY>', 'output': 'json', 'server': 'newszilla.xs4all.nl', 'ajax': '1', 'newszilla.xs4all.nl': '1', 'enable': '1', 'displayname': 'newszilla.xs4all.nl', 'host': 'newszilla.xs4all.nl', 'port': '119', 'username': '', 'password': '', 'connections': '3', 'priority': '0', 'retention': '0', 'timeout': '120', 'ssl_verify': '2', 'ssl_ciphers': '', 'expire_date': '', 'quota': '', 'notes': ''}
2022-01-24 19:43:20,875::INFO::[happyeyeballs:152] Quickest IP address for newszilla.xs4all.nl (port 119, ssl 0, preferipv6 False) is 94.232.116.172
2022-01-24 19:43:20,877::DEBUG::[happyeyeballs:156] Happy Eyeballs lookup and port connect took 27 ms
2022-01-24 19:43:20,878::DEBUG::[downloader:188] newszilla.xs4all.nl: Connecting to address 94.232.116.172

When I switch on SSL, the logfile shows this:
2022-01-24 19:43:06,469::DEBUG::[interface:130] Request POST /api from 192.168.178.20 [Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/97.0.4692.99 Safari/537.36 Edg/97.0.1072.69] {'mode': 'config', 'name': 'test_server', 'apikey':<APIKEY>', 'output': 'json', 'server': 'newszilla.xs4all.nl', 'ajax': '1', 'newszilla.xs4all.nl': '1', 'enable': '1', 'displayname': 'newszilla.xs4all.nl', 'host': 'newszilla.xs4all.nl', 'port': '563', 'ssl': '1', 'username': '', 'password': '', 'connections': '3', 'priority': '0', 'retention': '0', 'timeout': '120', 'ssl_verify': '1', 'ssl_ciphers': '', 'expire_date': '', 'quota': '', 'notes': ''}
2022-01-24 19:43:06,538::INFO::[happyeyeballs:152] Quickest IP address for newszilla.xs4all.nl (port 563, ssl 1, preferipv6 False) is None
2022-01-24 19:43:06,540::DEBUG::[happyeyeballs:156] Happy Eyeballs lookup and port connect took 41 ms
2022-01-24 19:43:06,541::DEBUG::[downloader:191] newszilla.xs4all.nl: No successful IP connection was possible

Can you confirm this indeed isn't an SABnzbd-matter?

User avatar
sander
Release Testers
Release Testers
Posts: 7955
Joined: January 22nd, 2008, 2:22 pm

Re: SABnzbd not downloading after updating QKPG on QNAP

Post by sander »

Code: Select all

2022-01-24 19:43:20,875::INFO::[happyeyeballs:152] Quickest IP address for newszilla.xs4all.nl (port 119, ssl 0, preferipv6 False) is 94.232.116.172

2022-01-24 19:43:06,538::INFO::[happyeyeballs:152] Quickest IP address for newszilla.xs4all.nl (port 563, ssl 1, preferipv6 False) is None
That is ... "interesting" ...


I cannot reproduce with 3.4.2 nor 3.5.0RC4

Code: Select all

2022-01-24 20:02:00,543::INFO::[happyeyeballs:152] Quickest IP address for news.kpn.nl (port 563, ssl 1, preferipv6 False) is 94.232.116.171
2022-01-24 20:02:00,544::DEBUG::[happyeyeballs:156] Happy Eyeballs lookup and port connect took 50 ms
2022-01-24 20:02:00,545::DEBUG::[downloader:188] news.kpn.nl: Connecting to address 94.232.116.171
2022-01-24 20:02:00,665::INFO::[newswrapper:333] [email protected]: Connected using TLSv1.2 (AES128-SHA)

2022-01-24 20:02:10,592::INFO::[happyeyeballs:152] Quickest IP address for news.kpn.nl (port 119, ssl 0, preferipv6 False) is 94.232.116.171
2022-01-24 20:02:10,592::DEBUG::[happyeyeballs:156] Happy Eyeballs lookup and port connect took 9 ms
2022-01-24 20:02:10,594::DEBUG::[downloader:188] news.kpn.nl: Connecting to address 94.232.116.171
At this moment, I can only think "SAB cannot make the SSL connection (using HappyEyeballs)", but you've said SAB can download via SSL from newszilla.xs4all.nl if you hard-specify the IPv4 address. Right?

EDIT

I used news.kpn.nl instead of newszilla.xs4all.nl. They are almost the same (hosted by Abavia), but to be sure:

Code: Select all

2022-01-24 20:17:25,860::INFO::[happyeyeballs:152] Quickest IP address for newszilla.xs4all.nl (port 119, ssl 0, preferipv6 False) is 94.232.116.172
2022-01-24 20:17:25,861::DEBUG::[happyeyeballs:156] Happy Eyeballs lookup and port connect took 23 ms
2022-01-24 20:17:25,862::DEBUG::[downloader:188] newszilla.xs4all.nl: Connecting to address 94.232.116.172


2022-01-24 20:17:44,340::INFO::[happyeyeballs:152] Quickest IP address for newszilla.xs4all.nl (port 563, ssl 1, preferipv6 False) is 94.232.116.172
2022-01-24 20:17:44,341::DEBUG::[happyeyeballs:156] Happy Eyeballs lookup and port connect took 23 ms
2022-01-24 20:17:44,341::DEBUG::[downloader:188] newszilla.xs4all.nl: Connecting to address 94.232.116.172
2022-01-24 20:17:44,416::INFO::[newswrapper:333] [email protected]: Connected using TLSv1.2 (AES128-SHA)
2022-01-24 20:17:47,319::DEBUG::[downloader:188] newszilla.xs4all.nl: Connecting to address 94.232.116.172
2022-01-24 20:17:47,399::INFO::[newswrapper:333] [email protected]: Connected using TLSv1.2 (AES128-SHA)
So no problem.

EDIT

newszilla.xs4all.nl has an IPv6 address, but that should not be the problem, as HappyEyeballs is there to avoid problems with non-reachable IPv6 and IPv4.

Code: Select all

2022-01-24 20:21:15,152::INFO::[happyeyeballs:152] Quickest IP address for newszilla.xs4all.nl (port 119, ssl 0, preferipv6 False) is 2001:67c:174:101:0:65:ff02:172
2022-01-24 20:21:15,152::DEBUG::[happyeyeballs:156] Happy Eyeballs lookup and port connect took 28 ms
2022-01-24 20:21:15,154::DEBUG::[downloader:188] newszilla.xs4all.nl: Connecting to address 2001:67c:174:101:0:65:ff02:172

2022-01-24 20:21:24,805::INFO::[happyeyeballs:152] Quickest IP address for newszilla.xs4all.nl (port 563, ssl 1, preferipv6 False) is 94.232.116.172
2022-01-24 20:21:24,805::DEBUG::[happyeyeballs:156] Happy Eyeballs lookup and port connect took 72 ms
2022-01-24 20:21:24,806::DEBUG::[downloader:188] newszilla.xs4all.nl: Connecting to address 94.232.116.172
2022-01-24 20:21:24,892::INFO::[newswrapper:333] [email protected]: Connected using TLSv1.2 (AES128-SHA)

andyvie
Newbie
Newbie
Posts: 11
Joined: January 20th, 2022, 3:21 pm

Re: SABnzbd not downloading after updating QKPG on QNAP

Post by andyvie »

sander wrote: January 24th, 2022, 2:04 pm
At this moment, I can only think "SAB cannot make the SSL connection (using HappyEyeballs)", but you've said SAB can download via SSL from newszilla.xs4all.nl if you hard-specify the IPv4 address. Right?
No, when I hard-specify the IPv4 address I get the following error:

[Errno 111] [SSL: SSLV3_ALERT_HANDSHAKE_FAILURE] sslv3 alert handshake failure (_ssl.c:997)

User avatar
sander
Release Testers
Release Testers
Posts: 7955
Joined: January 22nd, 2008, 2:22 pm

Re: SABnzbd not downloading after updating QKPG on QNAP

Post by sander »

andyvie wrote: January 25th, 2022, 11:24 am
sander wrote: January 24th, 2022, 2:04 pm
At this moment, I can only think "SAB cannot make the SSL connection (using HappyEyeballs)", but you've said SAB can download via SSL from newszilla.xs4all.nl if you hard-specify the IPv4 address. Right?
No, when I hard-specify the IPv4 address I get the following error:

[Errno 111] [SSL: SSLV3_ALERT_HANDSHAKE_FAILURE] sslv3 alert handshake failure (_ssl.c:997)
That's because SABnzbd checks the certificate against the URL given ... which won't work if you hard-specify an IP address.
You can disable that SSL checking at your settings for newszilla.xs4a..nl: Config -> Server ... make sure Advanced Settings is blue-checked. Then, at settings for newszilla.xs4all.nl, set "Certificate verification" to disabled. Then click Save Changes, and try again.

Another workaround: Config -> Switches: at the top, at "Server IP address selection" try the other two options (so not "Quickest IP ..."). I'm not a fan of this, because newszilla.xs4all.nl also has an IPv6 address, which your NAS probably does not understand ...

andyvie
Newbie
Newbie
Posts: 11
Joined: January 20th, 2022, 3:21 pm

Re: SABnzbd not downloading after updating QKPG on QNAP

Post by andyvie »

sander wrote: January 25th, 2022, 12:29 pm
andyvie wrote: January 25th, 2022, 11:24 am
sander wrote: January 24th, 2022, 2:04 pm
At this moment, I can only think "SAB cannot make the SSL connection (using HappyEyeballs)", but you've said SAB can download via SSL from newszilla.xs4all.nl if you hard-specify the IPv4 address. Right?
No, when I hard-specify the IPv4 address I get the following error:

[Errno 111] [SSL: SSLV3_ALERT_HANDSHAKE_FAILURE] sslv3 alert handshake failure (_ssl.c:997)
That's because SABnzbd checks the certificate against the URL given ... which won't work if you hard-specify an IP address.
You can disable that SSL checking at your settings for newszilla.xs4a..nl: Config -> Server ... make sure Advanced Settings is blue-checked. Then, at settings for newszilla.xs4all.nl, set "Certificate verification" to disabled. Then click Save Changes, and try again.
That gives invalid hostname again.
Another workaround: Config -> Switches: at the top, at "Server IP address selection" try the other two options (so not "Quickest IP ..."). I'm not a fan of this, because newszilla.xs4all.nl also has an IPv6 address, which your NAS probably does not understand ...
When I use both the other options I get [Errno 111] [SSL: SSLV3_ALERT_HANDSHAKE_FAILURE] sslv3 alert handshake failure (_ssl.c:997).

It seems like something in SSL/TLS is broken (don't have any knowledge of that). Perhaps this is a problem in one of the packages SABnzbd uses on my QNAP and not SABnzbd itself?

User avatar
OneCD
Sr. Member
Sr. Member
Posts: 472
Joined: March 4th, 2017, 3:47 pm

Re: SABnzbd not downloading after updating QKPG on QNAP

Post by OneCD »

@andyvie, if you’ve not yet reinstalled Entware, can you please do so? Just to rule-out any issues with your Python installation:

Code: Select all

sherpa reinstall ew
Stuff I like: Apache BASH CRON DD-WRT Debian DNSMasq Entware FireFox GitHub ImageMagick Java Kate KDE LibreELEC Netrunner NFS NVIDIA OpenVPN Orvibo-S20 pfSense Python Raspberry-Pi RAID SABnzbd Transmission Usenet VirtualBox Watcher3 XFCE

andyvie
Newbie
Newbie
Posts: 11
Joined: January 20th, 2022, 3:21 pm

Re: SABnzbd not downloading after updating QKPG on QNAP

Post by andyvie »

OneCD wrote: January 25th, 2022, 2:03 pm @andyvie, if you’ve not yet reinstalled Entware, can you please do so? Just to rule-out any issues with your Python installation:

Code: Select all

sherpa reinstall ew
Hey OneCD. I have done that, but sadly no change. The error messages are the same after the reinstall of Entware.

Oh well. It works without SSL. I download from a server provided by my internet provider, so using SSL would be nice, but isn’t a necessity I guess
Last edited by andyvie on January 25th, 2022, 2:24 pm, edited 1 time in total.

Post Reply