Sending NZB's from Indexer & SSL Issue

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
Sekt0r
Newbie
Newbie
Posts: 1
Joined: November 28th, 2022, 6:21 am

Sending NZB's from Indexer & SSL Issue

Post by Sekt0r »

Hello, what would be some possible reasons that would prevent a particular indexer (DrunkenSlug) from being able to send NZB's to Sabnzbd only when using HTTPS but no issues with regular HTTP?

And I don't have (and never have had) this issue with any other indexer, all others work fine with my usual DynDNS address and HTTPS port (including Sonarr and Sab related Android apps). I assume this is my issue because I've always had this issue with DrunkenSlug (for years) and I can't find a single mention of this problem from anyone else online.

I'm using Sabnzbd 3.7.0 with Windows 10 (Pro), my Sab host is set to 0.0.0.0. When I try to add an NZB using HTTPS, I get the usual blue box in DrunkenSlug that states it's been added to my queue but there's nothing in Sabnzbd and nothing in the Sabnzbd log relating to that action. During testing I did manage to set it to something that at least showed there is some sort of connectivty happening - I changed my DrunkenSlug API URL and appended sabnzbd/api to my usual host address and tried adding a NZB, I then get the "no API key added to third party program error".

Makes no difference whether I give DrunkenSlug my Full or NZB API key (currently set to NZB), also tried a different browser (I use Brave Browser; Chrome based) and I tried my direct IP address with no DynDNS involved, tried VPN and no VPN, tried adding the port to Windows Firewall manually (seemed pointless since it works fine everywhere else), I dont have an Antivirus, I tried turning on allow_old_ssl_tls, tried saying Sabnzbd 3 times not unlike a magical spell, nothing works.

Simply reverting in my DrunkSlug account, my address to http and using the same DynDNS address/hostname and non-HTTPS Sab port, all is working again... I did try switching the ports around, so making the HTTP port my HTTPS port since I know that port works with DrunkenSlug but apparently not with HTTPS.. Any ideas come to mind?
User avatar
sander
Release Testers
Release Testers
Posts: 8228
Joined: January 22nd, 2008, 2:22 pm

Re: Sending NZB's from Indexer & SSL Issue

Post by sander »

Do it the easy way: in SAB fill out Drunkenslug's car RSS URL, and SAB will poll Drunkenslug each 15 minutes.

No port forwarding, no DynDNS needed. And the RSS URL is HTTPS, so it's safe.


Go to https://drunkenslug.com/cart , at the top there is the text "Your cart can be downloaded as an RSS Feed." ... click on it. Then get the URL from your browser and put it into SAB's RSS setting.

Done
Post Reply