Mac packaged app not launching on boot

Report & discuss bugs found in SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
jbrn
Newbie
Newbie
Posts: 2
Joined: December 2nd, 2022, 3:31 pm

Mac packaged app not launching on boot

Post by jbrn »

Apologies if this is a known issue. A brief search did not find any similar reports.

On my M1 Mac Studio running latest OS Ventura, sabnzbd appears to have trouble launching at system start. I’ve just used the usual “Login Items” system preferences option, which works for the *arr apps. Sabnzbd launches fine after boot manually.

I can try to grab logs later if needed.
User avatar
safihre
Administrator
Administrator
Posts: 4922
Joined: April 30th, 2015, 7:35 am
Contact:

Re: Mac packaged app not launching on boot

Post by safihre »

Hmmm, could you enable Debug logging in the Status window and then after it happens again click Show Logging in the Status window. Does it show anything at boot times?
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate
jbrn
Newbie
Newbie
Posts: 2
Joined: December 2nd, 2022, 3:31 pm

Re: Mac packaged app not launching on boot

Post by jbrn »

Fixed myself. Sorry for the static. Fantastic program, by the way.

I had just moved from a different system and forgot the little detail about "Host SABnzbd should listen on" needing to be 0.0.0.0. Logs showed a failure to secure the socket. It wasn't obvious that should cause an issue at boot but no when launching manually.
User avatar
safihre
Administrator
Administrator
Posts: 4922
Joined: April 30th, 2015, 7:35 am
Contact:

Re: Mac packaged app not launching on boot

Post by safihre »

Great, I'm not really a Mac expert so wouldn't known how to help otherwise 🤣
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate
Post Reply