4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Questions and bug reports for Beta releases should be posted here.
Forum rules
Help us help you:
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
HorseCalledHorse
Newbie
Newbie
Posts: 36
Joined: September 19th, 2011, 8:05 pm

4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by HorseCalledHorse »

Found an issue running 4.1.0Alpha 1 on macOS (on two different machines, one M1 running Ventura, one Intel running Monterey) where using the Multi-Operations toggle to set the Category (TV, Movies, etc) simply doesn't work. Setting each one individually (ie, not using Multi-Operations) does work. No such issue with 4.0.3.
User avatar
safihre
Administrator
Administrator
Posts: 5196
Joined: April 30th, 2015, 7:35 am
Contact:

Re: 4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by safihre »

What browser do you use? Safari?
Could you verify if it works on Chrome or Firefox?
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate
HorseCalledHorse
Newbie
Newbie
Posts: 36
Joined: September 19th, 2011, 8:05 pm

Re: 4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by HorseCalledHorse »

safihre wrote: August 21st, 2023, 3:54 am What browser do you use? Safari?
Could you verify if it works on Chrome or Firefox?
Yes, I do use Safari. Always have and have never had an issue with this before. But I just tried it (with numerous files) using Chrome and Firefox and get exactly the same issue: setting the category in Multi-Operations with this alpha has no effect. Everything ends up in the default directory, with none of the sorting rules applied.

Maybe someone could try it on another system to see if it's specifically a macOS issue.

Should also note that reverting to 4.0.3 fixes the issue and Multi-Operations goes back to working as intended.
User avatar
safihre
Administrator
Administrator
Posts: 5196
Joined: April 30th, 2015, 7:35 am
Contact:

Re: 4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by safihre »

I can't reproduce this on Windows in any browser, so quite strange..
Will test on my Mac later.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate
HorseCalledHorse
Newbie
Newbie
Posts: 36
Joined: September 19th, 2011, 8:05 pm

Re: 4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by HorseCalledHorse »

safihre wrote: August 21st, 2023, 4:36 am I can't reproduce this on Windows in any browser, so quite strange..
Will test on my Mac later.
Thanks, safihre.

Definitely sounds like a macOS build issue then.
HorseCalledHorse
Newbie
Newbie
Posts: 36
Joined: September 19th, 2011, 8:05 pm

Re: 4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by HorseCalledHorse »

Issue persists with 4.1.0b1 for me.
User avatar
safihre
Administrator
Administrator
Posts: 5196
Joined: April 30th, 2015, 7:35 am
Contact:

Re: 4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by safihre »

I tried it on my MacBook and can't reproduce it on Safari and Chrome.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate
HorseCalledHorse
Newbie
Newbie
Posts: 36
Joined: September 19th, 2011, 8:05 pm

Re: 4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by HorseCalledHorse »

safihre wrote: August 30th, 2023, 2:09 am I tried it on my MacBook and can't reproduce it on Safari and Chrome.
That's great to know. Must be something with my settings. Is there anything I can do to track down the problem, besides starting from scratch?
User avatar
safihre
Administrator
Administrator
Posts: 5196
Joined: April 30th, 2015, 7:35 am
Contact:

Re: 4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by safihre »

Could you enable Debug logging in the Status window, pause the queue (to prevent noise in the logs) and then try the multi operations?
Then click Show Logging in the Status window and share the log with me at [email protected]
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate
HorseCalledHorse
Newbie
Newbie
Posts: 36
Joined: September 19th, 2011, 8:05 pm

Re: 4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by HorseCalledHorse »

Sending the log now.
HorseCalledHorse
Newbie
Newbie
Posts: 36
Joined: September 19th, 2011, 8:05 pm

Re: 4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by HorseCalledHorse »

No idea why, but I'm still experiencing this issue with 4.10RC2 on both of my Macs. Doesn't matter if I use Safari, Firefox or Chrome, selecting Multi-Operations has no effect. And switching back to 4.0.3 fixes it immediately.

Is there nothing that has changed in the code that could be causing this?
User avatar
safihre
Administrator
Administrator
Posts: 5196
Joined: April 30th, 2015, 7:35 am
Contact:

Re: 4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by safihre »

I couldn't find anything... Hopefully now it's an release candidate, more people will try and maybe have the same problem.
If you like our support, check our special newsserver deal or donate at: https://sabnzbd.org/donate
HorseCalledHorse
Newbie
Newbie
Posts: 36
Joined: September 19th, 2011, 8:05 pm

Re: 4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by HorseCalledHorse »

safihre wrote: September 14th, 2023, 11:34 am I couldn't find anything... Hopefully now it's an release candidate, more people will try and maybe have the same problem.
I feel bad about hoping other people have the same problem, but yeah, I hope so ::)
HorseCalledHorse
Newbie
Newbie
Posts: 36
Joined: September 19th, 2011, 8:05 pm

Re: 4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by HorseCalledHorse »

No great surprise, but this is still happening in the released version of 4.1.0. Wonder if this will now bite anybody else.
Howitzer
Newbie
Newbie
Posts: 27
Joined: September 15th, 2016, 8:55 pm

Re: 4.1.0Alpha1 Multi-Operations (Categories) not working on macOS

Post by Howitzer »

Having the same issue with PROD build of 4.1 on Windows 10 using Chrome....

viewtopic.php?p=130415

@safihre - I reupdated to 4.1 enabled debugging and tried to do some mass changes, there was nothing added to the log.
Post Reply