SABCTools fails with no attribute 'bytearray_malloc'

Support for the Debian/Ubuntu package, created by JCFP.
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
oldgrumpy
Newbie
Newbie
Posts: 6
Joined: June 27th, 2014, 1:03 pm

SABCTools fails with no attribute 'bytearray_malloc'

Post by oldgrumpy »

Just upgraded from 3.7.1 to 4.2.1 [18f4cc2]. Using Mint LMDE 6 (debian 12).
Python 3.11.2 (main, Mar 13 2023, 12:18:29)
Start up with "/opt/SABnzbd-4.2.1/SABnzbd.py" "--disable-file-log" "--logging" "1" "--browser" "0"

When I first tried to run python3 was externally managed so I was using "apt-get install python3-xxxx"

Sabctools installed python3-sabctools_7.1.2-1~bpo12+1_amd64.deb. Found out I needed 8.1 but apt did not have it. Remove EXTERNALLY_MANAGED and used "pip install". Went through the requirements.txt and everything is up to date now.

No errors show up in the logs. When I attempt to test a server I get the errors: "module 'sabctools' has no attribute 'bytearray_malloc'".

Have no idea what this means especially since I m running the current version. Everything looks fine, the queue has items and will not download nything.

Please Help!

This is the log file with the debug option - nothing but what my settings are at https://pastes.io/oepqrqnobr
User avatar
sander
Release Testers
Release Testers
Posts: 8777
Joined: January 22nd, 2008, 2:22 pm

Re: SABCTools fails with no attribute 'bytearray_malloc'

Post by sander »

How good are you with Debian?
oldgrumpy
Newbie
Newbie
Posts: 6
Joined: June 27th, 2014, 1:03 pm

Re: SABCTools fails with no attribute 'bytearray_malloc'

Post by oldgrumpy »

Decent. Been playing around with it for years.
User avatar
sander
Release Testers
Release Testers
Posts: 8777
Joined: January 22nd, 2008, 2:22 pm

Re: SABCTools fails with no attribute 'bytearray_malloc'

Post by sander »

OK. I'm asking because python module can be difficult. Plus you have other errors in your sabnzbd.log ... not good.

"module 'sabctools' has no attribute 'bytearray_malloc'".

My guess: you still have an old sabctools which does not have that function.

So ... do the below on your debian and post the output here.

Code: Select all

$ python3
Python 3.10.12 (main, Nov 20 2023, 15:14:05) [GCC 11.4.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import sabctools

>>> sabctools.__path__
['/usr/lib/python3/dist-packages/sabctools']

>>> sabctools.__version__
'8.1.0'

>>> sabctools.bytearray_malloc(0)
bytearray(b'')
           
 
oldgrumpy
Newbie
Newbie
Posts: 6
Joined: June 27th, 2014, 1:03 pm

Re: SABCTools fails with no attribute 'bytearray_malloc'

Post by oldgrumpy »

Sander,

Thank you! I did remove sbctools using apt AFTER installing the newer version using pip then I reinstalled the new one using pip again. That did not fix it, but I started tinkering with par2cmdline-turbo, dowloaded it removed the previous par2 version then built and installed. Great! That did it. Probably both affected each other somehow, It's seems to be running completly and is now even downloading.

Paul
User avatar
sander
Release Testers
Release Testers
Posts: 8777
Joined: January 22nd, 2008, 2:22 pm

Re: SABCTools fails with no attribute 'bytearray_malloc'

Post by sander »

Top!
Post Reply