MovieGrabber - Completely Automated Movie Downloader

Got a program that plays well with SABnzbd? Share it here!
neo_x
Newbie
Newbie
Posts: 30
Joined: March 5th, 2012, 11:23 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by neo_x » May 7th, 2014, 8:46 am

binhex wrote:no probs, if you get an arch linux vm running on unraid and want to get moviegrabber running then download the following file and run pacman -U <package name> working well for me

http://sourceforge.net/projects/moviegr ... z/download

Still haven't jumped ship to arch yet (have enough performance to run a windows VM, and trust it quite well.)

will probably dab my toe into an ARch downloader if time allows :) , but for now ill rather wait for you to release the windows binary (or how is there a way to update it myself?

thx

splnut
Newbie
Newbie
Posts: 35
Joined: February 21st, 2011, 8:46 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by splnut » May 9th, 2014, 10:59 pm

I installed the package on arch and am having trouble getting it started. The arch VM is currently running couch, sick, sab, head, and plex. When starting MovieGrabber, I get the error below. There is no config or logs created.

[[email protected]_v3 moviegrabber]# python MovieGrabber.py
File "MovieGrabber.py", line 692
print "byte string"
^
SyntaxError: invalid syntax
[[email protected]_v3 moviegrabber]#

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » May 10th, 2014, 3:41 am

Hi splnut you need to specify the version of python, as arch has both python 3 and python 2 installed, start it with python2 MovieGrabber.py or just run systemctl enable moviegrabber and reboot and it will start on boot or run systemctl start moviegrabber ☺
Last edited by binhex on May 10th, 2014, 3:57 am, edited 1 time in total.

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » May 10th, 2014, 3:47 am

Hi neo I hear your pain I will try my best to get the next beta out by the end of next week latest to fix the torrent issue. Going to be looking into adding piratebay support next

neo_x
Newbie
Newbie
Posts: 30
Joined: March 5th, 2012, 11:23 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by neo_x » May 10th, 2014, 6:19 am

binhex wrote:Hi neo I hear your pain I will try my best to get the next beta out by the end of next week latest to fix the torrent issue. Going to be looking into adding piratebay support next
thx!

Much appreciated :)


*adds another beer to the pile*

splnut
Newbie
Newbie
Posts: 35
Joined: February 21st, 2011, 8:46 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by splnut » May 10th, 2014, 7:12 am

This is what I got when using systemctl.

[roo[email protected]_v3 ~]# systemctl status moviegrabber
● moviegrabber.service - MovieGrabber automated movie downloader
Loaded: loaded (/usr/lib/systemd/system/moviegrabber.service; disabled)
Active: failed (Result: exit-code) since Sat 2014-05-10 13:14:59 BST; 6s ago
Process: 1727 ExecStart=/usr/bin/env python2 /opt/moviegrabber/MovieGrabber.py (code=exited, status=217/USER)
Main PID: 1727 (code=exited, status=217/USER)

May 10 13:14:59 ArchApplianceVM_v3 systemd[1]: Started MovieGrabber automated movie downloader.
May 10 13:14:59 ArchApplianceVM_v3 systemd[1]: moviegrabber.service: main process exited, code=exited, status=217/USER
May 10 13:14:59 ArchApplianceVM_v3 systemd[1]: Unit moviegrabber.service entered failed state.
[[email protected]_v3 ~]#

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » May 11th, 2014, 1:47 pm

Hi splnut that's odd that it's not starting, can you run it via python2 MovieGrabber.py and send me the output please, also check the log files for any traceback messages

splnut
Newbie
Newbie
Posts: 35
Joined: February 21st, 2011, 8:46 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by splnut » May 11th, 2014, 2:08 pm

Python2 MovieGrabber.py works fine. I tried systemctl again with same results.


rZn
Newbie
Newbie
Posts: 1
Joined: February 23rd, 2013, 2:09 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by rZn » May 15th, 2014, 8:25 pm

splnut wrote:This is what I got when using systemctl.

[[email protected]_v3 ~]# systemctl status moviegrabber
● moviegrabber.service - MovieGrabber automated movie downloader
Loaded: loaded (/usr/lib/systemd/system/moviegrabber.service; disabled)
Active: failed (Result: exit-code) since Sat 2014-05-10 13:14:59 BST; 6s ago
Process: 1727 ExecStart=/usr/bin/env python2 /opt/moviegrabber/MovieGrabber.py (code=exited, status=217/USER)
Main PID: 1727 (code=exited, status=217/USER)

May 10 13:14:59 ArchApplianceVM_v3 systemd[1]: Started MovieGrabber automated movie downloader.
May 10 13:14:59 ArchApplianceVM_v3 systemd[1]: moviegrabber.service: main process exited, code=exited, status=217/USER
May 10 13:14:59 ArchApplianceVM_v3 systemd[1]: Unit moviegrabber.service entered failed state.
[[email protected]_v3 ~]#
I changed user:group in '/usr/lib/systemd/system/moviegrabber.service' and chowned ' /opt/moviegrabber/' to the user:group

//rZn

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » May 16th, 2014, 7:27 am

hi rzn, many thanks for your post, you are indeed correct, the moviegrabber package was not correctly setting permissions and ownership for the install moviegrabber folder and thus wasnt able to run as user moviegrabber. this was due to a CR issue in the install script and has now been resolved and the new package recompiled.

splnut - can you please stop moviegrabber and then do a rm -R /op/moviegrabber to remove the current install then download the package again (same location) and reinstall using pacman again, this works for me on a clean install of arch linux so im confident it should now be able to call systemctl and get moviegrabber to start/run on boot as expected, if your still having issues let me know.

cheers guys!.

splnut
Newbie
Newbie
Posts: 35
Joined: February 21st, 2011, 8:46 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by splnut » May 19th, 2014, 10:24 pm

binhex wrote:hi rzn, many thanks for your post, you are indeed correct, the moviegrabber package was not correctly setting permissions and ownership for the install moviegrabber folder and thus wasnt able to run as user moviegrabber. this was due to a CR issue in the install script and has now been resolved and the new package recompiled.

splnut - can you please stop moviegrabber and then do a rm -R /op/moviegrabber to remove the current install then download the package again (same location) and reinstall using pacman again, this works for me on a clean install of arch linux so im confident it should now be able to call systemctl and get moviegrabber to start/run on boot as expected, if your still having issues let me know.

cheers guys!.
I followed your instructions but still having issues.

Code: Select all

[[email protected]_v3 opt]# rm -R /opt/moviegrabber
[[email protected]_v3 Software]# pacman -U moviegrabber-2.2.0.b8-1-any.pkg.tar\ \(1\)
loading packages...
warning: moviegrabber-2.2.0.b8-1 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

Packages (1): moviegrabber-2.2.0.b8-1

Total Installed Size:   11.29 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                                                                                                 [#######################################################################################] 100%
(1/1) checking package integrity                                                                                                               [#######################################################################################] 100%
(1/1) loading package files                                                                                                                    [#######################################################################################] 100%
(1/1) checking for file conflicts                                                                                                              [#######################################################################################] 100%
(1/1) checking available disk space                                                                                                            [#######################################################################################] 100%
(1/1) reinstalling moviegrabber                                                                                                                [#######################################################################################] 100%
[[email protected]_v3 configs]# systemctl start moviegrabber
[[email protected]_v3 configs]# systemctl status moviegrabber
● moviegrabber.service - MovieGrabber automated movie downloader
   Loaded: loaded (/usr/lib/systemd/system/moviegrabber.service; enabled)
   Active: failed (Result: exit-code) since Tue 2014-05-20 04:24:26 BST; 15s ago
  Process: 17485 ExecStart=/usr/bin/env python2 /opt/moviegrabber/MovieGrabber.py (code=exited, status=1/FAILURE)
 Main PID: 17485 (code=exited, status=1/FAILURE)

May 20 04:24:24 ArchApplianceVM_v3 systemd[1]: Started MovieGrabber automated movie downloader.
May 20 04:24:26 ArchApplianceVM_v3 env[17485]: Traceback (most recent call last):
May 20 04:24:26 ArchApplianceVM_v3 env[17485]: File "/opt/moviegrabber/MovieGrabber.py", line 317, in <module>
May 20 04:24:26 ArchApplianceVM_v3 env[17485]: config_write()
May 20 04:24:26 ArchApplianceVM_v3 env[17485]: File "/opt/moviegrabber/MovieGrabber.py", line 308, in config_write
May 20 04:24:26 ArchApplianceVM_v3 env[17485]: with open(config_ini, 'w') as configini:
May 20 04:24:26 ArchApplianceVM_v3 env[17485]: IOError: [Errno 13] Permission denied: '/opt/moviegrabber/configs/config.ini'
May 20 04:24:26 ArchApplianceVM_v3 systemd[1]: moviegrabber.service: main process exited, code=exited, status=1/FAILURE
May 20 04:24:26 ArchApplianceVM_v3 systemd[1]: Unit moviegrabber.service entered failed state.

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » May 20th, 2014, 4:15 am

hmm ok i can see why its failing but i dont understand why the permissions are not set correctly, basically the issue is it doesnt have permissions to create the config.ini file:-

IOError: [Errno 13] Permission denied: '/opt/moviegrabber/configs/config.ini'

can you do the following, "ls -al /opt/moviegrabber" and paste me the directory listing result, i want to see if its correctly set the permissions or not, im assuming not, also can you run "cat /etc/passwd" and "groups moviegrabber" this should show the users and groups defined, there should be a user moviegrabber and a group moviegrabber.

also grasping at straws here but you did re-download the pkg file right?, as this has been modified.

binhex
Sr. Member
Sr. Member
Posts: 470
Joined: December 5th, 2008, 11:54 am

Re: MovieGrabber - Completely Automated Movie Downloader

Post by binhex » May 23rd, 2014, 1:35 pm

Just in case you guys didn't spot it there is new version released, should be visible in the ui at the bottom.

splnut
Newbie
Newbie
Posts: 35
Joined: February 21st, 2011, 8:46 pm

Re: MovieGrabber - Completely Automated Movie Downloader

Post by splnut » May 25th, 2014, 12:22 am

I just revisited this issue and all is fine now. Not sure what was going on. Thanks for all the support and awesome work....Now I'm just waiting on a new hard drive to replace my failing parity drive.

Post Reply