Synology DSM 5.0-4458 safe to upgrade ?

Get help with all aspects of SABnzbd
Forum rules
Help us help you:
  • Are you using the latest stable version of SABnzbd? Downloads page.
  • Tell us what system you run SABnzbd on.
  • Adhere to the forum rules.
  • Do you experience problems during downloading?
    Check your connection in Status and Interface settings window.
    Use Test Server in Config > Servers.
    We will probably ask you to do a test using only basic settings.
  • Do you experience problems during repair or unpacking?
    Enable +Debug logging in the Status and Interface settings window and share the relevant parts of the log here using [ code ] sections.
Post Reply
Hanzen
Newbie
Newbie
Posts: 4
Joined: March 12th, 2014, 5:34 am

Synology DSM 5.0-4458 safe to upgrade ?

Post by Hanzen » March 12th, 2014, 5:38 am

Before installing the new DSM version, i would like to know if there are any problems re. SABnzbd installed on my DS212j

Tscherno
Newbie
Newbie
Posts: 7
Joined: July 25th, 2010, 7:16 am

Re: Synology DSM 5.0-4458 safe to upgrade ?

Post by Tscherno » March 12th, 2014, 3:32 pm

Beta was fine, but the final broke sab: it doesnt unrar anymore.

Nonil
Newbie
Newbie
Posts: 1
Joined: March 16th, 2014, 2:46 pm

Re: Synology DSM 5.0-4458 safe to upgrade ?

Post by Nonil » March 16th, 2014, 3:01 pm

Synology DSM 5.0-4458 uses unrar v5.01 and the current SABnzbd 0.7.16-7 from synocommunity is not really capable of v4 and v5 Password extraction.

Solution:

Go to your 'newsunrar.py' in /usr/local/sabnzbd/share/SABnzbd/sabnzbd and search for:

Code: Select all

    elif 'ncrypted file' in line and 'CRC failed' in line:
            # unrar 4.x syntax
and replace it all with:

Code: Select all

      elif 'The specified password is incorrect' in line or \
             ('ncrypted file' in line and (('CRC failed' in line) or ('Checksum error' in line))):
            # unrar 3.x: "Encrypted file: CRC failed in oLKQfrcNVivzdzSG22a2xo7t001.part1.rar (password incorrect ?)"
            # unrar 4.x: "CRC failed in the encrypted file oLKQfrcNVivzdzSG22a2xo7t001.part1.rar. Corrupt file or wrong password."
            # unrar 5.x: "Checksum error in the encrypted file oLKQfrcNVivzdzSG22a2xo7t001.part1.rar. Corrupt file or wrong password."
            # unrar 5.01 : "The specified password is incorrect."
This workaround is taken from 'newsunpack.py' of 0.7.17RC1 and I've found the hint/solution here http://forums.sabnzbd.org/viewtopic.php?f=3&t=16166

Unpack of password files with DSM 5.0-4458 and 0.7.16-7 from synocommunity is working for me again like a charme. I've not tested it with Password in nzb filename but in pass.txt its working fine.

Hope this helps the Syno users a bit.
regards
Nnl

Tscherno
Newbie
Newbie
Posts: 7
Joined: July 25th, 2010, 7:16 am

Re: Synology DSM 5.0-4458 safe to upgrade ?

Post by Tscherno » March 16th, 2014, 3:03 pm

I've updated to the latest beta of sab. That also solved the issue.

scheuri
Newbie
Newbie
Posts: 3
Joined: March 18th, 2014, 4:31 am

Re: Synology DSM 5.0-4458 safe to upgrade ?

Post by scheuri » March 18th, 2014, 4:46 am

So I take it with version 0.7.17 is it "safe" to update to DSM 5.0 without the manual changes (which are very good described anyhow)?

Hanzen
Newbie
Newbie
Posts: 4
Joined: March 12th, 2014, 5:34 am

Re: Synology DSM 5.0-4458 safe to upgrade ?

Post by Hanzen » March 20th, 2014, 5:39 am

Back in november 2013 I changed unrar from /usr/local/sabnzbd/bin/unrar (5.0) to /usr/syno/bin/unrar ( 3.8 ) due to the password problem.

Does this still work or do I get 5.0 back ? If 5.0 is back, does it work now ?

Post Reply