Page 1 of 1

SABnzbd repeated crashing: "Fatal error in Assembler"

Posted: May 5th, 2022, 11:56 pm
by delboy
I s tarted yesterday having problems with SABnzb crashing and restarting. It would stay up for a minute or so then restart. It does this over and over. I had this problems tarting with 3.5.3. I went back to earlier and earlier versions. I went back to 3.5.2, same problem. Then I went back to 3.5.1 and still same problem. When I went back to 3.5.0 it worked normaly. Each time, I got this error message where the queue normally shows.

Fatal error in Assembler
Traceback (most recent call last):
File "/usr/share/sabnzbdplus/sabnzbd/", line 166, in run
nzo.handle_par2(nzf, filepath)
File "/usr/share/sabnzbdplus/sabnzbd/", line 36, in call_func
return f(*args, **kw)
File "/usr/share/sabnzbdplus/sabnzbd/", line 1059, in handle_par2
if pack not in self.md5packs.values():
AttributeError: 'NoneType' object has no attribute 'value

I have kubuntu 20.04 on a Dell Optiplex 7010 with 32GB RAM. If you want to see sabnzbd.lof it's at

Any idea what's going on? thanks

Re: SABnzbd repeated crashing.

Posted: May 6th, 2022, 1:22 am
by sander
I don't see the Fatal error nor traceback in your log?

Does this only happen with this download, or also others, or all downloads?

Re: SABnzbd repeated crashing: "Fatal error in Assembler"

Posted: May 6th, 2022, 11:53 am
by safihre
You have temporarily used 3.6.0 and then tried to go back to 3.5.3.
You need to shutdown Sabnzbd and remove all files from your incomplete folder. Yes, this will kill the queue but there's no way around it.
If that doesn't work, you also need to remove queue.sab and postproc.sab from the location of your sabnzbd.ini.